Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th January 2007, 05:19
sethtat sethtat is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default [Debian Sarge] Installing A Bind9 Master/Slave DNS System Configuration Help

AM VERY NEW TO LINUX AND BIND

I have setup two debian boxes using the The Perfect Setup - Debian Sarge (3.1)

on both and then used the master/slave setup. I am getting an error when is restart the bind services on both servers

the error is "Stopping domain name service: namedrndc: connect failed: connection refused"
and then it tries to start the services and gives no error


I have attached my two named.conf files from the master and slave.

These are the last part of the files that I changed.

Please help me get this up and running

domain - friendswd.net
master 72.16.90.178
slave 72.16.90.179

the master is my web and email server also

i am going to install a hosting controll panel. I have been using ravencore

It seems to work

If anyone has any suggestions on which one to use please let me know
Attached Files
File Type: txt master.txt (1.2 KB, 253 views)
File Type: txt slave.txt (1.5 KB, 235 views)
Reply With Quote
Sponsored Links
  #2  
Old 16th January 2007, 09:31
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

You made a mistake somewhere in you DNS setup:
Code:
;; ANSWER SECTION:
friendswd.net.          10800   IN      A       82.165.133.52
Code:
;; ANSWER SECTION:
178.90.16.72.in-addr.arpa. 86392 IN     PTR     h178.90.16.72.ip.alltel.net.
The domain and IP do not point to each other.
Reply With Quote
  #3  
Old 18th January 2007, 05:25
sethtat sethtat is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I do not even have the registar pointing to my dns server's yet
I am trying to get them working first without errors.
Reply With Quote
  #4  
Old 18th January 2007, 22:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

Quote:
Originally Posted by sethtat
the error is "Stopping domain name service: namedrndc: connect failed: connection refused"
and then it tries to start the services and gives no error
I think it's a permissions problem, as some people pointed out in the comments below http://www.howtoforge.com/howto_bind_chroot_debian .
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
Bind9 Master/Slave DNS System zimele Installation/Configuration 13 11th December 2006 14:43
Help with DNS configuration (understanding DNS setup) jimjawn Installation/Configuration 1 3rd May 2006 16:43
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 20:29
DNS Zone file configuration Commdude Installation/Configuration 7 20th March 2006 03:02


All times are GMT +2. The time now is 18:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.