Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th January 2007, 21:17
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default ISPC move to port 80 on dedicated IP, but now ISPC complains Apache down

Ubuntu 6.10, ISPConfig 2.2.9 mostly according to the Howto's.

I allocated a specific IP to ISPConfig and used the tricks to have ISPConfig running on port 80. That works nicely, including Squirrelmail and phpMyadmin. https on port 80 on a dedicated IP (172.16.3.79).

I added all IP's in the /etc/network/interface file:
Code:
auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
        address 172.16.3.75
        netmask 255.255.255.0
        network 172.16.3.0
        broadcast 172.16.3.255
        gateway 172.16.3.254
auto eth0:0
iface eth0:0 inet static
        address 172.16.3.76
        netmask 255.255.255.0
        network 172.16.3.0
        broadcast 172.16.3.255
        gateway 172.16.3.254
auto eth0:1
iface eth0:1 inet static
        address 172.16.3.77
        netmask 255.255.255.0
        network 172.16.3.0
        broadcast 172.16.3.255
        gateway 172.16.3.254
auto eth0:2
iface eth0:2 inet static
        address 172.16.3.78
        netmask 255.255.255.0
        network 172.16.3.0
        broadcast 172.16.3.255
        gateway 172.16.3.254
auto eth0:3
iface eth0:3 inet static
        address 172.16.3.79
        netmask 255.255.255.0
        network 172.16.3.0
        broadcast 172.16.3.255
        gateway 172.16.3.254
and added the 75-78 addresses in the panel under Management->Server->Settings in the textbox IP list. I entered the 79 address IP address in the hostname block. This results in ISPConfig complaining the webserver is not running. Writing this down, I come to think I need to remove the 79 address and just use e.g. 75 and remove from the IP List.

Checking ...... Testing .......

Nope, but the error became clear. Running manually the check script gives:
Code:
~# /root/ispconfig/php/php /root/ispconfig/scripts/shell/check_services.php

Warning: fsockopen(): unable to connect to localhost:80 (Connection refused) in /root/ispconfig/scripts/shell/check_services.php on line 92

Warning: fsockopen(): unable to connect to localhost:80 (Connection refused) in /root/ispconfig/scripts/shell/check_services.php on line 92
Any suggestion?
Reply With Quote
Sponsored Links
  #2  
Old 11th January 2007, 21:30
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Arrow Fixed by second look

Have to answer myself ......

As I changed apache to listen only on specific IP's, it's not listening on localhost. Adding 127.0.0.1 to /etc/apache2/ports.conf makes it all working again.
Code:
~# cat /etc/apache2/ports.conf
Listen 127.0.0.1:80
Listen 172.16.3.75:80
Listen 172.16.3.76:80
Listen 172.16.3.77:80
Listen 172.16.3.78:80
Listen 127.0.0.1:443
Listen 172.16.3.75:443
Listen 172.16.3.76:443
Listen 172.16.3.77:443
Listen 172.16.3.78:443
Great panel though. I should not want to do specific modifications ......
Reply With Quote
  #3  
Old 12th January 2007, 03:02
horus.solaris horus.solaris is offline
Junior Member
 
Join Date: Nov 2006
Location: Dublin, Ireland
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Post how?

Hi martinfst !

Is there a how-to or thread with those tricks how to get the ISPConfig running on port 80 ?

Thx!

HS
Reply With Quote
  #4  
Old 12th January 2007, 09:51
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
 
Default

The tricks are all documented in these forums. Maybe I combined a few here and there, but essentially it's all there. See http://www.howtoforge.com/forums/showthread.php?t=4829 for the essentials I used.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 17:33
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 01:45
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 23:40
Moving Apache to another port DrAgOOn Installation/Configuration 2 16th September 2005 12:14


All times are GMT +2. The time now is 01:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.