Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd October 2005, 16:33
onoxsis onoxsis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Red face No login access by http or https

Hi first off i am a linux newbie:

The problem i am having is being able to access the ispconfig web page using the domain name, i can access it fine using the ip address.

I have double checked just to make sure port 81 wasn't being blocked and just to be sure changed the port to 8080.

When i acccess the webpage using the ip address most of the tabs don't work and timeout. such as in the management tab.

when running through the install: i did provide a host name: www
and then the domain name and i chose https.

i have installed/unistalled about 7 times now and still can't get this to work

need help!

Thankyou.
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2005, 16:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You have to make sure that the domain name you provided during the installation resolves to your ISPConfig box. If it doesn't you can also use the IP address during the installation (leave the host name empty and enter the IP address as domain name). But before you do another install: you can change this in the file /home/admispconfig/ispconfig/lib/config.inc.php.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd October 2005, 17:13
onoxsis onoxsis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

okay in this file: /home/admispconfig/ispconfig/lib/config.inc.php.
do i just go to the same line that i changed the port number to
and remove the domain name and replace with the machines ip address?
Reply With Quote
  #4  
Old 22nd October 2005, 17:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Yes, you can use an IP or Domain pointing to your server.
Reply With Quote
  #5  
Old 22nd October 2005, 19:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

It's the $go_info["server"]["server_url"] line.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd October 2005, 07:57
onoxsis onoxsis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Still didn't work

okay here is my settings: $go_info["server"]["server_url"] = "https://172.32.1.67:8080";

I can access the webpage fine but some links in management for eg:

click settings: https://172.32.1.67:8080/172.32.1.67
:8080/multidoc/edit/edit.php?doc_id=1&doctype_id=1010&

and get the following: Page cannot be displayed in ie and in mozilla firefox:

Not Found
The requested URL /172.32.1.67:8080/multidoc/edit/edit.php was not found on this server

Any other ideas?, i can't figure out what i am doing wrong!
Reply With Quote
  #7  
Old 23rd October 2005, 13:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Please send the complete file /home/admispconfig/ispconfig/lib/config.inc.php to t.brehm [at] ispconfig [dot] org and i will have a look on it. Before you send it please replace the mysql password inside with some xxx'es
Reply With Quote
  #8  
Old 24th October 2005, 04:22
onoxsis onoxsis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Email Sent

Hi okay i have sent you the file. Thankyou for helping me with this i really appreciate it.
Reply With Quote
  #9  
Old 24th October 2005, 10:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by onoxsis
Hi okay i have sent you the file. Thankyou for helping me with this i really appreciate it.
I've checked your config file, in the URL is one slash missing:

$go_info["server"]["server_url"] = "https:/172.32.1.67:8080";

Correct URL:

$go_info["server"]["server_url"] = "https://172.32.1.67:8080";
Reply With Quote
  #10  
Old 24th October 2005, 11:13
onoxsis onoxsis is offline
Junior Member
 
Join Date: Oct 2005
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default OMG Shoot me NOW!!!!!!!!!!!!!!!!!!!!!!!!

I can't believe i missed the most obvious syntax error, this goes to show that even a simple error like this can go unoticed.

Everything is up and working! now for step 2 trying to get it to work with the domain name.

Thankyou so much for the help!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
From HTTP to HTTPS fastcooler Installation/Configuration 4 15th April 2006 15:43
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 18:45
FTP access? ctroyp Installation/Configuration 14 29th September 2005 17:26
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28
Change from https to http after install hagel Installation/Configuration 4 22nd August 2005 17:14


All times are GMT +2. The time now is 00:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.