Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd October 2005, 01:01
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Removed PostFix, Now MySql Problems!!!

Please help.

I decided to reinstall postfix to hopefully solve a problem i had with it.

i done an

apt-get remove postfix

then

apt-get install postfix

when it went to remove postfix it shutdown msyqld

and now Mysql isnt working!!! what have i done!???? what can i do>?
Reply With Quote
Sponsored Links
  #2  
Old 23rd October 2005, 01:01
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I cant even find mysqld! or run it... is everything lost?

[edit]
Well, I now know that everything is not lost. My Mysql folder is still there and I found all the tables and databases in there. But Mysqld is nowhere to be found and of course it is not running.

So everything on my server is just sitting still. Please tell me how to get mysqld back up and running (or installed) and how to restore the databases - if i need to.
[/edit]

Last edited by sapient; 23rd October 2005 at 02:01.
Reply With Quote
  #3  
Old 23rd October 2005, 14:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Does /etc/init.d/mysql exist? If so, run
Code:
/etc/init.d/mysql start
to start MySQL.

If not, run
Code:
apt-get install mysql-server mysql-client libmysqlclient12-dev
to re-install MySQL.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 23rd October 2005, 16:02
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

etc/init.d/mysql is there, but when i:

Code:
/etc/init.d/mysql start
nothing happens.
Reply With Quote
  #5  
Old 23rd October 2005, 16:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Did you get any errors in the syslog or in the mysql log?
Reply With Quote
  #6  
Old 23rd October 2005, 16:16
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

mysql logs are empty
and syslog doesnt seem to catch anything when I try to run or stop or restart mysql
Reply With Quote
  #7  
Old 23rd October 2005, 16:31
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried to apt-get install but i keep getting the error

Quote:
Could not resolve 'mirrors.kernel.org'
Strange considering my other computers on the Lan can reach it. If I do an nslookup with my server it is showing 192.26.92.30 as the ip. I suppose there are more problems than just mysql. Perhaps a complete reinstall will fix (Debian & Ispconfig)?
Reply With Quote
  #8  
Old 23rd October 2005, 18:37
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Reinstall is going fine- no worries now. thx for the great how-to's
Reply With Quote
  #9  
Old 23rd October 2005, 21:23
sapient sapient is offline
Junior Member
 
Join Date: Jul 2005
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache2 default page

Ive got it all back up and running smooth except:

whenever i goto one of my sites it goes to the apache2_default directory and displays the default apache2 index page.

What do i need to change to fix this? (my sites are all there with their pages, but I cant see them because apache automatically re-routes me)
Reply With Quote
  #10  
Old 23rd October 2005, 21:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

You will see this behaviour when an vhost can not be found or has the wrong IP address.

If you are in a NAT enviroment, your websites must have private IP's assigned.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with postfix vervem Installation/Configuration 5 27th March 2008 20:40
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 17:37
postfix problems. jernis Installation/Configuration 2 16th September 2005 22:14
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 10:41
Mysql ejs Installation/Configuration 5 12th August 2005 08:01


All times are GMT +2. The time now is 04:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.