Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th January 2007, 14:01
Herbert Herbert is offline
Member
 
Join Date: May 2006
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Default Redirect question {SERVERNAME} for webmail

In /root/ispconfig/isp/conf/vhost.conf.master i put this:
Redirect /webmail "https://{SERVERNAME}:81/webmail"

The problem is i get in my vhost.conf
Redirect /webmail "https://domainname.tld:80:81/webmail"

How can i get: Redirect /webmail "https://domainname.tld:81/webmail"

I don't know all the vrariables from ISPConfig, i try everything but no result.
Reply With Quote
Sponsored Links
  #2  
Old 7th January 2007, 15:15
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

You're editing the wrong configuration file. You should redirect your main web server to the ISPConfig server. I'm working on something similar, but still struggling with the rewrite rules, as I have a more complex setup. I require several different rewite rules, and currently they interfere.

But if someone has a good suggestion ......

Last edited by martinfst; 7th January 2007 at 20:27.
Reply With Quote
  #3  
Old 7th January 2007, 18:42
Herbert Herbert is offline
Member
 
Join Date: May 2006
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, but i need it also for more than 50 differend domains, a redirect to the webmail for one domain is verry simple.
Every virtualhost must have a own rewrite rule or redirect.
Reply With Quote
  #4  
Old 8th January 2007, 01:00
Clogboy Clogboy is offline
Junior Member
 
Join Date: Mar 2006
Location: Sydney, Australia
Posts: 19
Thanks: 0
Thanked 1 Time in 1 Post
Default

Why don't you put:

Redirect /webmail "https://domainname.tld:81/webmail"

in /etc/apache2/apache2.conf? That way one entry will work for all domains.
Reply With Quote
  #5  
Old 8th January 2007, 09:12
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Redirect is, as is says, a redirect. It's not a proxy. It means, you need to be able to access port 81 on your client, which may well be blocked in a large corporate network..
Sometimes Internet access is restricted on such corporate networks and you want to access your webmail over a regular port 80, which is normally not closed down. Hence the reason to use rewrite/proxy and no redirect. This post still does not answer the OP

Last edited by martinfst; 8th January 2007 at 10:05.
Reply With Quote
  #6  
Old 8th January 2007, 10:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

To the original post from Herbert:

There is no such variable without the part appended. If you need this variable, you will have to create your own and add it to the make_vhost function in the file /root/ispconfig/scripts/lib/config.lib.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 10th January 2007, 00:27
Herbert Herbert is offline
Member
 
Join Date: May 2006
Posts: 56
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
To the original post from Herbert:

There is no such variable without the part appended. If you need this variable, you will have to create your own and add it to the make_vhost function in the file /root/ispconfig/scripts/lib/config.lib.php
Ok thanks, i have done..

// Variablen zuweisen
$mod->tpl->assign( array( SERVERNAME => $servername.$web_port,
IP => $web["web_ip"].$web_port,
SERVERNAME1 => $servername,
DOCUMENTROOT => $document_root,
SERVERALIAS => $serveralias,

I get with {SERVERNAME1} the domainname without :81
In the file vhost.conf.master i put:
Redirect /webmail "https://{SERVERNAME1}:81/webmail"
Its works..
But a redirect is not good, i need i Rewrite Rule
The rewrite rule must working from http to https and nothing works.
Reply With Quote
  #8  
Old 10th January 2007, 11:05
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by Herbert
But a redirect is not good, i need i Rewrite Rule
The rewrite rule must working from http to https and nothing works.
To rewrite http to https appears to be a bad idea. I have the same route investigated yesterday, but it has lead me nowhere. Also https --> https rewrite seems to be a bad idea according to several hits I got in Google. It may lead to middleman attacks. So I have decided to run ISPConfig on a dedicated IP and modify it to run on port 80. That will also run Squirrelmail/phpMyAdmin on port 80. But remember it is SSL over port 80 .
ISPConfig will use the other IP addresses on my server. There's a thread in these forums somewhere, but it seems I'm unable to track that now.
Reply With Quote
  #9  
Old 10th January 2007, 11:11
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by martinfst
There's a thread in these forums somewhere, but it seems I'm unable to track that now.
A good suggestion is http://www.howtoforge.com/forums/showthread.php?t=157
Reply With Quote
  #10  
Old 11th January 2007, 01:13
richjam000 richjam000 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I've had some success using http proxy stuff.

ie: say this is my URL for ispconfig: https://www.fred.com:81
I then setup a new SSL vhost ( https://www.bill.com) containing this:
SSLProxyEngine On
ProxyPreserveHost On
ProxyPass /ispconfig https://www.fred.com:81/
ProxyPassReverse /ispconfig https://www.fred.com:81/
ProxyPass /design https://www.fred.com:81/design/
ProxyPassReverse /design https://www.fred.com:81/design/
ProxyPass /squirrelmail https://www.fred.com:81/squirrelmail/
ProxyPassReverse /squirrelmail https://www.fred.com:81/squirrelmail/

Not really sure what Im doing ! - just copying something I did when setting
up ntop.

With the above set-up ispconfig seems to work just fine - ie: over port 80,
proxied to port 81. - via https://www.bill.com/ispconfig/

However the squirrelmail doesnt quite work - once I've logged in to
squirrelmail ( via https://www.bill.com/squirrelmail. ), I see my mail OK but
the URL , annoyingly , changes to :
https://www.bill.net:81/squirrelmail//src/webmail.php
ie: seems to go back to port 81.

Bit stuck now - maybe someone can take this forward ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading Dapper to Edgy with aptitude dist-upgrade roolet Installation/Configuration 8 2nd November 2006 14:10
Odd question for Falko Randy Installation/Configuration 1 16th October 2006 14:58
Upgrade to 2.2.6 puts # Redirect # NOT SUPPORTED ppettigrew Installation/Configuration 3 29th September 2006 10:52
Can you advice for Redirect and web home name? datayoung Installation/Configuration 6 13th August 2006 19:44
Routing question virtual machines geek.de.nz Server Operation 1 2nd July 2006 18:13


All times are GMT +2. The time now is 04:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.