Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st October 2005, 16:41
boombari boombari is offline
Junior Member
 
Join Date: Sep 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default php don't work ! :(

hi,

i have installed on perfect suse 9.3 ISPConfig 2.1.0 ...create one reseller, one user and one domain ...
i'm trying to install maxdev or typo3 via FTP ...but all php pages doesn't display nothing ...how can i do ?
Reply With Quote
Sponsored Links
  #2  
Old 21st October 2005, 17:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Have you checked the php checkboxes in the settings of this site?

Save the following content as info.php file in the website and call it in a browser.

<?php
phpinfo();
?>


Does the page show the version and configuration of your PHP?
Reply With Quote
  #3  
Old 21st October 2005, 17:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Also have a look at the test files: http://www.howtoforge.com/forums/showthread.php?t=171
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 21st October 2005, 17:29
boombari boombari is offline
Junior Member
 
Join Date: Sep 2005
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

in attachment my phpinfo
Attached Files
File Type: zip phpinfo().zip (10.3 KB, 352 views)
Reply With Quote
  #5  
Old 21st October 2005, 17:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
Default

Thats fine so far. PHP is running and configured properly. Are you shure you uploaded the files to the correct location?

You must upload the into the "web" folder as Administrator user of this website. Please check on the shell if the files are uploaded to the correct location and belong to the correct user (admin of this website) and group (group of this website).
Reply With Quote
  #6  
Old 21st October 2005, 18:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Did you activate "PHP Safe Mode"? If so, disable it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st October 2005, 18:57
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

On my server, the hello_world.pl file does not load properly.

There is a 403 Error - Forbidden error.

How do I fix this?
Reply With Quote
  #8  
Old 21st October 2005, 19:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by kisong
On my server, the hello_world.pl file does not load properly.

There is a 403 Error - Forbidden error.

How do I fix this?
Did you upload hello_world.pl to the cgi-bin directory and made a chmod 755 on it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 21st October 2005, 19:20
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

Now there is a 500 error. I did chmod 755 ...

Quote:
Originally Posted by falko
Did you upload hello_world.pl to the cgi-bin directory and made a chmod 755 on it?
Reply With Quote
  #10  
Old 21st October 2005, 21:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,334 Times in 4,184 Posts
 
Default

Have you uploaded it with linux linebreaks?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
PHP not working jefash General 10 28th May 2006 08:48
Cannot compile new PHP with apxs olli Installation/Configuration 11 4th March 2006 15:32
double apache installation (with php) aolex Installation/Configuration 3 19th October 2005 17:04
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 10:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.