#1  
Old 3rd January 2007, 16:33
cvenom96 cvenom96 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default dns troubles

I'm running Ubuntu 6.10 using ISPConfig. I followed the tutorial here http://www.howtoforge.com/perfect_setup_ubuntu_6.10. I set this up on two machines and I had no problems getting into ispconfig. I then worked through this tutorial on running my own dns servers http://www.howtoforge.com/ispconfig_dns_godaddy with the only exception being I am not using godaddy as my registrar. After an initial goof of running the primary and secondary servers on the same machine, I was able to run dig @ns1.hostmyvids.com any hostmyvids.com and here are my results:

; <<>> DiG 9.3.2 <<>> @ns1.hostmyvids.com any hostmyvids.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 47023
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;hostmyvids.com. IN ANY

;; ANSWER SECTION:
hostmyvids.com. 86400 IN SOA ns1.hostmyvids.com. admin.hostmyvids.com. 2007010205 28800 7200 604800 86400
hostmyvids.com. 86400 IN NS ns1.hostmyvids.com.
hostmyvids.com. 86400 IN NS ns2.hostmyvids.com.
hostmyvids.com. 86400 IN MX 10 mail.hostmyvids.com.
hostmyvids.com. 86400 IN A 72.151.8.188

;; ADDITIONAL SECTION:
mail.hostmyvids.com. 86400 IN A 72.151.8.188

;; Query time: 12 msec
;; SERVER: 72.151.8.189#53(72.151.8.189)
;; WHEN: Wed Jan 3 07:59:04 2007
;; MSG SIZE rcvd: 163

However, I am not consistently able to dig these records. I was just able to run dig @ns1.hostmyvids.com any www.hostmyvids.com and got some info back but, when I tried using mail.hostmyvids.com, I got ; <<>> DiG 9.3.2 <<>> @ns1.hostmyvids.com any mail.hostmyvids.com

; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached

Any ideas as to why it is sporadically working?
Reply With Quote
Sponsored Links
  #2  
Old 3rd January 2007, 16:56
cvenom96 cvenom96 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just wanted to mention that it has only been about 24 hours since I got the name servers changed with the registrar. Maybe about 12 hours since I got things straightened out on my dns servers.
Reply With Quote
  #3  
Old 4th January 2007, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

It's still not working:

Code:
mh1:~# dig hostmyvids.com

; <<>> DiG 9.2.1 <<>> hostmyvids.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 16596
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;hostmyvids.com.                        IN      A

;; Query time: 179 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Thu Jan  4 15:27:59 2007
;; MSG SIZE  rcvd: 32

mh1:~# dig ns hostmyvids.com

; <<>> DiG 9.2.1 <<>> ns hostmyvids.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 27313
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;hostmyvids.com.                        IN      NS

;; Query time: 290 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Thu Jan  4 15:28:05 2007
;; MSG SIZE  rcvd: 32

mh1:~# dig any hostmyvids.com

; <<>> DiG 9.2.1 <<>> any hostmyvids.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 7392
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;hostmyvids.com.                        IN      ANY

;; Query time: 124 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Thu Jan  4 15:28:14 2007
;; MSG SIZE  rcvd: 32
I think the problem is that you need a glue record: http://en.wikipedia.org/wiki/Dns#Cir...d_glue_records
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 4th January 2007, 16:50
cvenom96 cvenom96 is offline
Junior Member
 
Join Date: Jan 2007
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks I'll try that.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS Configuration Problems VMartins Installation/Configuration 10 24th July 2007 15:40
IP and DNS Setup troubles nightsbird Installation/Configuration 19 29th August 2006 21:50
Using a different DNS server with Dynamic DNS CombatGod Installation/Configuration 1 11th May 2006 18:43
Pri & Slave DNS HOWTO (FC4) ppettigrew Suggest HOWTO 0 1st April 2006 16:35
Reverse DNS disasm General 3 13th January 2006 20:43


All times are GMT +2. The time now is 11:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.