Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th December 2006, 20:39
netphreak netphreak is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default Debian 3.1 & ISPConfig, perfect setup, but redirected to apache2-default

I have followed the guide for perfect setup with Debian Sarge 3.1. But when I add sites in ISPConfig, they point to 'apache2-default', not the userdirectory which is being created.

Since I am a newbie in Linux (sorry), I don't know how to fix this. But I have an idea on what might be a reason for this problem:

My ISP gives me a /29 subnet, so I have 5 available public static IP's. I used one of these IP's when installing, instead of a local subnet address like in the guide (192.168.0.100 or whatever).

Could this be the problem?
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2006, 20:43
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

Which settings do you have within ISPConfig under Management > Server > Settings ?
__________________
Hans

MrHostman | Master in managed hosting
Reply With Quote
  #3  
Old 29th December 2006, 20:50
netphreak netphreak is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Server Name: Server 1

Hostname: www
Domain: 80.200.100.36
IP Address: 80.200.100.36
Netmask: 255.255.255.0
Admin Email: root@localhost

IP List:
Reply With Quote
  #4  
Old 29th December 2006, 21:05
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Default

You can change it into:

Server Name: Server 1

Hostname: www
Domain: yourdomain.com *
IP Address: 80.200.100.36
Netmask: 255.255.255.0
Admin Email: username@mydomain.com **

* = your domain name of your server.
For example, if your full qualified domain name is: server1.mydomain.com, you should use here: yourdomain.com
Make sure that the mentioned IP Address belongs to that domain name.

** = you can change this into the emailaddress of the ISPConfig system administrator. (root@localhost is the default emailaddress within this field of ISPConfig).

Within the IP List, you can add the IP-addresses which you've received from your provider. This is uselful, if a domain needs its own IP-address.

I think these tips are useful to you as you have more than one IP available, however, i do not think that this will solve your problem.
__________________
Hans

MrHostman | Master in managed hosting

Last edited by Hans; 30th December 2006 at 11:53.
Reply With Quote
  #5  
Old 30th December 2006, 10:49
netphreak netphreak is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No, you where right - it didn't solve any problems. But I figured it out. My domain names where pointed to one of my other IP addresses, so I changed the IP address of my Debian box. From *36 to *34. But it wasn't enough to change the /etc/network/interfaces file. I deleted all my entries in the ISPConfig controlpanel, and added them again. It works

But, there's still problems: When I try to access my https://www.domain.dom:81/mailuser, I can see that I am being redirected to that original *36 address. And I can not find where this should be changed! Ideas?
Reply With Quote
  #6  
Old 30th December 2006, 11:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

It would have been enough if you selected the new IP address for the websites in ISPConfig and save them.

Quote:
But, there's still problems: When I try to access my https://www.domain.dom:81/mailuser, I can see that I am being redirected to that original *36 address. And I can not find where this should be changed! Ideas?
Have you changed the domain name under management > server > settings and in the file /home/admispconfig/ispconfig/lib/config.inc.php ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 30th December 2006, 12:19
netphreak netphreak is offline
Junior Member
 
Join Date: Dec 2006
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Ah - editing /home/admispconfig/ispconfig/lib/config.inc.php did the trick Sorry I didn't see that line...

Thank you for excellent support - I love ISPConfig and these forums
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about the The Perfect Setup - Debian Sarge (3.1) page 3 paulley Installation/Configuration 2 1st December 2006 01:33
The Perfect Setup - Debian Sarge (3.1) "quote problem" crow HOWTO-Related Questions 5 29th April 2006 17:42
Problems with saslauthd - Debian Perfekt setup 3.1 + ISPConfig r12dk Installation/Configuration 6 14th April 2006 00:07
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 22:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.