Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th December 2006, 00:35
LuisC-SM LuisC-SM is offline
Member
 
Join Date: Apr 2006
Location: Webland, Mexico
Posts: 32
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation How To Compile A Kernel - The SuSE Way- Errors

Hi Folks.

First off I'd like to say I wish You all had a nice Christmas time along with your beloved friends and family.

I have a Toshiba Satellite P105 SP921 which has a sound issue on SLED 10 and Ubuntu 6.10 (just works with acpi=off) and I've been trying to solve this since 10 days or so with no joy. However, during this long long research, I've found in some posts that using the latest prepatch kernel cuold solve some problems and that's what I've been trying to do.

So I've followed this tutorial and when trying to apply the patch it's giving me some errors and asks me things, I don't really understand. I'm not exactly a noob in linux but also I'm not a programmer or coder, just use it because I really like it over any other platform.

So, when I run "bzip2 -dc /usr/src/patch-2.6.20-rc2.bz2 | patch -p1 --dry-run" in /usr/src/linux, I get
Quote:
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/.gitignore b/.gitignore
|index 9eb4b77..060a71d 100644
|--- a/.gitignore
|+++ b/.gitignore
--------------------------
File to patch:
linux:/usr/src # cd linux
linux:/usr/src/linux # bzip2 -dc /usr/src/patch-2.6.20-rc2.bz2 | patch -p1 --dry-run
patching file .gitignore
Hunk #1 FAILED at 42.
1 out of 1 hunk FAILED -- saving rejects to file .gitignore.rej
patching file CREDITS
Reversed (or previously applied) patch detected! Assume -R? [n]
and then I don't know what to answer in this point so I just give it <Ctrl>+C to abort.

I assume I followed everything as it's explained in the Howto. I'm using linux-2.6.19.tar.bz2 kernel and the patch-2.6.20-rc2.bz2 patch.

Any ideas on what I'm doing wrong?

Kind Regards

Luis C. Suárez

EDIT: Sorry but I missed the correct forum, so please admin, be so kind to move it to the right place in case it applies. TIA
__________________
Humility is not a "Status"...
It's a "Gift"!

Last edited by LuisC-SM; 26th December 2006 at 00:43.
Reply With Quote
Sponsored Links
  #2  
Old 26th December 2006, 17:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by LuisC-SM
Reversed (or previously applied) patch detected! Assume -R? [n]
Did you apply another patch before you tried this one?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st December 2006, 12:37
Freibier Freibier is offline
Junior Member
 
Join Date: Dec 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default 2.6.19.1?

Hi, if found this thread because i had a similar problem :-)
I tried to patch kernel 2.6.19.1 which obviously wasn't the right way.
from www.kernel.org concerning patches:
----------------------------------------------------------------------------------------------------------
They should be applied using the patch(1) utility to the source code of the previous full release with a 3-part version number (for example, the 2.6.12-rc4 prepatch should be applied to the 2.6.11 kernel sources, not, for example, 2.6.11.10.)
----------------------------------------------------------------------------------------------------------
LuisC-SM, maybe you applied the 2.6.19.1 patch to 2.6.19 ?
If so, you can do a "patch -R" with the 2.6.19.1-patch to downgrade to 2.6.19.
After that, the patch-2.6.20-rc2 applies smoothly.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Xen 3.0.2 /3.0.3 | No Swap in DomU Merc HOWTO-Related Questions 10 27th March 2007 11:40
Fedora Core 5 - Server not responding kyriakos Installation/Configuration 13 16th November 2006 14:16
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02
Questions about ubuntu ISP-Server Setup badgerbox76 HOWTO-Related Questions 15 5th March 2006 14:41


All times are GMT +2. The time now is 08:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.