#1  
Old 22nd December 2006, 04:52
BlueStream BlueStream is offline
Member
 
Join Date: Oct 2005
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Default UebiMiau Time bug?

Code:
:: [F]usion[S]tream :: -- G...  	test at 11.37am  	22/12/06 03:37
Time stamp is wrong here..
Time stamp is correct in squirrelmail..
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2006, 11:49
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

Try This:

Ok If you are using a 64bit system this is what you will need to do in order to make the time and date work on the we interface to Ubeimiau.

Go to this file:

home/admispconfig/ispconfig/web/webmail/smarty/smarty.addons.php

and find the function smarty_make_timestamp($string)

if(empty($string)) {
$string = "now";
}else if(is_numeric($string)) {
return (int)$string;
}$time = strtotime($string);
if(is_numeric($time) && $time != -1
return $time;

You need to add in the code in red above into the function and that should make the webmail time and date look right.
Reply With Quote
  #3  
Old 22nd December 2006, 12:17
BlueStream BlueStream is offline
Member
 
Join Date: Oct 2005
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm on a 32 bit machine
Reply With Quote
  #4  
Old 23rd December 2006, 15:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Try it anyway. Maybe it works for you as well. Make sure that the output of
Code:
date
on the shell is correct.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 23rd December 2006, 20:58
BlueStream BlueStream is offline
Member
 
Join Date: Oct 2005
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Try it anyway. Maybe it works for you as well. Make sure that the output of
Code:
date
on the shell is correct.
I did try it and the file does not exist.

So I noted that I'm on a 32bit machine.

#date does returns correct information
Reply With Quote
  #6  
Old 24th December 2006, 14:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by BlueStream
I did try it and the file does not exist.
What's the output of
Code:
ls -la /home/admispconfig/ispconfig/web/webmail/smarty
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 24th December 2006, 21:42
BlueStream BlueStream is offline
Member
 
Join Date: Oct 2005
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:
ls -la /home/admispconfig/ispconfig/web/webmail/smarty
?
discovered that file begins with a capital S. thanks for that tip. I usually do the same but for some reason didn't this time.


In any case, it does not fix the problem. Old mail time is not updated and new mail still is shown with a wrong time.
Reply With Quote
  #8  
Old 24th December 2006, 22:27
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default Give this a try

Within the file /home/admispconfig/ispconfig/web/webmail/inc/config.php there is a line like this, where you can set your local timezone:


################################################## ######################
# The TIME ZONE of server, format (+|-)HHMM (H=hours, M=minutes), eg. +0100
################################################## ######################
$server_time_zone = "+0200"; //CST

Have also a look here:
http://blog.edula.com/?p=14
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005

Last edited by Hans; 24th December 2006 at 22:31.
Reply With Quote
  #9  
Old 25th December 2006, 08:05
BlueStream BlueStream is offline
Member
 
Join Date: Oct 2005
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

brilliant.. that works..!

Cheers. =D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Change Date/Time format of Uebimiau Rocky Installation/Configuration 0 12th October 2006 17:32
uebimiau question ozonblue Installation/Configuration 3 8th October 2006 15:16
Bug in UebiMiau after delete mail and reload page tom Installation/Configuration 4 22nd April 2006 16:44
uebimiau bug? webmail problem with attachments Praude General 3 21st April 2006 17:40
UebiMiau locks out after server receives email sbecker Installation/Configuration 2 25th March 2006 00:00


All times are GMT +2. The time now is 22:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.