Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th November 2007, 18:45
brouck brouck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Root user not opening administration GUI

Hello,
I have recently built a fedora 6 server and installed Zenoss on it for network monitoring. I am also remoting into the server with VNC. I have been trying to setup Zamanda to backup the server but that is an other topic. I'm not sure what I have done, but I can no longer open most of the items under System-> Administration like "Users and Groups" and "Network" etc. I have tried both from the console and remotely. It use to work fine. Fairly new to fedora and appreciate any tips.
Reply With Quote
Sponsored Links
  #2  
Old 28th November 2007, 17:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Are there any errors in your log files (in /var/log/)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th November 2007, 17:54
brouck brouck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default From the /var/log/secure

Nov 28 10:37:30 ZENOSS userhelper[8189]: pam_timestamp(system-config-users:session): updated timestamp file `/var/run/sudo/root/unknown'
Nov 28 10:37:30 ZENOSS userhelper[8192]: running '/usr/share/system-config-users/system-config-users' with root privileges on behalf of 'root'

Thanks for your help
Reply With Quote
  #4  
Old 29th November 2007, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Did you take a look at the other logs also?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th November 2007, 17:32
brouck brouck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Other Logs

falko,
Thanks for your help. What I did is attempt to access "Add/Remove Software", "Network", and "Users and Groups" from the GUI. Then I checked the /var/log folder for any files that had changed. The only ones were secure and maybe messages.

Secure =

Nov 29 10:12:16 ZENOSS userhelper[11445]: pam_timestamp(pirut:session): updated

timestamp file `/var/run/sudo/root/unknown'
Nov 29 10:12:16 ZENOSS userhelper[11448]:

running '/usr/sbin/pirut' with root privileges on behalf of 'root'
Nov 29 10:12:42

ZENOSS userhelper[11458]: pam_timestamp(pirut:session): updated timestamp file

`/var/run/sudo/root/unknown'
Nov 29 10:12:42 ZENOSS userhelper[11461]: running

'/usr/sbin/pirut' with root privileges on behalf of 'root'
Nov 29 10:13:00 ZENOSS

userhelper[11473]: pam_timestamp(system-config-network:session): updated timestamp

file `/var/run/sudo/root/unknown'
Nov 29 10:13:00 ZENOSS userhelper[11476]: running

'/usr/sbin/system-config-network' with root privileges on behalf of 'root'
Nov 29

10:13:09 ZENOSS userhelper[11499]: pam_timestamp(system-config-users:session):

updated timestamp file `/var/run/sudo/root/unknown'
Nov 29 10:13:09 ZENOSS

userhelper[11502]: running '/usr/share/system-config-users/system-config-users' with

root privileges on behalf of 'root'
Nov 29 10:13:15 ZENOSS userhelper[11513]:

pam_timestamp(system-config-users:session): updated timestamp file

`/var/run/sudo/root/unknown'
Nov 29 10:13:15 ZENOSS userhelper[11516]: running

'/usr/share/system-config-users/system-config-users' with root privileges on behalf

of 'root'
___________________________________
messages = Nov 29 10:10:25 ZENOSS kernel: end_request: I/O error, dev fd0, sector 0

Let me know if there are other log areas I should be checking.
Reply With Quote
  #6  
Old 30th November 2007, 15:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by brouck
falko,
Thanks for your help. What I did is attempt to access "Add/Remove Software", "Network", and "Users and Groups" from the GUI.
Can you find out which commands are called by these menu entries (should be in the properties of these menu entries), then open a terminal and run these commands manually? Do you get any errors then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th November 2007, 16:25
brouck brouck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Command line launch

Launching Network from command line
[root@ZENOSS ~]# /usr/bin/system-config-network
/usr/bin/system-config-network:

/opt/zenoss/lib/libpng12.so.0: no version information available (required by

/usr/lib/libcairo.so.2)
Error in sys.excepthook:
Traceback (most recent call last):
File

"/usr/sbin/system-config-network-gui", line 67, in <lambda>
PROGNAME, PRG_VERSION)
File

"/usr/lib/python2.4/site-packages/rhpl/exception.py", line 337, in handleException
import gtk


File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 48, in ?
from gtk import

_gtk
ImportError: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden

Original exception

was:
Traceback (most recent call last):
File "/usr/sbin/system-config-network-gui", line 70, in ?


import gtk
File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 48, in ?


from gtk import _gtk
ImportError: /usr/lib/libcairo.so.2: undefined symbol: FT_GlyphSlot_Embolden
You

have new mail in /var/spool/mail/root
------------------------------------------------------
Launching Users and Groups from command line
[root@ZENOSS ~]# /usr/bin/system-config-users
/usr/bin/system-config-users:

/opt/zenoss/lib/libpng12.so.0: no version information available (required by

/usr/lib/libcairo.so.2)
system-config-users requires a currently running X server.
-----------------------------------------------------
Launching Add/Remove programs from command line
[root@ZENOSS ~]# /usr/bin/pirut
/usr/bin/pirut: /opt/zenoss/lib/libpng12.so.0: no version information

available (required by /usr/lib/libcairo.so.2)
Unable to import modules. Maybe you're not running

under X?
-------------------------------------------------------
Thanks
Reply With Quote
  #8  
Old 1st December 2007, 13:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by brouck
system-config-users requires a currently running X server.
Did you run these commands in a terminal on your desktop, or over SSH, or on a terminal without a desktop? Because if you open a terminal on your desktop and run these commands, they should not complain about X.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 2nd December 2007, 17:51
brouck brouck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Running from VNC

I was running these in a VNC window with a separate terminal window pulled up. But I have the same problem when I try from the console.
Reply With Quote
  #10  
Old 3rd December 2007, 18:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Can you try these commands in a terminal on your desktop?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
monit howto Jamesk5 HOWTO-Related Questions 11 5th August 2008 16:10
apache not working cruz Server Operation 21 29th October 2007 01:19
Add Webmin to the system sushestvo Installation/Configuration 44 21st August 2007 17:52
Server Side Includes don't work PermaNoob General 7 1st May 2007 21:38
cannot connect to ispconfig guidovanh Installation/Configuration 22 3rd March 2006 20:52


All times are GMT +2. The time now is 02:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.