Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th December 2006, 18:35
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Default ISPconfig in a home network

I am new to ISPconfig and networking.

I installed a home network with an openvz machine. The HN (hardware node) of the machine serves as a firewall (shorewall) and one of the VE (vps) has ISPConfig installed and running. The ISPConfig web interface is accessible from the internet. Now the question is how to configure it such a way that the new tlds inside VE could be accessed from internet, too.

To make my problem clear, the external public IP is 81.xx.xx.xx with two nameservers which has been defined as ns1.tld.domain and ns2.tld.domain in the domain control panel of the domain registrar. The VE has 192.168.1.x. I could not access the internet with the https://tld.domain:81 no matter whatever I change in the server settings (I used the IP of the VE as well as the external IP of the router, does not make any difference).

On the other hand the ISPconfig status shows that postifix mailserver is stopped. Where shall I need to make the changes to make it run?

PS: I have installed v2.2.9 of ISPConfig and initially I installed with localhost.localdomain as a parameter which I want to change to my registered tld.domain. Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 21st December 2006, 10:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Example for creating and running a website domain.tld in ISPConfig:

1) Create a client.
2) Create a website in ISPConfig for www.domain.tld, select the internal IP of your server for this website.
3) Make sure you forwarded port 80 on your router to the internal server IP, that you selected for the website.
4) make sure that the DNS-Records for www.domain.tld are pointing to the external IP of your router.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd December 2006, 11:48
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Default

I did it exactly with the internal IPs specified and also pointed the DNS in the domain control panel (external) to the nameservers specified. Still no luck.
Reply With Quote
  #4  
Old 23rd December 2006, 11:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

What do you see exactly when you call the website domain in the browser?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd December 2006, 12:06
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Default

The error message with domain.tld is "Firefox can't find the server at http://domain.tld"

However, I can access the server when I type the IP address instead of the domainname.
Reply With Quote
  #6  
Old 23rd December 2006, 12:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Ok, this is a dns error. Make sure that you created the domain in the authoritive nameserver for domain.tld and thet the IP points to your external server IP.

You can not access websites in ISPConfig by IP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 23rd December 2006, 12:20
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Default

Thanks and sorry for my dumb questions. I could not follow what are authoritative nameservers (I got two from my ISP, aren't they?) and what do you mean by "you cannot specify websites in ISPconfig by IP?" I meant that I can access ISPConfig webinterface by IP, not domain.
Reply With Quote
  #8  
Old 24th December 2006, 11:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by zenny
I could not follow what are authoritative nameservers (I got two from my ISP, aren't they?)
Authoritative name servers are the name servers that are responsible for your domain. You can find out about them by running
Code:
dig ns yourdomain.com
on the shell.

Quote:
Originally Posted by zenny
and what do you mean by "you cannot specify websites in ISPconfig by IP?"
You can access the web sites that you create in ISPConfig only by their domain names, not by IP address.
The ISPConfig web interface, however, can be accessed by IP address or domain.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 25th December 2006, 23:33
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Default

Thank you till and falko.

The dig command gives the following output:

dig ns domain.com

; <<>> DiG 9.2.4 <<>> ns domain.com
;; global options: printcmd
;; connection timed out; no servers could be reached

Now, where did I go wrong?

Here is what I did. I managed child namservers in my domain control panel of the domain registrar and pointed to the same server. Whois gives the correct nameservers where I pointed to. I specified the same nameserves in the ISPConfig DNS settings. I pointed the DNS-records in ISPConfig to the external IP of my router.

Thanks for your guidance. Merry Xmas and Happy New year.

Last edited by zenny; 26th December 2006 at 00:44.
Reply With Quote
  #10  
Old 26th December 2006, 16:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
 
Default

Plaese make sure that the DNS servers listed in /etc/resolv.conf are reachable.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best Distribution for Home Network Server thecgmguy Installation/Configuration 3 15th November 2006 17:01
ISPConfig Home Directory rlhesson Installation/Configuration 2 7th August 2006 12:44
mail problem - authentication (postfix,ISPconfig) marclar General 57 24th June 2006 16:24
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 22:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.