Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st December 2006, 13:27
qtx qtx is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Angry postfix/saslauthd/etc. SMTP problems after update

Hi evr'1

I did a bad thing
I wasn't paying attention while upgrading my debian-Server.

My installation includes the mailserver-solution from falko (Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)).
After upgraded my system, I cannot send mails (smtp) anymore.

The following errors while trying to authenticate (mail.log):

Code:
Dec  1 12:14:25 localhost postfix/smtpd[14084]: warning: SASL authentication failure: Password verification failed
Dec  1 12:14:25 localhost postfix/smtpd[14084]: warning: localhost[127.0.0.1]: SASL PLAIN authentication failed: generic failure
Dec  1 12:14:26 localhost postfix/smtpd[14084]: warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied
After cancelling the SMTP-Auth in the mail client:

Code:
Dec  1 12:14:26 localhost postfix/smtpd[14084]: warning: localhost[127.0.0.1]: SASL LOGIN authentication failed: generic failure
Dec  1 12:14:29 localhost postfix/smtpd[14084]: lost connection after AUTH from localhost[127.0.0.1]
Dec  1 12:14:29 localhost postfix/smtpd[14084]: disconnect from localhost[127.0.0.1]
I am stuck here.
I checked every conf-file but did not find anything.
Starting the daemons (postfix, amavisd-new etc.) is no problem, and as I mentioned reveiving mails works just fine.

Can someone 'light me up'?
OR
What would I have to do to return to the 'old' setting (before upgrading)?

Thanks in advance for any help!
QT
Reply With Quote
Sponsored Links
  #2  
Old 2nd December 2006, 16:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

You shouldn't have updated Postfix because you've lost the quota patch now.

I suggest you configure yor system again following the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th December 2006, 00:36
qtx qtx is offline
Junior Member
 
Join Date: Oct 2006
Posts: 15
Thanks: 2
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by falko
I suggest you configure yor system again following the tutorial.
That's definitely not an option!

It was a permission problem on the sasl socket directory, after all!

Everything works fine again.

The 'quota'-issue is not a big loss in my case.

Anyway, thanks for the input.
Reply With Quote
  #4  
Old 15th December 2006, 15:34
Khushil Khushil is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default What changes...

qtx: Care to elaborate on what fixes you applied to get it working? What permission changes did you make please? I'm in the same situation...
Reply With Quote
  #5  
Old 16th December 2006, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Try
Code:
chmod 777 /var/spool/postfix/var/run/saslauthd
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 16th December 2006, 14:09
Khushil Khushil is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Great! Worked. Thanks mate. Does anyone know of any links to explain more about the full install of SASL authentication at all? Something readable?
Reply With Quote
  #7  
Old 17th December 2006, 20:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Ok. You should now open /etc/init.d/saslauthd. There's a chmod line somewhere near the beginning. Comment it out because otherwise the script will change the permissions of /var/spool/postfix/var/run/saslauthd everytime you restart saslauthd.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 06:19
Ispconfig update problems from 2.4 to 2.6 adrenalinic Installation/Configuration 23 7th September 2006 13:58


All times are GMT +2. The time now is 16:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.