Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th December 2006, 00:18
hossman12 hossman12 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Webalizer not creating or updating stats folder

I had installed ISPConfig and everything was working fine. I've now notised that sibnce Aug. 29th on sites stats have been updated or any new sites stat folder created The stats viewable using the control panel are upto date. The only change was on Aug 30th I updated to 2.2.6. What do I need to do to get it working agian?
Reply With Quote
Sponsored Links
  #2  
Old 17th December 2006, 12:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please try this:

http://www.howtoforge.com/forums/sho...?t=6098&page=2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th December 2006, 16:22
hossman12 hossman12 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've followed the instructions except I do not have the webalizer on the options tab?
"then login ispconfig -> goto site you want -> choose option tab and unchecked Webalizer Statistic -> Save
after few minutes rechecked Webalizer Statistic and Save again"

I took a look at the database table ips_isp_web there is a field called web_webalizer that is NULL for all my sites.

Is it possible that the update did not complete properly and the database was updated to a new version but the admin panel was not.

Should I try updating to the latest version or fixe this problem before updating?

Last edited by hossman12; 18th December 2006 at 16:36.
Reply With Quote
  #4  
Old 18th December 2006, 19:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

I think its not nescessary to update or edir the database. Please wait until tomorrow if the stats where generated this night.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 20th December 2006, 03:19
hossman12 hossman12 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Stats still not updateing. I looked into the webalizer.php script and the following line sticks out
"if($web_data = $mod->db->queryOneRecord("SELECT * FROM isp_isp_web WHERE doc_id = '$web_doc_id' AND webalizer_stats = '1'"))"

Looking at the table isp_isp_web I do not have the field webalizer_stats in the table.
Reply With Quote
  #6  
Old 20th December 2006, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please try to create the field webalizer_stats in the ISPConfig database in the table isp_isp_web and set the default to 1
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 20th December 2006, 18:26
hossman12 hossman12 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I did something similar, I removed " AND webalizer_stats = '1' " from the SQL statment in the PHP file. The stats updated. I'm still wondering how the Database and the Programing are out of sync. Was the DB supposed to be upgraded with 2.2.6 or is there a way to check what version of the DB design I am running? Also is it possible to create the stats for the missing months it did not run?
Reply With Quote
  #8  
Old 21st December 2006, 10:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Was the DB supposed to be upgraded with 2.2.6 or is there a way to check what version of the DB design I am running?
I will check that.

Quote:
Also is it possible to create the stats for the missing months it did not run?
No, at least not automatically with the webalizer scripts from ISPConfig. You might be able to recreate them manually if the logfiles for these months are still available, but I've not tested it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 21st December 2006, 14:58
hossman12 hossman12 is offline
Junior Member
 
Join Date: Dec 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thanks for looking into it. I'd like to get my system squared away so I can upgrade to the latest version. I figured it would be a long shot on the past months data but had to ask. Thanks for your help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
again on webalizer stats gilas Installation/Configuration 6 6th October 2006 16:16
webalizer stats not accessible only for one user gilas Installation/Configuration 4 21st July 2006 13:08
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48
view webalizer stats kuyaedz General 22 12th March 2006 14:45


All times are GMT +2. The time now is 11:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.