Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd November 2006, 07:55
m61 m61 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to m61 Send a message via Yahoo to m61 Send a message via Skype™ to m61
Default postfix on LAMP setup with fc6

i followed the LAMP set up for FC6 and everything installed fine [no errors or anything], but i did not install ISPconfig, and now whenever i try to send an email to my email server, it gets returned with the error message as "relaying denied", any help would be muchly appreciated
Reply With Quote
Sponsored Links
  #2  
Old 24th November 2006, 15:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you configure email accounts as described here? http://www.howtoforge.com/forums/showthread.php?t=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 25th November 2006, 04:32
m61 m61 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to m61 Send a message via Yahoo to m61 Send a message via Skype™ to m61
Default

did that, and i still get the "relaying denied" error
Reply With Quote
  #4  
Old 26th November 2006, 15:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Please post the exact error message here. What's in /etc/postfix/main.cf (please strip out the comments)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th November 2006, 16:30
m61 m61 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to m61 Send a message via Yahoo to m61 Send a message via Skype™ to m61
Default

main.cf
Code:
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
mydestination = /etc/postfix/local-host-names
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
         PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
         xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.3.3/samples
readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
mynetworks = 127.0.0.0/8
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
mailbox_command =
relay_domains_reject_code = 572
virtual_maps = hash:/etc/postfix/virtusertable
error message:
Code:
Nov 27 07:25:25 www1 postfix/smtpd[6103]: connect from shawidc-mo1.cg.shawcable.net[24.71.223.10]
Nov 27 07:25:25 www1 postfix/smtpd[6103]: 6010A4E15FB: client=shawidc-mo1.cg.shawcable.net[24.71.223.10]
Nov 27 07:25:25 www1 postfix/cleanup[6107]: 6010A4E15FB: message-id=<456B0ACD.1050604@shaw.ca>
Nov 27 07:25:25 www1 postfix/qmgr[6236]: 6010A4E15FB: from=<mike.clarkson@shaw.ca>, size=1378, nrcpt=1 (queue active)
Nov 27 07:25:25 www1 postfix/smtpd[6103]: disconnect from shawidc-mo1.cg.shawcable.net[24.71.223.10]
Nov 27 07:25:25 www1 postfix/smtpd[6103]: connect from S0106000f3d5c1bc9.ok.shawcable.net[24.71.95.166]
Nov 27 07:25:25 www1 postfix/smtp[6108]: warning: host mail.hitmenforhire.com[24.71.95.166]:25 greeted me with my own hostname www1.hitmenforhire.com
Nov 27 07:25:25 www1 postfix/smtp[6108]: warning: host mail.hitmenforhire.com[24.71.95.166]:25 replied to HELO/EHLO with my own hostname www1.hitmenforhire.com
Nov 27 07:25:25 www1 postfix/smtp[6108]: 6010A4E15FB: to=<mclarkso@www1.hitmenforhire.com>, orig_to=<mclarkso@hitmenforhire.com>, relay=mail.hitmenforhire.com[24.71.95.166]:25, delay=0.34, delays=0.07/0.02/0.26/0, dsn=5.4.6, status=bounced (mail for www1.hitmenforhire.com loops back to myself)
Nov 27 07:25:25 www1 postfix/smtpd[6103]: disconnect from S0106000f3d5c1bc9.ok.shawcable.net[24.71.95.166]
Nov 27 07:25:25 www1 postfix/cleanup[6107]: B93D74E1600: message-id=<20061127152525.B93D74E1600@www1.hitmenforhire.com>
Nov 27 07:25:25 www1 postfix/qmgr[6236]: B93D74E1600: from=<>, size=3333, nrcpt=1 (queue active)
Nov 27 07:25:25 www1 postfix/bounce[6110]: 6010A4E15FB: sender non-delivery notification: B93D74E1600
Nov 27 07:25:25 www1 postfix/qmgr[6236]: 6010A4E15FB: removed
Nov 27 07:25:32 www1 postfix/smtp[6111]: B93D74E1600: to=<mike.clarkson@shaw.ca>, relay=idcmail.shaw.ca[64.59.134.8]:25, delay=6.5, delays=0.01/0.02/5.9/0.55, dsn=2.5.0, status=sent (250 2.5.0 Ok.)
Nov 27 07:25:32 www1 postfix/qmgr[6236]: B93D74E1600: removed
Reply With Quote
  #6  
Old 28th November 2006, 16:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Nov 27 07:25:25 www1 postfix/smtp[6108]: 6010A4E15FB: to=<mclarkso@www1.hitmenforhire.com>, orig_to=<mclarkso@hitmenforhire.com>, relay=mail.hitmenforhire.com[24.71.95.166]:25, delay=0.34, delays=0.07/0.02/0.26/0, dsn=5.4.6, status=bounced (mail for www1.hitmenforhire.com loops back to myself)
Please add www1.hitmenforhire.com to /etc/postfix/local-host-names and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 5th December 2006, 15:50
m61 m61 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to m61 Send a message via Yahoo to m61 Send a message via Skype™ to m61
Default

did that and it still doesn't work, thunderbird keeps comming back saying "An error occured while sending the mail. The mail server responded: 5.7.1 <mclarkso@hitmenforhire.com>... Relyaing denied. Please verify that your email address is correct in your mail preferences and try again"

and there is nothing in the mail log so it doesn't even seem it gets that far
Reply With Quote
  #8  
Old 6th December 2006, 17:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Also make sure that hitmenforhire.com is listed in /etc/postfix/local-host-names.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 7th December 2006, 04:37
m61 m61 is offline
Junior Member
 
Join Date: Nov 2006
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via MSN to m61 Send a message via Yahoo to m61 Send a message via Skype™ to m61
Default

it is, here is local-host-names
Code:
localhost
www1.hitmenforhire.com
hitenforhire.com
localhost.hitmenforhire.com
localhost.www1.hitmenforhire.com
Reply With Quote
  #10  
Old 8th December 2006, 14:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

I only see
www1.hitmenforhire.com
hitenforhire.com

but not hitmenforhire.com...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Perfect Setup FC4 + Postfix problems pjcast Installation/Configuration 1 12th August 2006 01:29
Perfect Setup - Fedora Core 4 - postfix problem Median Installation/Configuration 7 2nd February 2006 12:21
Postfix on Debian Sarge Perfect Setup daniel_rodriguez HOWTO-Related Questions 1 12th January 2006 22:07


All times are GMT +2. The time now is 10:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.