#1  
Old 10th December 2006, 19:21
AboGassir AboGassir is offline
Junior Member
 
Join Date: Dec 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation LDAP SuSE 10.1

Hi to all;

I want to install an LDAP server along with a file server on a SuSE 10.1 machine. Actually, I googled for LDAP and found one useful article that made a good walkthrough:

http://en.opensuse.org/Howto_setup_S...1_as_Samba_PDC

I struggled a bit to make it work for me, but finally I could make my LDAP work. I tested the configuration to see if it's working, I made that by trying to log a windows machine through my server, and it worked. But when authunticating the windows machine, it refered to that It can't find my profile, and by the way, I could only log in with the Administrator account "root". I also get concered about the roles and users policies and groups, I don't know ho to assign a user to a certain windows group? I mean how to apply a certain policy to a certain user? Is that possible? Where to create the policy? Where are the users' profiles are stored? ....? ......? .....etc.....

So, I thinked about a GUI tool to configure the LDAP server, I googled alot and finally found NetDirector, which a web application that manages servers, I installed it and it's LDAP plugin also, thinking that I will go in a GUI way to configure my already UP server. But, when I try to configure the LDAP, it asks me for " Ldap Server Root(include absolute path) " and " Main Configuration File(include path relative to serverRoot) ", which actually I don't know.

Before I got NetDirector, I downloaded many tools, but most of them were just LDAP browsers but not editors, and the rest I couldn't install.

I aplogize for being too descriptive, but I tried to make my self clear as much as I can.

I hope to find a solution to my case here, as I was looking to overcome this problem for over than a week!.

Thanx in advance.
Reply With Quote
Sponsored Links
  #2  
Old 21st June 2007, 07:16
budianto budianto is offline
Junior Member
 
Join Date: Jun 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

For your problem which the windows can only log in as 'root'. It's because you haven't add user. You only add machine.
You can add user with the same command with add machine but use different type.
If i am not wrong, you add machine using "smbldap-useradd -w" right??
So you add user using "smbldap-useradd -m".
After you add user, you must login to windows as 'root' like you experience just now, and in control panel, create new user account there, the same with the user name you just create in linux.
Restart windows and try the new user account you have made.

You can't find your profile because you use root and you haven't declare profile for root. it doesn't matter but your new user account won't face this error.

certain policy for group or user can be declare at smb.conf. Find any information about user and security configuration for samba in internet.

I never use Ldap in GUI model. If you success please share your experience ;D
Reply With Quote
  #3  
Old 22nd June 2007, 08:50
budianto budianto is offline
Junior Member
 
Join Date: Jun 2007
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

your profile error, it's because there is small error in http://en.opensuse.org/Howto_setup_S...1_as_Samba_PDC.

In giving samba permission to create roaming profile directories, it's written "# chmod 1777 /var/lib/samba/profiles".
The right one is "# chmod 777 /var/lib/samba/profiles".

777 means can be read, written, and execute by user, group, and other
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC & KDE - connecting to the previous session in SUSE 10.1 mariojjsimoes Desktop Operation 4 8th December 2006 13:11
PHP5 and Firebird on SUSE 10.1 glasprilla Installation/Configuration 2 6th October 2006 05:35
The Perfect Setup - SuSE 10.1 (32-bit) - Qouta Issues ? ezfilez HOWTO-Related Questions 3 26th September 2006 18:09
ispconfig on suse 10.1 and fedora core 5 dimas Installation/Configuration 1 13th August 2006 19:52
Courier-imap and suse 10.1 64 BIT rickygm Installation/Configuration 8 8th July 2006 01:10


All times are GMT +2. The time now is 11:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.