#1  
Old 14th October 2005, 09:04
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default postgrsql problem

I am getting postgrsql errors with this cronjob:

Quote:
Cron <postgres@hxxxx> if ! pidof /usr/lib/postgresql/bin/pg_autovacuum > /dev/null && [ -x /usr/lib/postgresql/bin/do.maintenance ]; then /usr/lib/postgresql/bin/do.maintenance -a; fi
the error is as follows:
Quote:
/bin/sh: line 1: /bin/pidof: Keine Berechtigung
/usr/sbin/invoke-rc.d: line 1: /sbin/runlevel: Keine Berechtigung

so now who has no permission to what? and how can I correct this?
Reply With Quote
Sponsored Links
  #2  
Old 14th October 2005, 09:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Which user is running that cron job? Seems like the user postgres. What happens if root runs the cron job?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th October 2005, 04:26
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

psql: FATAL: Benutzer »root« existiert nicht
psql: FATAL: Benutzer »root« existiert nicht
Reply With Quote
  #4  
Old 18th October 2005, 01:07
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

anyone able to help with these postgrsql errors?
Reply With Quote
  #5  
Old 18th October 2005, 10:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,755
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Quote:
Originally Posted by Tenaka
psql: FATAL: Benutzer »root« existiert nicht
psql: FATAL: Benutzer »root« existiert nicht
Do you have a pgsql user "root" ?
Reply With Quote
  #6  
Old 18th October 2005, 14:11
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

sorry, falko helped out with installing postgrsql, I dunno nothing 'bout it. I just found the error in the logfiles and wanted to fix it, though I posted here...
I'll wait for his feedback.
Reply With Quote
  #7  
Old 18th October 2005, 15:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by Tenaka
sorry, falko helped out with installing postgrsql, I dunno nothing 'bout it. I just found the error in the logfiles and wanted to fix it, though I posted here...
I'll wait for his feedback.
I haven't done any Postgresql configuration, I've just installed it with
Code:
apt-get install postgresql
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 18th October 2005, 16:38
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
 
Default

OK ,-) that means I can safely deinstall and reinstall it and see what the original crontab entry will look like thx
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with WebFTP mystix General 7 7th October 2005 20:22
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
Installation problem xma Installation/Configuration 15 26th September 2005 13:22
Problem with webmail MyLinux General 10 17th September 2005 14:31
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 22:15


All times are GMT +2. The time now is 21:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.