#1  
Old 24th November 2006, 23:35
xavier xavier is offline
Junior Member
 
Join Date: Oct 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Basic POP email setup guide

Hi, this is the second ISPCONFIG box I have setup up, but the first time I am configuring it to handle email.

Fresh Mandriva 2006 following the "Perfect Guide." Not using DNS, the DNS is through my ISP. In ISPCONFIG, I created new site, with a user "web4_admin" whose email I would like to be "admin@mysite.net"

When I check "/etc/postfix/virtusertable" I see one of the lines seems to be setup to receive mail there:
Code:
admin@www.mysite.net    web4_admin
web4_admin@www.mysite.net    web4_admin
admin@mysite.net    web4_admin
web4_admin@mysite.net    web4_admin
But when I send an email to that, I get the reply

Code:
Hi. This is the qmail-send program at st08.startlogic.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.

<admin@mysite.net>:
208.201.249.230 does not like recipient.
Remote host said: 550 5.1.1 <admin@mysite.net>... No such user here
Giving up on 208.201.249.230.
also tried emailing the username directly: still no dice

Code:
208.201.249.230 does not like recipient.
Remote host said: 550 5.1.1 <web4_admin@mysite.net>... No such user here
Giving up on 208.201.249.230.

I read the post at http://www.howtoforge.com/forums/showthread.php?t=2

But that seemed command-line oriented; I did everything through the control panel. I must have missed something, where can I read more about basic POP email setup with ISPCONFIG ... or what are the next logical troubleshooting steps?

Thanks in advance,

xavier

Last edited by xavier; 25th November 2006 at 04:17.
Sponsored Links
  #2  
Old 25th November 2006, 11:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Does your main.cf file contains these two lines:

Quote:
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
  #3  
Old 25th November 2006, 17:39
xavier xavier is offline
Junior Member
 
Join Date: Oct 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, it contains those lines verbatim, full contents below I did notice in "main.cf" a couple parameters that seemed weird:

Code:
mydomain = example.com
myhostname = server1.$mydomain
Could that be the problem? Below find the complete contents of main.cf:

Code:
# These are only the parameters changed from a default install
# see /etc/postfix/main.cf.dist for a commented, fuller version of this file.

# These are changed by postfix install script
readme_directory = /usr/share/doc/postfix-2.2.5/README_FILES
html_directory = /usr/share/doc/postfix-2.2.5/html
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
command_directory = /usr/sbin
manpage_directory = /usr/share/man
daemon_directory = /usr/lib/postfix
newaliases_path = /usr/bin/newaliases
mailq_path = /usr/bin/mailq
queue_directory = /var/spool/postfix
mail_owner = postfix



# User configurable parameters
inet_interfaces = all
mynetworks_style = host
delay_warning_time = 4h
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandriva Linux)
unknown_local_recipient_reject_code = 450
smtp-filter_destination_concurrency_limit = 2
lmtp-filter_destination_concurrency_limit = 2
smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
recipient_delimiter = +
owner_request_special = no
alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
mydomain = example.com
myhostname = server1.$mydomain
mydestination = /etc/postfix/local-host-names
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable
home_mailbox = Maildir/
mailbox_command =

Last edited by xavier; 25th November 2006 at 17:41.
  #4  
Old 26th November 2006, 16:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Are the MX records of your domains correct? Do they point to the correct server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #5  
Old 28th November 2006, 06:05
xavier xavier is offline
Junior Member
 
Join Date: Oct 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yes, when I check it out at dnsstuff.com, I see this

Code:
mysitenet.	MX	IN	7200	mail.mysite.net. [Preference = 10]
mysite.net.	MX	IN	7200	custmx.sonic.net. [Preference = 20]
I also tried changing the following lines in /etc/postfix/main.cf to this ...

Code:
mydomain = mysite.net
myhostname = mail.$mydomain
But that didn't work, so I changed them back to the original ...

Code:
mydomain = example.com
myhostname = server1.$mydomain
Below find the tail of /var/log/mail/info. You can see the connection attempt starting at 19:59. There is an error for name service server1.example.com, not sure what to do next.

Code:
Nov 27 19:52:11 colo ipop3d[26293]: pop3 service init from 66.65.62.41
Nov 27 19:52:12 colo ipop3d[26293]: Login user=web4_admin host=cpe-66-65-62-41.nyc.res.rr.com [66.65.62.41] nmsgs=0/0
Nov 27 19:52:12 colo ipop3d[26293]: Logout user=web4_admin host=cpe-66-65-62-41.nyc.res.rr.com [66.65.62.41] nmsgs=0 ndele=0
Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max connection rate 1/60s for (smtp:66.235.193.134) at Nov 27 19:48:10
Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max connection count 1 for (smtp:66.235.193.134) at Nov 27 19:48:10
Nov 27 19:53:33 colo postfix/anvil[26222]: statistics: max cache size 1 at Nov 27 19:48:10
Nov 27 19:59:34 colo postfix/smtpd[26388]: connect from st08.startlogic.com[66.235.193.134]
Nov 27 19:59:34 colo postfix/smtpd[26388]: 57A4B8AC267: client=st08.startlogic.com[66.235.193.134]
Nov 27 19:59:34 colo postfix/cleanup[26392]: 57A4B8AC267: message-id=<B7A290B3-B0CF-4B27-AF4F-5F03450DBACC@xthomas.com>
Nov 27 19:59:34 colo postfix/qmgr[6699]: 57A4B8AC267: from=<xavier@xthomas.com>, size=1052, nrcpt=1 (queue active)
Nov 27 19:59:34 colo postfix/smtpd[26388]: disconnect from st08.startlogic.com[66.235.193.134]
Nov 27 19:59:34 colo postfix/smtp[26394]: 57A4B8AC267: to=<web4_admin@server1.example.com>, orig_to=<admin@xavierthomas.net>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=A: Host not found)
Nov 27 19:59:34 colo postfix/cleanup[26392]: 7D8648AC26A: message-id=<20061128035934.7D8648AC26A@server1.example.com>
Nov 27 19:59:34 colo postfix/qmgr[6699]: 7D8648AC26A: from=<>, size=3009, nrcpt=1 (queue active)
Nov 27 19:59:34 colo postfix/qmgr[6699]: 57A4B8AC267: removed
Nov 27 19:59:34 colo postfix/local[26397]: 7D8648AC26A: to=<xavier@xthomas.com>, relay=local, delay=0, status=bounced (unknown user: "xavier")
Nov 27 19:59:34 colo postfix/qmgr[6699]: 7D8648AC26A: removed
  #6  
Old 29th November 2006, 16:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Please change it back to
Code:
mydomain = mysite.net
myhostname = mail.$mydomain
and restart Postfix. Then this error:
Quote:
Nov 27 19:59:34 colo postfix/smtp[26394]: 57A4B8AC267: to=<web4_admin@server1.example.com>, orig_to=<admin@xavierthomas.net>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=server1.example.com type=A: Host not found)
shouldn't occur anymore.

Quote:
Nov 27 19:59:34 colo postfix/local[26397]: 7D8648AC26A: to=<xavier@xthomas.com>, relay=local, delay=0, status=bounced (unknown user: "xavier")
Is xavier@xthomas.com listed in /etc/postfix/virtusertable?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #7  
Old 5th December 2006, 17:33
xavier xavier is offline
Junior Member
 
Join Date: Oct 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

We fixed this offline, but I just wanted to respond in this thread, close the issue. The problem was with the settings in main.cf, changing it to

mydomain = mysite.net
myhostname = mail.$mydomain

worked like a charm.

x
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
re:perfect setup ubuntu 6.06 - email setup when not using ispconfig caffine_fizz HOWTO-Related Questions 5 19th August 2006 21:05
email setup shiidii Installation/Configuration 2 2nd August 2006 12:39
email forwarding locally consumes all resources rdells General 20 1st May 2006 20:43
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 21:58
Postfix or email server setup matrich Server Operation 3 24th November 2005 23:26


All times are GMT +2. The time now is 07:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.