Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd December 2006, 10:06
jack.ma jack.ma is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation problem on rebooting the system with kernel compiled by myself

Hi
I met a problem on rebooting the system with kernel compiled by my self according to "How to compile kernel on ubuntu way".I found that whenever I reboot the system,it would break down at point where it displayed "rebooting ..." and then stop.So I had to turn off the power although it shutdown gracefully.If I logined in form of "recovery mod" and rebooted it ,it would break down at the same point and displayed "No reboot fixup found for your hardware". I don't kown why.

Any information or suggestion is appreciated.

-jack

Last edited by jack.ma; 2nd December 2006 at 10:14.
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2006, 18:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Please boot your old kernel and compile a new one. The other one doesn't seem to work for your system.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th December 2006, 14:34
jack.ma jack.ma is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Quote:
Originally Posted by falko
Please boot your old kernel and compile a new one. The other one doesn't seem to work for your system.
Hi,falko

The compiled kernel still does not work although I tried to compile many times.I searched this problem via google.someone saied that the source of problem might be located at "the file arch/i386/kernel/reboot_fixups.c:30 ".Yeah,there I find a table with only one entry.

static struct device_fixup fixup_table[]={
{PCI_VENDOR_ID_CYRIX, PCI_VENDOR_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
};


Folllowing that is match_reboot_fixup function.

Does PCI_VENDOR_ID_CYRIX, PCI_VENDOR_ID_CYRIX_5530_LEGACY not match my laptop?What should I do to resolve this problem?

My laptop is compaq nx6120.


I am always waiting for your suggestion.

-jack
Reply With Quote
  #4  
Old 5th December 2006, 18:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

I have no idea. This seems to be a trial and error thing...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th December 2006, 03:35
jack.ma jack.ma is offline
Junior Member
 
Join Date: Nov 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Maybe,the kernel from kernel.org is incompatible with my HP nx6120 laptop. it reboots gracefully on the kernel compiled again the kernel source from ubuntu by apt-get install linux-source-2.6.12 command.
Reply With Quote
  #6  
Old 8th December 2006, 14:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Yes, it's possible that the Ubuntu kernel has some special patches that make it work on your laptop.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
Fedora Core 5 - Server not responding kyriakos Installation/Configuration 13 16th November 2006 14:16
WG311v2 almost working with Edgy (w/o ndiswrapper) need help with the rest caudata Server Operation 11 13th November 2006 20:02
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59
Questions about ubuntu ISP-Server Setup badgerbox76 HOWTO-Related Questions 15 5th March 2006 14:41


All times are GMT +2. The time now is 09:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.