Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th October 2005, 23:39
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default Warnings in ispconfig.log and path for apache problem.

Code:
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: WARNING: could not /etc/init.d/apache reload &> /dev/null
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1856: WARNING: could not groupadd -g 12007 web7_anonftp &> /dev/null
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1857: WARNING: could not useradd -d /var/www/web7/ftp -g web7_anonftp -M -s /bin/false -u 12007 web7_anonftp &> /dev/null
The init.d/apache dosent exist, but ./apache2 does, where can I change the correct path in ISPconfig for the init.d script? Right now I have just copied

Code:
cp /etc/init.d/apache2 /etc/init.d/apache
But this should not bee the solution? Have looked every where for to find the path, but no success.

Also, I cant figure out how to solved the warning about "groupadd and useradd"

no messages in /var/log/syslog or /var/log/messages.
Reply With Quote
Sponsored Links
  #2  
Old 16th October 2005, 00:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Pelle
Code:
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 696: WARNING: could not /etc/init.d/apache reload &> /dev/null
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1856: WARNING: could not groupadd -g 12007 web7_anonftp &> /dev/null
15.10.2005 - 13:09:14 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1857: WARNING: could not useradd -d /var/www/web7/ftp -g web7_anonftp -M -s /bin/false -u 12007 web7_anonftp &> /dev/null
The init.d/apache dosent exist, but ./apache2 does, where can I change the correct path in ISPconfig for the init.d script?
Use phpMyAdmin, and have a look at the isp_server table in your ISPConfig database.

Quote:
Originally Posted by Pelle
Also, I cant figure out how to solved the warning about "groupadd and useradd"

no messages in /var/log/syslog or /var/log/messages.
Run the commands
Code:
groupadd -g 12007 web7_anonftp
useradd -d /var/www/web7/ftp -g web7_anonftp -M -s /bin/false -u 12007 web7_anonftp
manually on the shell and see if you get errors.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th October 2005, 02:37
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I get the messages:
Code:
groupadd: group web7_anonftp exists
useradd: user web7_anonftp exists
Reply With Quote
  #4  
Old 16th October 2005, 03:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by Pelle
I get the messages:
Code:
groupadd: group web7_anonftp exists
useradd: user web7_anonftp exists
Ok, then ignore the warnings on the log.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 16th October 2005, 12:28
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have one more problem. I cant login to the mail!

Have installed the webmail package in ispconfig.

Made an email for each domain (have 2 domains).

But none of these mails work.

when I enter the email and the password it saying:
Code:
You cannot login with the username and password entered.
Please check your username and password and try again.
Then I go in and try to change the password for the email, but then it gives the error with groupadd and useradd.

BUT! I can easyly login to the ftp for the website with these information (user and password)?

In the files: local-host-names and virtualuserstable they all have the right information in them about my domain and user?!

Also my /var/log/syslog is saying about pop3:

Code:
Oct 16 02:17:43 houston2 ipop3d[31377]: connect from 127.0.0.1 (127.0.0.1)
Oct 16 02:17:43 houston2 ipop3d[31377]: pop3 service init from 127.0.0.1
Oct 16 02:19:19 houston2 ipop3d[31626]: Command stream end of file while reading line user=??? host=gmlitconsultis [127.0.0.1]
if this helps.

Last edited by Pelle; 16th October 2005 at 12:30.
Reply With Quote
  #6  
Old 16th October 2005, 14:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Seems as if something is wrong with your POP3 daemon...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 16th October 2005, 23:26
Pelle Pelle is offline
Junior Member
 
Join Date: Sep 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

After 1 hours of probe scanning, I figure out that its because I have used a bad login.
Used the username@domain.tld for login, but finaly found out that I was the "ispconfig" username I needed to use, and then I can log in thru Thunderbird, but cant do it thru UebiMiau, then it will give me the messages of bad login?

Wierd, now that I can log in, I just need to find out how I can recieve the emails... Have sent an email to the adress, can see the file on my server. But I dosent download the file, and the mail.log just saying:

Code:
Oct 16 13:14:42 houston2 ipop3d[8073]: pop3s SSL service init from 80..xxx.xx.xx
Oct 16 13:14:43 houston2 ipop3d[8073]: Auth user=w7_pelle host=xxxx.dk [80.xxx.xx.xx] nmsgs=0/0
Oct 16 13:14:43 houston2 ipop3d[8073]: Logout user=w7_pelle host=xxxx.dk [80.xxx.xx.xx] nmsgs=0 ndele=0
Do not recieve the email thru pop3 or imap. Any Idea where to look for the problem?

Have used the perfect setup for debian sarge, so the reason I looking for answers on this forum
Reply With Quote
  #8  
Old 17th October 2005, 00:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

You're using ipop3d which uses the mbox format so make sure you uncheck Maildir under Management -> Server -> Settings -> Email.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.