Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th November 2005, 01:15
Geoinline Geoinline is offline
Member
 
Join Date: Nov 2005
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Default FTP server offline after fresh install

FTP server is offline in ISPConfig
I got this error when installing

Code:
Restarting ProFTPD ftp daemon..
.. - getaddrinfo 'mydomain.com' error: Temporary failure in name resolution
 - warning: unable to determine IP address of 'mydomain.com'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/etc/proftpd.conf'
It seems to me that it's failing to get address info for the domain name I entered. Is it possible for me to change the domain to be my IP address? How would I do this?

Any help would be appreciated
Reply With Quote
Sponsored Links
  #2  
Old 16th November 2005, 01:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Your hostname has to exist in DNS.
You can either create proper DNS records for your hostname, or give your system another hostname like this:

Code:
echo server1.example.com > /etc/hostname
/bin/hostname -F /etc/hostname
, or modify /etc/hosts and add your current hostname to the 127.0.0.1 line.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th November 2005, 04:45
Geoinline Geoinline is offline
Member
 
Join Date: Nov 2005
Posts: 50
Thanks: 0
Thanked 0 Times in 0 Posts
Default Got it working

I just reinstalled again and now it works.
Reply With Quote
  #4  
Old 20th December 2005, 09:37
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Uhmm, here is my /etc/hostname
Code:
alcon
And here is /etc/hosts
Code:
127.0.0.1 localhost.localdomain localhost alcon

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
I have configured a domain in ispconfig with this machine: abejasalud.cl (www.abejasalud.cl with NS1 ns1.abejasalud.cl), but that is all. I'm experiencing problems with proftpd... after some time the server gets offline and trys to start with /etc/init.d/proftpd start but it never can, until I reboot. Could this something to do with it?
Many thanks
Reply With Quote
  #5  
Old 20th December 2005, 09:43
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

His /etc/proftpd_ispconfig.conf:
Code:
###################################
#
# ISPConfig proftpd Configuration File
#         Version 1.0
#
###################################
<VirtualHost 200.104.78.7>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>
<VirtualHost 200.104.78.7>
        DefaultRoot             ~
        AllowOverwrite          on
        Umask                   002
</VirtualHost>
Maybe the problem is that it should be with something like www.abejasalud.cl or something? And why is it repeated twice?
Reply With Quote
  #6  
Old 20th December 2005, 10:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you get any error messages when you try to restart Proftpd? Is there anything in the logs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th December 2005, 10:48
danf.1979 danf.1979 is offline
Senior Member
 
Join Date: Dec 2005
Location: Chile
Posts: 247
Thanks: 4
Thanked 3 Times in 2 Posts
Send a message via MSN to danf.1979
Default

Nothing strange in the syslog but this:
Code:
Dec 20 06:34:39 localhost postfix/smtp[9078]: connect to mx.vtr.net[200.83.1.24]: server refused to talk to me: 554 mx02.vtr.net Service not available - access denied   (port 25)
Dec 20 06:34:39 localhost postfix/smtp[9078]: 3B5441DDE: to=<abejasalud@vtr.net>, relay=none, delay=107677, status=deferred (connect to mx.vtr.net[200.83.1.24]: server refused to talk to me: 554 mx02.vtr.net Service not available - access denied  )
Code:
Dec 20 06:35:55 localhost proftpd[9204]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - FTP session opened. 
Dec 20 06:35:55 localhost proftpd[9204]: localhost.localdomain (localhost.localdomain[127.0.0.1]) - mod_delay/0.4: delaying for 12 usecs 
.
.
.
Dec 20 06:17:59 localhost proftpd[7890]: localhost.localdomain - ProFTPD killed (signal 15) 
Dec 20 06:17:59 localhost proftpd[7890]: localhost.localdomain - ProFTPD 1.2.10 standalone mode SHUTDOWN 
Dec 20 06:18:01 localhost proftpd[8236]: localhost.localdomain - ProFTPD 1.2.10 (stable) (built do mrt 22 18:28:32 CET 2001) standalone mode STARTUP
Reply With Quote
  #8  
Old 20th December 2005, 12:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

The first log entries are for Postfix, not Proftpd.

Do you see any error messages when you try to restart Proftpd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Server: Offline Kraethor Installation/Configuration 7 30th November 2005 11:25
Server Hostname and IPSConfig Lil'Brudder Installation/Configuration 2 14th October 2005 12:46
Server can't "see" the internet Luciano Installation/Configuration 8 22nd August 2005 23:22
Fresh Install of FC4 using Perfect Install HowTo latcarf HOWTO-Related Questions 21 10th August 2005 22:55
Fresh Install of ISPConfig latcarf Installation/Configuration 0 6th August 2005 20:06


All times are GMT +2. The time now is 19:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.