Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th November 2006, 08:43
grant-skywalker grant-skywalker is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Httpd service not running

Hi all,

Following Perfect Debian Setup and ISPConfig was the most relax setup i've ever had!

Thanks the team who created ISPConfig and falko for Perfect Debian Setup!

Successful installation of ISPConfig could only last for 1 day where my httpd service was "offline".

This is the funny part, i can access my admin page for ISPConfig and other app like phpmyadmin and roundcube-webmail. Meaning that the port 81 is functioning well but unfortunately port 80 "may not" work, as i receive a lot of emails that states : WARNING: services httpd not running [as the subject title]

This is what shows when i type netstat -ntl

testc@debmail:~$ netstat -ntl
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:81 0.0.0.0:* LISTEN
tcp 0 0 10.10.10.155:53 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8822 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN

Can anyone point out what could be the problem??

regards,
Skywalker
Reply With Quote
Sponsored Links
  #2  
Old 29th November 2006, 09:33
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

ISPConfig uses his own apache instance.

Did you try to restart your Apache webserver

Code:
/etc/init.d/apache2 restart
And if after that it's still not running look in apache's error log, and tell us what is in there.
Reply With Quote
  #3  
Old 29th November 2006, 11:04
grant-skywalker grant-skywalker is offline
Junior Member
 
Join Date: Nov 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

After force restart, it was okay.

Thanks for your input.

This is the output screen of my error.log from /var/log/apache2/

[Wed Nov 29 17:50:52 2006] [error] (88)Socket operation on non-socket: apr_accept: (client socket)
[Wed Nov 29 17:50:53 2006] [notice] caught SIGTERM, shutting down
[Wed Nov 29 17:50:58 2006] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec2)
[Wed Nov 29 17:51:03 2006] [notice] Apache/2.0.54 (Debian GNU/Linux) PHP/4.3.10-18 mod_ssl/2.0.54 OpenSSL/0.9.7e mod_perl/1.999.21 Perl/v5.8.4 configured -- resuming normal operations

regards,
Skywalker
Reply With Quote
  #4  
Old 30th November 2006, 15:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by grant-skywalker
[Wed Nov 29 17:50:52 2006] [error] (88)Socket operation on non-socket: apr_accept: (client socket)
This doesn't look good, but I don't know what may have caused it. Anyway, if it's running now, you should observe it, and if it happens again, post it here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
Can't restart Apache2.. httpd (pid #) not running Geoinline Installation/Configuration 18 27th February 2007 15:45
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
WARNING: services not running MicCo Installation/Configuration 31 4th September 2006 12:16
UebiMiau login puntjuh Installation/Configuration 13 14th March 2006 18:24


All times are GMT +2. The time now is 02:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.