Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th November 2006, 19:36
emresumengen emresumengen is offline
Junior Member
 
Join Date: Oct 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Upgrade question for "Virtual Users And Domains With Postfix, Courier And MySQL"

I have followed Falko's guide in Howtoforge to create a good-working Postfix box. Unfortunately, it has not been upgraded since and I see amavis and spamassassin has released newer versions, along with other packages in the system.

The question is, I'm not sure if an upgrade would work out-of-the-box. I fear it would break some configuration and I would have to re-check it from the beginning. (It was 7-8 months ago and I don't want to go over configuration files after each upgrade).

To make certain, would letting debian upgrade itself with the command "apt-get upgrade" directly, hinder anything useless? I have already held back the kernel, mysql (client and server), postfix, postfix-mysql and postfix-tls packages from upgrades.

Or at least, could I upgrade spamassassin and amavis (and related packages) without problems?

The server is getting a lot of mails and in a remote office, so I don't want to risk it...

Any comments?

NOTE: The related packages installed on the server are:
Quote:
courier-authda 0.47-4sarge4 Courier Mail Server - Authentication daemon
courier-authmy 0.47-4sarge4 Courier Mail Server - MySQL authentication
courier-base 0.47-4sarge4 Courier Mail Server - Base system
courier-imap 3.0.8-4sarge4 Courier Mail Server - IMAP server
courier-imap-s 3.0.8-4sarge4 Courier Mail Server - IMAP over SSL
courier-pop 0.47-4sarge4 Courier Mail Server - POP3 server
courier-pop-ss 0.47-4sarge4 Courier Mail Server - POP3 over SSL
courier-ssl 0.47-4sarge4 Courier Mail Server - SSL/TLS Support
libdbd-mysql-p 2.9006-1 A Perl5 database interface to the MySQL data
libmysqlclient 3.23.56-3 LGPL-licensed client library for MySQL datab
libmysqlclient 3.23.56-3 LGPL-licensed client development files for M
libmysqlclient 4.0.24-10sarge mysql database client library
libpam0g 0.76-22 Pluggable Authentication Modules library
libpam-modules 0.76-22 Pluggable Authentication Modules for PAM
libpam-mysql 0.5.0-6 PAM module allowing authentication from a My
libpam-runtime 0.76-22 Runtime support for the PAM library
libsasl2 2.1.19-1.5 Authentication abstraction library
libsasl2-dev 2.1.19-1.5 Development files for authentication abstrac
libsasl2-modul 2.1.19-1.5 Pluggable Authentication Modules for SASL
mysql-client 4.0.24-10sarge mysql database client binaries
mysql-common 4.0.24-10sarge mysql database common files (e.g. /etc/mysql
mysql-server 4.0.24-10sarge mysql database server binaries
openssl 0.9.7e-3sarge1 Secure Socket Layer (SSL) binary and related
php4-mysql 4.3.10-16 MySQL module for php4
phpmyadmin 2.6.2-3sarge1 set of PHP-scripts to administrate MySQL ove
postfix 2.1.5-9 A high-performance mail transport agent
postfix-doc 2.1.5-9 Postfix documentation
postfix-mysql 2.1.5-9 MYSQL map support for Postfix
postfix-tls 2.1.5-9 TLS and SASL support for Postfix
sasl2-bin 2.1.19-1.5 Programs for manipulating the SASL users dat
Reply With Quote
Sponsored Links
  #2  
Old 29th November 2006, 16:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You cannot update Postfix because you will lose the quota feature then: http://www.howtoforge.com/forums/sho...ht=apt-pinning
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th November 2006, 08:13
emresumengen emresumengen is offline
Junior Member
 
Join Date: Oct 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question Upgrade...

Actually, I'm not really into upgrading Postfix. What I really want to replace is Amavis-new and SpamAssassin (with Razor and etc.)

The remaining question is, would even that break something up?

NOTE: I have already postponed upgrades for Postfix, Mysql and some other stuff, like the kernel itself, as I said in the beginning.

Quote:
Originally Posted by falko
You cannot update Postfix because you will lose the quota feature then: http://www.howtoforge.com/forums/sho...ht=apt-pinning
Reply With Quote
  #4  
Old 1st December 2006, 15:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by emresumengen
Actually, I'm not really into upgrading Postfix. What I really want to replace is Amavis-new and SpamAssassin (with Razor and etc.)

The remaining question is, would even that break something up?
Normally that should be no problem, but you can never know. Make backups before you try it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.