Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd December 2006, 15:33
phor phor is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default shared IP | ISPConfig creates wrong vhost configs

Hello there,

I managed to install ISPConfig and am quite impressed by its features. A single problem keeps me away now from chilling down with my ISPConfig installation:

Every new Site creation in ISPConfig ends up with the problem, that all sites opened in a browser are forwarded to the "sharedip" Directory, because of the following entry in /etc/apache2/Vhosts_ispconfig.conf

Code:
NameVirtualHost 123.123.123.123:80
<VirtualHost 123.123.123.123:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
If I comment these lines out, all Sites work properly. But with every new creation ISPConfig adds these lines again and I have to remove them manually to keep my sites working.

Now, how can I prevent ISPConfig from creating these lines? I would also be thankful for some workaround...
Reply With Quote
Sponsored Links
  #2  
Old 23rd December 2006, 16:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

This enrtry is correct and required. So the question is what you configured wrong in the vhosts, you must connect to the websites with the domain and not with a IP, when your server is behind a router, you must select your internal IP, not the external.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 23rd December 2006, 16:52
phor phor is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Default

It's a dedicated Server (not behind a router or anything like that)...

I didn't change anything within the "/etc/apache2/Vhosts_ispconfig.conf" (just uncommented some lines out as reported in the mainthread for testing). The original config-file doesn't work!

When I open a Domain, which points on my serverip, like www.example.com in my Browser, I am being referred to the "/var/www/sharedip" folder. (Placed a special index.html within sharedip to ensure that.)
Reply With Quote
  #4  
Old 24th December 2006, 11:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

The config file is correct without commenting anything out, it works on thousands of dedicated servers, so its a configuration issue of your domain.

Does the domain www.example.com points with a DNS A-Recoird to your server IP address, the same IP address that you selected in the ISPConfig interface for the domain?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
phor (12th December 2009)
  #5  
Old 24th December 2006, 14:19
phor phor is offline
Junior Member
 
Join Date: Dec 2006
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I think it's because ISPConfig forces to use a "Hostname" (e.g. www) which I didn't want to but ISPConfig did automatically.

But I'm now used to it. Additionally I forgot to activate "Administrator" mode in my user configuration, so that my uploaded data was stored in /home/www/webX/user/webX_user/web/ instead of /home/www/webX/web/ ...

Thanks for your help. ISPConfig is nice but has some peculiarities you need to know...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig, dovecot all works but now want shared folders NuttyGambler Installation/Configuration 2 9th May 2009 05:01
ISPConfig Shared IP Error Page gjcomputer Installation/Configuration 4 30th December 2007 17:23
ispconfig with shared ssl fulltilt General 6 20th October 2006 15:30
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 12:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.