#1  
Old 22nd November 2006, 11:44
danjo danjo is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Another suphp issue

Hi all,

im installing my first ispconfig on debian etch with php5.
I`ve used the debian sarge perfect setup tutorial before i installed ispconfig. (of course php5 instead of php4 )

Now i have to problems:

1) when i change something on web - the Vhosts_ispconfig.conf file is deleted

2) when i copy the latest Vhosts_ispconfig.conf_* file to Vhosts_ispconfig.conf following error message returns:

Quote:
Syntax error on line 30 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'suPHP_UserGroup', perhaps misspelled or defined by a module not included in the server configuration
Here are the first Virtualhost from my Vhost_ispconfig.conf (which i copied):
Quote:
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 88.198.23.48:80
<VirtualHost 88.198.23.48:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.steps-cms.de:80
######################################
#
#
<VirtualHost 88.198.23.48:80>
ServerName www.steps-cms.de:80
ServerAdmin webmaster@steps-cms.de
DocumentRoot /var/www/web3/web
ServerAlias steps-cms.de
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web3/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
suPHP_Engine on
suPHP_UserGroup web3_info web3
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php
Alias /error/ "/var/www/web3/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web3/user/$1/web/$3
</VirtualHost>
and my suphp.conf form /etc/suphp/

Quote:
[global]
;Path to logfile
logfile=/var/log/suphp/suphp.log

;Loglevel
loglevel=info

;User Apache is running as
webserver_user=www-data

;Path all scripts have to be in
docroot=/var/www

;Path to chroot() to before executing script
;chroot=/mychroot

; Security options
allow_file_group_writeable=false
allow_file_others_writeable=false
allow_directory_group_writeable=false
allow_directory_others_writeable=false

;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true

;Send minor error messages to browser
errors_to_browser=false

;PATH environment variable
env_path=/bin:/usr/bin

;Umask to set, specify in octal notation
umask=0077

; Minimum UID
min_uid=100

; Minimum GID
min_gid=100


[handlers]
;Handler for php-scripts
x-httpd-php=php:/usr/bin/php5
x-httpd-php=php:/usr/bin/php5-cgi

;Handler for CGI-scripts
x-suphp-cgi=execute:!self
Apache is installed as mpm-worker. Before I had installed apache2-prork, but i changed this as i read some posts here in the forum.

Thanks for any help

Greets
Danjo
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2006, 11:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

This looks like mod_suphp is not loaded in your apache configuration. Do you have a symlink in the mods-enabled directory to the apache suphp config file?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd November 2006, 11:56
danjo danjo is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi till,

There is a suphp.conf in the mods-enabled.

Here is the content:
Quote:
<IfModule mod_suphp.c>
AddHandler x-httpd-php .php .php3 .php4 .php5 .phtml
suPHP_AddHandler x-httpd-php
suPHP_Engine on
# # Use a specific php config file (a dir which contains a php.ini file)
# suPHP_ConfigPath /etc/php4/cgi/suphp/
# # Tells mod_suphp NOT to handle requests with the type <mime-type>.
# suPHP_RemoveHandler <mime-type>
</IfModule>
There is also a suphp.load:

Quote:
LoadModule suphp_module /usr/lib/apache2/modules/mod_suphp.so
Reply With Quote
  #4  
Old 22nd November 2006, 12:22
danjo danjo is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

How can i check if the module is loaded?

Should be an error message on "suPHP_Engine on" when the module is not loaded?
Reply With Quote
  #5  
Old 22nd November 2006, 17:46
danjo danjo is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

can nobody help?

i really don`t know what to do....
Reply With Quote
  #6  
Old 22nd November 2006, 17:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Please compare your current configuration with this howto.

http://www.howtoforge.com/apache2_suphp_php4_php5_p2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd November 2006, 19:09
danjo danjo is offline
Junior Member
 
Join Date: Nov 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

yes that works!

thanks till.

i thought suphp is installed with the package suphp-common in debian ....

Bye
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
suPHP -couldn't create child process error tipsy HOWTO-Related Questions 10 26th November 2007 00:56
suPHP and mod_vhost_alias Wiesemarc HOWTO-Related Questions 0 6th November 2006 16:45
OpenSuSE 10 suphp and apache2? doom4 Installation/Configuration 1 19th September 2006 15:19
Big issue with suPHP ddelbia General 13 23rd June 2006 12:44
Outlook 2003 issue with courier-pop3 RotHorseKid Installation/Configuration 6 7th December 2005 20:35


All times are GMT +2. The time now is 03:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.