Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 3rd January 2006, 11:22
momo momo is offline
Junior Member
 
Join Date: Dec 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem too:
for example:

#
cat virtusertable | grep audrone
audrone@changed.tld audrone
audrone@changed.tld audrone
#
repquota -avug | grep audrone
audrone -- 16468 0 0 113 0 0
#
/tmp/quota.audrone exist!

And the user cannot receive emails, got Mail Quota Exceeded...
Reply With Quote
Sponsored Links
  #12  
Old 3rd January 2006, 11:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

You mean you have the same problem as skirmis, but not the same problem then brent.stephens.

Run:

rm -f /tmp/quota.*

I've posted a solution how to disable the quota script in this thread:

http://www.howtoforge.com/forums/showthread.php?t=1653
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 5th January 2006, 19:28
momo momo is offline
Junior Member
 
Join Date: Dec 2005
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
You mean you have the same problem as skirmis, but not the same problem then brent.stephens.

Run:

rm -f /tmp/quota.*

I've posted a solution how to disable the quota script in this thread:

http://www.howtoforge.com/forums/showthread.php?t=1653

Yes, I mean this, I fallowed your advice:
If you use maildir, you can try to disable the quota procmail recipe. Then the quota is handled completely by the linux system quota. This might solve the problem.

Open the file

/root/ispconfig/isp/conf/procmailrc.master

and comment out the line:

INCLUDERC={PMDIR}/.quota.rc

Then go in the ispconfig interface and change something in an account of y user where you got this problem and save the user. The procmailrc will then be rewritten.

=============================

But don't know how to change to all users this ? Not to only 4 one... I have about 600 users

Thanks for advice!
Reply With Quote
  #14  
Old 5th January 2006, 21:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by momo
But don't know how to change to all users this ? Not to only 4 one... I have about 600 users

Thanks for advice!
You could either write a script that does it, or you set the status field of all users in the isp_isp_user table in the ISPConfig database to u and run
Code:
touch /home/admispconfig/ispconfig/.run
This will make ISPConfig rewrite the procmail recipes (I haven't tested it, but it should work).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 3rd April 2006, 02:45
rafaelenrike rafaelenrike is offline
Junior Member
 
Join Date: Mar 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had almost the same problem. this is the error email that returns back when I send an email to a specific account (not all accounts):

This is the Postfix program at host mailserver.domain.tld.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<web1_user1@mailserver.domain.tld> (expanded from <user1@domain.tld>):
can't create user output file. Command output: /bin/sh: let:
HD_QUOTA=*1024: syntax error: operand expected (error token is "*1024")
/bin/sh: line 1: [: !=: unary operator expected procmail: Error while
writing to "/var/mail/web1_user1"

Does anyone know why is dis happening and how to fix it?

Thanks for your help.
Reply With Quote
  #16  
Old 3rd April 2006, 07:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please set a web (harddisk) quota for this user in ISPCOnfig.

Do you use maildir or mbox format for mail storage?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #17  
Old 4th April 2006, 16:02
rafaelenrike rafaelenrike is offline
Junior Member
 
Join Date: Mar 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with Mails

Quote:
Originally Posted by till
Please set a web (harddisk) quota for this user in ISPCOnfig.

Do you use maildir or mbox format for mail storage?
I use mbox format for mail storage. Every account for this domain is using mbox format and also every account has set 0 Mb for Web storage and XX Mb for Mail storage.
Reply With Quote
  #18  
Old 4th April 2006, 16:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Quote:
Originally Posted by rafaelenrike
I use mbox format for mail storage. Every account for this domain is using mbox format and also every account has set 0 Mb for Web storage and XX Mb for Mail storage.
Do you have linux system quota enabled on your /var partition?

If yes, you must set the webspace quota at least to the double size of the mbox size.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 4th April 2006, 17:51
rafaelenrike rafaelenrike is offline
Junior Member
 
Join Date: Mar 2006
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail System Problem

Quote:
Originally Posted by till
Do you have linux system quota enabled on your /var partition?

If yes, you must set the webspace quota at least to the double size of the mbox size.
I just have "/boot" and "/" partitions on my system (I used FC4 perfect setup). I already configured quotas for "/".

[root@webserver ~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
287G 3.5G 269G 2% /
/dev/sda2 99M 23M 72M 24% /boot
/dev/shm 504M 0 504M 0% /dev/shm

So I just have one partition for all the system.

Thanks for your help.
Reply With Quote
  #20  
Old 4th April 2006, 18:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Please post the output of
Code:
ls -la /var/mail
and
Code:
repquota -avug | web1_user1
What's web1_user1's homedir?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
internal domain error with mail matehortua Installation/Configuration 5 16th October 2005 18:31
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 17:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.