Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th October 2005, 13:27
SkIRmiS SkIRmiS is offline
Member
 
Join Date: Sep 2005
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail system problems.

Hello,

1. first problem.
Sometimes I got the strange message:
with no subject, name and et.c the body is:

X-Spam-Checker-Version: SpamAssassin 3.0.4 (2005-06-05) on changed.com
X-Spam-Level:
X-Spam-Status: No, score=-1.2 required=5.0 tests=ALL_TRUSTED,MISSING_DATE,
MISSING_SUBJECT autolearn=unavailable version=3.0.4

I got this message after sending file.txt to my email. Already, i got 5 messages like this. My email is set to system admin email in ISPconfig.

2. second problem, with quotas.
Web users and web site has quota 5000 mb. The ISPconfig shows that site are only using 23.2 mb of all 5000. Web site users does'nt has mail box quota limits. But sometimes whey cannot receive email, of a error Mail quota exceeded!

On shell:
repquota -avug | grep web29
web29 -- 410904 5120000 5120000 6992 0 0

As you can see web29 user are using 401 mb. Not 23.2 mb that says the ISPconfig. I checked the owners of users directories, everything is fine. Others sites are showing not correct size too But at least the emails are working well.

3. Where to find logs of spammassins reports, trashscan, clamav?

4. Thanks for advice.

Skirmis
Reply With Quote
Sponsored Links
  #2  
Old 13th October 2005, 15:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Quote:
Originally Posted by SkIRmiS
2. second problem, with quotas.
Web users and web site has quota 5000 mb. The ISPconfig shows that site are only using 23.2 mb of all 5000. Web site users does'nt has mail box quota limits. But sometimes whey cannot receive email, of a error Mail quota exceeded!

On shell:
repquota -avug | grep web29
web29 -- 410904 5120000 5120000 6992 0 0

As you can see web29 user are using 401 mb. Not 23.2 mb that says the ISPconfig. I checked the owners of users directories, everything is fine. Others sites are showing not correct size too But at least the emails are working well.
ISPConfig reports the size of the website directory including the subdirectorys user, logs, web, etc. If your users are able to store files in other places the sizes may differ.

Quote:
3. Where to find logs of spammassins reports, trashscan, clamav?
They dont write logs by default.
Reply With Quote
  #3  
Old 13th October 2005, 21:26
SkIRmiS SkIRmiS is offline
Member
 
Join Date: Sep 2005
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
ISPConfig reports the size of the website directory including the subdirectorys user, logs, web, etc. If your users are able to store files in other places the sizes may differ.


They dont write logs by default.
1.The users don't have other places outside webXX.
2.I need these logs to see that happens with rejected mail.

And do you know something about my first problem?


Thanks.
Reply With Quote
  #4  
Old 14th October 2005, 01:17
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

Well well,
I have started receiving quota exceeded errors for one user too, and the user definitely has no quota restrictions (neither does the group).
The debug output shows interesting things:
/bin/sh: line 1: let: HD_QUOTA=*1024: syntax error: operand expected (error token is "*1024")
Apparently procmail thinks QUOTA is set and then tries to do arithmetics on an empty expression which obviously goes wrong.
I didn't dig into procmail yet but maybe this helps someone figure out the real problem.
Regards,
~jm
Reply With Quote
  #5  
Old 14th October 2005, 01:28
jmroth jmroth is offline
ISPConfig Developer
 
Join Date: Sep 2005
Posts: 191
Thanks: 1
Thanked 6 Times in 6 Posts
Default

I don't really know but maybe what you were trying to do should be
... quota -v ${LOGNAME} | sed -n 3p ....
on line 22 of .quota.rc, otherwise the 3p wouldn't really make sense
however I do not know why my other users don't generate error messages
very strange although something is obviously wrong here
Reply With Quote
  #6  
Old 14th October 2005, 01:37
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,259
Thanks: 76
Thanked 23 Times in 19 Posts
Default

Quote:
Originally Posted by SkIRmiS
Hello,

1. first problem.
Sometimes I got the strange message:
with no subject, name and et.c the body is:

X-Spam-Checker-Version: SpamAssassin 3.0.4 (2005-06-05) on changed.com
X-Spam-Level:
X-Spam-Status: No, score=-1.2 required=5.0 tests=ALL_TRUSTED,MISSING_DATE,
MISSING_SUBJECT autolearn=unavailable version=3.0.4

I have exactly the same strange, empty emails, I get them around 5-7 times a day, its hard to track them down as they don't even have a timestamp, nothing. I had one idea, concerning their origin: it seemed like when I was trying to send an email to a non-existent mailbox I got these empty mails instead of a user unknown reply. but I can't test it as I can't send emails to local domains, because these get instantly verified...

can you try and send an email to nonexistent@web-designerz.de ? Please check if you get one ofthese empty mails right after that.
Reply With Quote
  #7  
Old 2nd January 2006, 19:26
brent.stephens brent.stephens is offline
Member
 
Join Date: Nov 2005
Posts: 32
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I'm getting these extremely odd mail quota issues now as well. I cannot discern why its happening, but its extremely frustrating and pretty embarassing too. syslog output below. It seems to be breaking up their 'real' name and trying to send it to them...I just have no idea where its getting it and WHY its happening...

Quote:
Jan 2 13:07:46 liquid5th postfix/smtpd[955]: connect from edited[xx.xx.xx.xx]
Jan 2 13:07:46 liquid5th postfix/smtpd[955]: 715DB11033: client=edited[xx.xx.xx.xx], sasl_method=PLAIN, sasl_username=myuser
Jan 2 13:07:46 liquid5th postfix/cleanup[959]: 715DB11033: message-id=<4366AD72-E6E8-4E0C-8BD9-9B8D2CB8B54A@liquid5th.com>
Jan 2 13:07:46 liquid5th postfix/local[960]: 715DB11033: to=<davesperandio@hosting.liquid5th.com>, orig_to=<dave@allforacappella.org>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jan 2 13:07:46 liquid5th postfix/pickup[31970]: D96F711033: uid=15011 from=<davesperandio>
Jan 2 13:07:46 liquid5th postfix/cleanup[959]: D96F711033: message-id=<20060102180746.D96F711033@liquid5th.net>
Jan 2 13:07:47 liquid5th postfix/local[960]: D96F711033: to=<admispconfig@localhost>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
Jan 2 13:07:48 liquid5th postfix/pickup[31970]: 0A74511039: uid=15011 from=<davesperandio>
Jan 2 13:07:48 liquid5th postfix/cleanup[959]: 0A74511039: message-id=<20060102180747.0A74511039@liquid5th.net>
Jan 2 13:07:48 liquid5th postfix/pickup[31970]: 18B0A11033: uid=15011 from=<David>
Jan 2 13:07:48 liquid5th postfix/cleanup[959]: 18B0A11033: message-id=<20060102180748.18B0A11033@liquid5th.net>
Jan 2 13:07:48 liquid5th postfix/local[960]: 0A74511039: to=<admispconfig@localhost>, relay=local, delay=1, status=sent (delivered to command: /usr/bin/procmail -f-)
Jan 2 13:07:48 liquid5th postfix/local[1037]: 18B0A11033: to=<Sperandio@hosting.liquid5th.com>, orig_to=<Sperandio>, relay=local, delay=0, status=bounced (unknown user: "sperandio")
Jan 2 13:07:48 liquid5th postfix/pickup[31970]: 4241311315: uid=15011 from=<davesperandio>
Jan 2 13:07:48 liquid5th postfix/cleanup[1026]: 4241311315: message-id=<20060102180748.4241311315@liquid5th.net>
Jan 2 13:07:48 liquid5th postfix/local[1037]: 4241311315: to=<admispconfig@localhost>, relay=local, delay=0, status=sent (delivered to command: /usr/bin/procmail -f-)
Jan 2 13:07:50 liquid5th postfix/local[960]: 18B0A11033: to=<davesperandio@hosting.liquid5th.com>, orig_to=<dave@allforacappella.org>, relay=local, delay=2, status=sent (delivered to command: /usr/bin/procmail -f-)
Jan 2 13:07:50 liquid5th postfix/cleanup[959]: 302761103B: message-id=<20060102180750.302761103B@liquid5th.net>
Jan 2 13:07:50 liquid5th postfix/local[1037]: 302761103B: to=<David@hosting.liquid5th.com>, relay=local, delay=0, status=bounced (unknown user: "david")
Reply With Quote
  #8  
Old 2nd January 2006, 21:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

I dont think this are quota errors. What is the linux username for example for the email address: David@hosting.liquid5th.com ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 3rd January 2006, 00:22
brent.stephens brent.stephens is offline
Member
 
Join Date: Nov 2005
Posts: 32
Thanks: 1
Thanked 0 Times in 0 Posts
Default

The username is davesperandio
Reply With Quote
  #10  
Old 3rd January 2006, 00:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Is David@hosting.liquid5th.com in /etc/postfix/virtusertable? If so, to what user is it mapped?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Mail System doesnt work! crichton Installation/Configuration 3 17th September 2007 23:49
internal domain error with mail matehortua Installation/Configuration 5 16th October 2005 18:31
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 20:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.