#1  
Old 22nd November 2006, 16:26
gzero gzero is offline
Junior Member
 
Join Date: Oct 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default UTF8 ubuntu problem

I have posted regarding this problem previously in the ISPConfig section but because it has nothing to do with ISPConfig ill post it here.

I've installed the "The Perfect Setup - Ubuntu 6.06 LTS Server (Dapper Drake)" on one of my servers together with ISPConfig. On one of the sites I have Drupal running with a fileshare module. I would like those users to upload files via drupal to share with others, but i would also like to provide the option to these users to upload files via FTP. Now when users try to upload files via Drupal it works and they are able to download without problems but when I connect with FTP to this directory the text is showing strange characters ie: périphériques

When i create directory's with FTP they will show correctly in FTP client but within Drupal i cannot enter them because they have strange characters.

I know Drupal 4.7 is completely UTF-8 so the directory's created with Drupal should also be UTF-8 and the locale of Dapper is also UTF-8 (LANG=en_US.UTF-8). So this should work or am i not getting it?

Another problem I am having is when i try to create directory's or files with special characters "Priphriques" it doesn't display them correctly. I thought UTF-8 should solve this issue completely?

Hope somebody here has a answer to these problems because it really driving me crazy.

TIA

gzero
Reply With Quote
Sponsored Links
  #2  
Old 23rd November 2006, 17:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I'm not sure, but maybe
Code:
dpkg-reconfigure locales
help.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 2nd December 2006, 10:10
tycho tycho is offline
Member
 
Join Date: Nov 2006
Location: Haarlem, The Netherlands
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It seems to me that you will have to add the french UTF8 string to
/var/lib/locales/supported.d/local
before doing dpkg-reconfigure locales.
Reply With Quote
  #4  
Old 2nd December 2006, 14:36
gzero gzero is offline
Junior Member
 
Join Date: Oct 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I added it and all other locales and after that run reconfigure.
Now I should be able to select all locales which i tried. Still it doesnt work with UTF8 selected. I gave up on UTF8 and are now working with iso charset again.

To bad but thanks for helping!

-gzero
Reply With Quote
  #5  
Old 2nd December 2006, 16:13
tycho tycho is offline
Member
 
Join Date: Nov 2006
Location: Haarlem, The Netherlands
Posts: 37
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'd like to know if it is actually working with the iso charset, because if it does, I think maybe your assumption that it should work with UTF might be wrong. Thast is, in UBUNTU. This goes for Squirrelmail too. It should work fine with UTF8 too (and it does, as long as you're english), but no such luck in other locales. Had to revert to ISO charsets.
Since I spotted more issues regarding locales in Ubuntu, and not being native English, these things are of great importance to me. Like to hear from you again.

Tycho.
Reply With Quote
  #6  
Old 11th January 2007, 05:38
Novacom Novacom is offline
Junior Member
 
Join Date: Oct 2006
Posts: 20
Thanks: 1
Thanked 1 Time in 1 Post
Default

Hi Tycho,

I stumbled on this problem on my new ISP Config install. I choosed french in the shell setup. Different server (now with Ubuntu, fr_CA UTF8) The first symptom was the IP shared page not showing the '' and '' correctly...

My initial test server was perfectly ok, squirrelmail ok and was setup on debian sarge in en_CA ISO-8859-1. All my french "accent" were ok. And the shell setup was done in english.

I will do some tests and post back my results...

Francis
Reply With Quote
  #7  
Old 11th January 2007, 09:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 37,036
Thanks: 841
Thanked 5,655 Times in 4,464 Posts
Default

I had a similar problem with another CMS system, please edit your apache2.conf file and enable the line:

AddDefaultCharset ISO-8859-1

Then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 13th January 2007, 08:28
Novacom Novacom is offline
Junior Member
 
Join Date: Oct 2006
Posts: 20
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

Hey thanks Till,

Your fix was successful in showing all the "accents" in french.

Francis
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Ubuntu 6.06 Ispconfig problem crabbox Installation/Configuration 12 6th November 2006 21:59
ISP-Server Setup - Ubuntu 5.10 "Breezy Badger" Problem with ISPConfig chipw Installation/Configuration 6 30th October 2006 10:38
Log for Debugging jwan Installation/Configuration 5 27th October 2006 15:34
VMWare install on Ubuntu problem with the IP velonis HOWTO-Related Questions 10 21st September 2006 15:19


All times are GMT +2. The time now is 04:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.