Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th March 2006, 15:08
petermachell petermachell is offline
Junior Member
 
Join Date: Mar 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Changing unix username

I am comparing ISPConfig with my existing Syscp setup.

If I am to transition, to make the change transparent I need to make the unix usernames user@domain

I've worked out how to do this manually in the database, in /etc/passwd and shadow and the postfix virtusertable

Is there an easier way to do this?

thanks,
Peter.
Reply With Quote
Sponsored Links
  #2  
Old 18th March 2006, 22:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Linux does not allow the '@' sign in system usernames.
If other control panels use it, it means that they're using virtual users, not system users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th March 2006, 12:27
petermachell petermachell is offline
Junior Member
 
Join Date: Mar 2006
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for that, of course you are right Falko. Looks like I'll leave the syscp server as it is and use ispconfig for new customers.

cheers,
Peter.
Reply With Quote
  #4  
Old 21st November 2006, 02:56
Rustin Rustin is offline
Junior Member
 
Join Date: May 2006
Location: Wisconsin, US
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey Falko,
I'm running debian 3.1 sarge and am able to do a useradd with an @ in the username.
I was also able to ssh into the account with the -l option (as user@domain@site.com wont work):
ssh -l test@test.com hostingsite.com
My /etc/passwd looks as follows:
test@test.com:x:10004:100::/home/test@test.com:

Would it be difficult to change the user format to _____@[DOMAIN]? Is there something else I might be breaking?

thanks in advance,
rustin
Reply With Quote
  #5  
Old 21st November 2006, 11:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
 
Default

Quote:
Originally Posted by Rustin
Would it be difficult to change the user format to _____@[DOMAIN]? Is there something else I might be breaking?
You can try that, but you most likely will break FTP and email functions on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
tlsmgr webmail problem, suse 9.3 perfect setup dschmid Installation/Configuration 44 2nd April 2006 18:55
POP3 login error /Suse perfect set up 9.3 gimhan90 Server Operation 29 18th February 2006 11:33
Virtual Users And Domains With Postfix, Courier And Mysql....help needed MrMattles HOWTO-Related Questions 9 13th February 2006 09:50
Help understanding how mail server should be setup micko_escalade Server Operation 51 12th February 2006 07:25
Courier-POP3 fail to start zer0_g666 Installation/Configuration 62 25th January 2006 12:03


All times are GMT +2. The time now is 05:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.