Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th July 2006, 15:36
virtualweb virtualweb is offline
Junior Member
 
Join Date: Jul 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to setting up webdav within a ispconfig web?

hi,

i have a web called "ssl.example.com" and a certificate for that domain.

ispconfig uses https://ssl.example.com:81

i created a web "ssl.example.com", it is availiable (over apache2).

i want to use webdav for that domain (apache2). i tried to put the directives in the directives field but it will be commented out:

-----
# DavLockDB /var/log/DavLock/DavLockDB # NOT SUPPORTED!
# <Location /var/www/ssl.example.com/dav> # NOT SUPPORTED!
# Dav On # NOT SUPPORTED!
# </Location> # NOT SUPPORTED!
-----

apache -t says "Invalid command 'DavLockDB'".

what is the correct way to enable webdav?

tia.
Reply With Quote
Sponsored Links
  #2  
Old 26th July 2006, 15:39
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

Is mod_dav loaded via AddModule or sth. like that?
For more maybe that helps on mod_dav questions: http://www.webdav.org/mod_dav/install.html
Reply With Quote
  #3  
Old 13th November 2006, 00:54
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Web dav

Got it to work in a non ispconfig with three basic steps
One..a2enmod dav
Two..Add line once to httpd.conf
DAVLockDB /tmp/DAVLock
Three..
Add directories
Alias /ifnl /var/var/www/web10/ifnl_dav
<Location /ifnaturallearning>
DAV On
</Location>
But I get this error with ISPConfig
Syntax error on line 6 of /etc/apache2/httpd.conf:
Invalid command 'DAVLockDB', perhaps mis-spelled or defined by a module not included in the server configuration
Maybe I need to do it via the ISP Web interface?
Oh well I will keep trying...
Also litmus test gives a 450 error if I put the above in the ispconfig for that site and test?
Reply With Quote
  #4  
Old 13th November 2006, 10:10
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,450
Thanks: 813
Thanked 5,218 Times in 4,090 Posts
Default

Quote:
Syntax error on line 6 of /etc/apache2/httpd.conf:
Invalid command 'DAVLockDB', perhaps mis-spelled or defined by a module not included in the server configuration
This means that mod_dav is not loaded. Plese install mod_dav from your linux distribution.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th November 2006, 10:54
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Loaded?

Debian/Ubuntu
a2enmod dav
Reply
This module is already enabled! <--it put the explanation point not me.
But am I doing this in the right place ie not via a place in ISPConfig but in Apache at the console level.
????
Thanks for the reply though.
PS if anyone has gotten it to work and then create per client settings maybe they could do a how to on this?
Reply With Quote
  #6  
Old 13th November 2006, 11:44
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default So far...

For Ubuntu I followed this
http://ubuntuforums.org/showthread.p...ghlight=webdav
Now I get a 404 error but this is a bit better....
Reply With Quote
  #7  
Old 14th November 2006, 14:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by yurtboy
Debian/Ubuntu
a2enmod dav
Reply
This module is already enabled! <--it put the explanation point not me.
If it is enabled already, there's no need to add it to /etc/apache2/httpd.conf.

What's in /etc/apache2/httpd.conf now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 14th November 2006, 17:20
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default Well here are some updates....

Ubuntu having a how to in the forum led to
One...
httpd.conf was left alone ie it is default
Two...
dav_fs conf looked like this
root@server1:/etc/apache2/mods-enabled# more dav_fs.conf
#DAVLockDB /var/lock/apache2/DAVLock
DAVLockDB /tmp/DAVLock
#DAVMinTimeout 600
#Alias /ifnl_dav /var/www/web11/web/aliasfolder/ifnl
#<Location /ifnl_dav>
# Dav On
# AuthType Basic
# AuthName *username*
# AuthUserFile /var/www/web11/web/alisfolder/.DAVlogin
# <LimitExcept PUT GET OPTIONS>
# Require user *username*
# </LimitExcept>
#</Location>
-----end paste
BUT even though this did not work I then went into ispconfig and used it's web interface to add this setting to the ONE client I want to have this access.
Stilll no luck though here is a litmus error
alfred@alfed:~$ litmus http://domainname/aliasfolder username password
-> running `basic':
0. init.................. pass
1. begin................. FAIL (Could not create new collection `/ifnl/litmus/' for tests: 302 Found
Server must allow `MKCOL /ifnl/litmus/' for tests to proceed)
<- summary for `basic': of 2 tests run: 1 passed, 1 failed. 50.0%
See debug.log for network/debug traces.
????
Thanks in advance
Reply With Quote
  #9  
Old 15th November 2006, 12:03
yurtboy yurtboy is offline
Junior Member
 
Join Date: Nov 2006
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Done...

Well almost done...
Seems if I just focused on the file...
/etc/apache2/mods-available/dav_fs.conf
It worked
For better or for worse I added to /etc/apache2/apache.conf
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
BrowserMatch "Microsoft-WebDAV-MiniRedir/5.1.2600" redirect-carefully
BrowserMatch "^WebDAVFS" redirect-carefully
#Header add MS-Author-Via "DAV"
Since sometimes I had trouble with ms clients
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setting up webdav within a ispconfig web? virtualweb Installation/Configuration 1 27th July 2006 13:28
ISPConfig 2.3.1-dev released till General 0 8th May 2006 22:18
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
Any howTO's on setting up phpnuke with ISPConfig? badgerbox76 HOWTO-Related Questions 1 5th March 2006 15:14
Little problems setting up the ISPConfig Luciano Installation/Configuration 1 15th August 2005 20:17


All times are GMT +2. The time now is 11:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.