Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th November 2006, 15:33
asyadiqin asyadiqin is offline
Senior Member
 
Join Date: Jul 2006
Posts: 120
Thanks: 0
Thanked 1 Time in 1 Post
Exclamation Multiple Domain Name In Outbound SMTP

Hi,

I recently installed ISPConfig and everything works fine.

However, I am having problem with the outgoing SMTP connections, which is sending emails using multiple domain names, ie. domains hosted on the server, instead of the dedicated name of the server.

As a result of this, the IP address of the server have been added to CBL as a spam server.

I've checked and it seems that whenever Postfix sends emails out, it identifies itself using domains or users hosted on the server and not the actual machine name.

Is there a way to set Postfix to only use 1 specific name, ie FQDN, which is the machine name.

Any help is greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 14th November 2006, 10:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,383
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
 
Default

If you have more then one IP address, you may bind postfix to the main server IP like this:

smtp_bind_address = 1.2.3.4

Have you set your hostname in main.cf like this:

myhostname = mailserver.mydomain.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running SMTP on multiple ports (postfix) eKg Tips/Tricks/Mods 23 29th August 2010 11:36
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Can't send External Mail AndyF Installation/Configuration 7 8th August 2006 21:53
Multiple MySQL Queries - with Postfix-mysql, courier-authmysql, maildrop-mysql... snowfly HOWTO-Related Questions 4 7th July 2006 04:19


All times are GMT +2. The time now is 08:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.