#1  
Old 12th November 2006, 00:58
radox radox is offline
Junior Member
 
Join Date: Aug 2006
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default Xen and lib6-dev

i get eror messages when building opensll on xen such as:





./include/openssl/bio.h:63:20: stdio.h: No such file or directory
In file included from cryptlib.h:69,
from cryptlib.c:61:
../include/openssl/bio.h:512: error: syntax error before '*' token
In file included from cryptlib.h:70,
from cryptlib.c:61:
../include/openssl/err.h:63:19: stdio.h: No such file or directory
../include/openssl/err.h:64:20: stdlib.h: No such file or directory
In file included from ../include/openssl/err.h:71,
from cryptlib.h:70,
from cryptlib.c:61:
../include/openssl/lhash.h:67:19: stdio.h: No such file or directory
In file included from ../include/openssl/err.h:71,
from cryptlib.h:70,
from cryptlib.c:61:
../include/openssl/lhash.h:184: error: syntax error before "FILE"
../include/openssl/lhash.h:185: error: syntax error before "FILE"
../include/openssl/lhash.h:186: error: syntax error before "FILE"
In file included from cryptlib.h:70,
from cryptlib.c:61:
../include/openssl/err.h:84:19: errno.h: No such file or directory
In file included from cryptlib.h:70,
from cryptlib.c:61:
../include/openssl/err.h:265: error: syntax error before '*' token
cryptlib.c: In function `CRYPTO_thread_id':
cryptlib.c:381: warning: implicit declaration of function `getpid'
cryptlib.c: In function `OpenSSLDie':
cryptlib.c:512: warning: implicit declaration of function `fprintf'
cryptlib.c:512: error: `stderr' undeclared (first use in this function)
cryptlib.c:512: error: (Each undeclared identifier is reported only once
cryptlib.c:512: error: for each function it appears in.)
cryptlib.c:515: warning: implicit declaration of function `abort'
make[2]: *** [cryptlib.o] Error 1
make[2]: Leaving directory `/usr/src/openssl-0.9.7e/crypto'
make[1]: *** [sub_all] Error 1
make[1]: Leaving directory `/usr/src/openssl-0.9.7e'
make: *** [build] Error 2


so i thought to install libc6-dev but then i get this error message



The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge4) but 2.3.2.xen-22 is to be installed
E: Broken packages


any ideas please

radox
Reply With Quote
Sponsored Links
  #2  
Old 12th November 2006, 17:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Which distribution do you use? Do you have this problem on dom0 or domU?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.