Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th November 2006, 07:02
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Issue with 'Too many recipients'

Dear All -

I need to send an e-mail invitation to a list of about 2000 addresses. If I try to do this from Thunderbird of Outlook (IMAP accounts to ISPConfig on Perfect Debian), I get an error: 'Too many recipients'.

Is there some way to (maybe temporary) increase the allowed total of recipients in Postfix (I assume)? Or is this general bad practice which should be handled in a totally different way? This mass mailing is something which I do not have to do very often, so I would prefer a simple 'fix'.

Thanks for all suggestions!

Erik
Reply With Quote
Sponsored Links
  #2  
Old 9th November 2006, 09:38
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,226 Times in 4,096 Posts
Default

Quote:
Is there some way to (maybe temporary) increase the allowed total of recipients in Postfix (I assume)? Or is this general bad practice which should be handled in a totally different way? This mass mailing is something which I do not have to do very often, so I would prefer a simple 'fix'.
Yes, its bad practice to send mail to 2000 recipients at once. The problem is not only the max recipients limit which you may change in the postfix main.cf file. The other problem is that when you send a email to 2000 addresses with BCC, if only one email address is incorrect, the complete sending process will fail and you will get back the mail with an error.

Either use a mailing list software for that or a nice (non free) windows tool for newsletters is groupmail, which sends the emails one by one and not at once like outlook or thunderbird.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th November 2006, 12:43
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks a lot for this clear answer. I will resort to the mailing list solution.

In these forums there are many references regarding running a list in ISPConfig. In fact, there are so many references that I kind of get lost.
Is there a specific recommendation for a very simple list implementation which works well? I have some basic mailman experience, but am no expert by any means.

Any suggestion or pointer is well appreciated, thanks a lot!

Erik
Reply With Quote
  #4  
Old 9th November 2006, 13:34
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 147 Times in 128 Posts
Default

I'm using MailWorksPro, but maybe this is something for you? http://www.phplist.com/
Reply With Quote
  #5  
Old 11th November 2006, 08:39
EvdM EvdM is offline
Junior Member
 
Join Date: Feb 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by edge
I'm using MailWorksPro, but maybe this is something for you? http://www.phplist.com/
That seems great for that I want to do, thanks!

I have installed it, and ran into the following issues:

The installation created this .htacces file:

Code:
DirectoryIndex index.php

<FilesMatch "\.(php|inc)$">
Order allow,deny
deny from all
</FilesMatch>
<FilesMatch "(index.php|dl.php|ut.php|lt.php|download.php)$">
Order allow,deny
allow from all
</FilesMatch>
php_flag magic_quotes_gpc on
This seems to leave the directory inaccessible (error 500) in the ISPConfig Apache configuration.
If I remove .htaccess this problem seems gone. However, I am not sure if that leaves me vulnerable.

Also, if I try to access phplist like this (without the .htaccess), I get an error page:

Quote:
Error: please make sure that index.php is your default document for a directory
If you have just installed PHPlist and get this message, make sure that your Apache configuration has somewhere

DirectoryIndex index.php index.html

or that at least index.php is mentioned before index.html
For other webservers please consult your manual to find how to make index.php be the default document for a directory.
I assume this has to do with the missing .htaccess, but could be something in the Apache2 configuration too...

I hope someone can suggest how to tackle this. I am out of clues...

Thanks a lot!
Reply With Quote
  #6  
Old 11th November 2006, 12:17
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,138
Thanks: 4
Thanked 52 Times in 48 Posts
Default

you need to set the options for the virtual host or that directory specifically to AllowOverride through .htaccess files.

http://httpd.apache.org/docs/1.3/how...l#troubleshoot

However since I don't have ISPConfig I don't know how to enable that in ISPConfig...
Reply With Quote
  #7  
Old 11th November 2006, 13:50
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,226 Times in 4,096 Posts
 
Default

Quote:
Originally Posted by sjau
you need to set the options for the virtual host or that directory specifically to AllowOverride through .htaccess files.

http://httpd.apache.org/docs/1.3/how...l#troubleshoot

However since I don't have ISPConfig I don't know how to enable that in ISPConfig...
Add the following line in the apache directives field of the website in ISPConfig:

Code:
AllowOverride All
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Issue thetekgeek Server Operation 18 25th October 2006 16:44
newsletter | send mail to huge number of recipients Ovidiu Server Operation 8 5th October 2006 17:06
Mail issue with Postfix + Amavis + Spamassassin mhxy594 Server Operation 3 21st August 2006 06:50
Mail configuration issue bogdinator Installation/Configuration 37 2nd March 2006 17:32
Outlook 2003 issue with courier-pop3 RotHorseKid Installation/Configuration 6 7th December 2005 20:35


All times are GMT +2. The time now is 20:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.