#1  
Old 5th November 2006, 03:27
arcadlemon arcadlemon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mail problems

Hello!
I'm running Debian 3.1 with ISPConfig.
I follower the perfect install stuffs.

Actually, when I restart my server, IMAP is not started automatically (though, imap-ssl and pop and postfix are up)

Code:
lamp:~# netstat -atp
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:20000                 *:*                     LISTEN     2363/perl
tcp        0      0 localhost:mysql         *:*                     LISTEN     1972/mysqld
tcp        0      0 *:10000                 *:*                     LISTEN     2366/perl
tcp        0      0 *:81                    *:*                     LISTEN     2182/ispconfig_http
tcp        0      0 *:ftp                   *:*                     LISTEN     2350/proftpd: (acce
tcp        0      0 ns2:domain              *:*                     LISTEN     2337/named
tcp        0      0 aaa.net:domain      *:*                     LISTEN     2337/named
tcp        0      0 aaa.net:domain      *:*                     LISTEN     2337/named
tcp        0      0 aaa.net:domain      *:*                     LISTEN     2337/named
tcp        0      0 mail:domain             *:*                     LISTEN     2337/named
tcp        0      0 ns1:domain              *:*                     LISTEN     2337/named
tcp        0      0 localhost:domain        *:*                     LISTEN     2337/named
tcp        0      0 localhost:953           *:*                     LISTEN     2337/named
tcp        0      0 *:smtp                  *:*                     LISTEN     2315/master
tcp6       0      0 *:imaps                 *:*                     LISTEN     1892/couriertcpd
tcp6       0      0 *:pop3s                 *:*                     LISTEN     1913/couriertcpd
tcp6       0      0 *:pop3                  *:*                     LISTEN     1900/couriertcpd
tcp6       0      0 *:www                   *:*                     LISTEN     2212/apache2
tcp6       0      0 *:ssh                   *:*                     LISTEN     2125/sshd
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2337/named
tcp6       0      0 *:smtp                  *:*                     LISTEN     2315/master
tcp6       0      0 *:https                 *:*                     LISTEN     2212/apache2
tcp6       0   2964 aaa.net:ssh         prg1-v-4-75.static:2225 ESTABLISHED2681/0
lamp:~#
I can start IMAP manually by using

Code:
lamp:~# /etc/init.d/courier-imap start
Starting Courier IMAP server: imapd.
lamp:~#
This works fine (I have to always start it manually)

But still, I'm not able to connect neither from thunderbird., nor from the webmail I installed.
I have checked the userName created by ISPCOnfig. It's in the /etc/password file. And I think I have the correct password.

my /var/log/mail.err is full of

Code:
Nov  5 00:43:43 localhost imapd-ssl: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:19:06 localhost imaplogin: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:19:31 localhost imapd-ssl: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:19:36 localhost imapd-ssl: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:20:11 localhost imaplogin: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:20:16 localhost imaplogin: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:23:39 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:23:54 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:62.177.77.75]
Nov  5 01:28:05 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Nov  5 01:28:47 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Nov  5 01:31:01 localhost imaplogin: DISCONNECTED, ip=[::ffff:127.0.0.1], time=60
Any hint?
Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 6th November 2006, 14:07
fobicodam fobicodam is offline
Senior Member
 
Join Date: Apr 2006
Location: Argentina
Posts: 346
Thanks: 0
Thanked 1 Time in 1 Post
Send a message via MSN to fobicodam
Default

Chek the "chkconfig" part from the perfect install.

What are you using as username?
Reply With Quote
  #3  
Old 6th November 2006, 14:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by arcadlemon
Actually, when I restart my server, IMAP is not started automatically (though, imap-ssl and pop and postfix are up)
Please run
Code:
update-rc.d courier-imap defaults
to make it start at boot time.

Quote:
Originally Posted by arcadlemon
But still, I'm not able to connect neither from thunderbird., nor from the webmail I installed.
I have checked the userName created by ISPCOnfig. It's in the /etc/password file. And I think I have the correct password.
Do POP3 or IMAPs work?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 7th November 2006, 00:37
arcadlemon arcadlemon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by fobicodam
Chek the "chkconfig" part from the perfect install.

What are you using as username?
The userName is the mail user I have created.
I used it without the @
But I tried also with @mydomain.tld but it did not work.

By userName is of the form webMyDomain.tld_myUserName . I checked in the passwd file and it was there.
But noway to login and access the mail account using thunderbird.

Thanks
Reply With Quote
  #5  
Old 7th November 2006, 00:55
arcadlemon arcadlemon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko.

Yesterday, I figured out that the startup files "S*" where missing in the rcX.d directories.
So, it's fixed.
Thanks.

And as I'm not sure whether I'll need IMAP-ssl and POP3-ssl, I disabled them (they don't start automatically).
Only normal POP and IMAP are automatically started.

Quote:
Originally Posted by falko
Please run
Code:
update-rc.d courier-imap defaults
to make it start at boot time.


Do POP3 or IMAPs work?
Neither POP nor IMAPs is working weel (no way to login).
It seems as if the mail system is not using the system login data in passwd.

in my system, I have "/etc/passwd" which contains the new user's info, and I also have "/etc/passwd-" which contains all data from "/etc/passwd" except the new user info.
So, the question is: which one of those two passwd files is used by the mail system?

Before, I used to have dovecot of this system, but I unstalled it after I installed courier.
Maybe a shared file was removed when I was deinstalling dovecot? I can't tell.

My current processes:
Code:
lamp:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost:mysql         *:*                     LISTEN     1950/mysqld
tcp        0      0 *:81                    *:*                     LISTEN     2154/ispconfig_http
tcp        0      0 *:ftp                   *:*                     LISTEN     7976/proftpd: (acce
tcp        0      0 ns2:domain              *:*                     LISTEN     2309/named
tcp        0      0 www:domain              *:*                     LISTEN     2309/named
tcp        0      0 www:domain              *:*                     LISTEN     2309/named
tcp        0      0 www:domain              *:*                     LISTEN     2309/named
tcp        0      0 www:domain              *:*                     LISTEN     2309/named
tcp        0      0 ns1:domain              *:*                     LISTEN     2309/named
tcp        0      0 localhost:domain        *:*                     LISTEN     2309/named
tcp        0      0 *:smtp                  *:*                     LISTEN     8081/master
tcp        0      0 localhost:953           *:*                     LISTEN     2309/named
tcp        0      0 www:32841               212.162.12.159:www      ESTABLISHED2327/freshclam
tcp6       0      0 *:pop3                  *:*                     LISTEN     1891/couriertcpd
tcp6       0      0 *:imap2                 *:*                     LISTEN     1883/couriertcpd
tcp6       0      0 *:www                   *:*                     LISTEN     2184/apache2
tcp6       0      0 *:ssh                   *:*                     LISTEN     2103/sshd
tcp6       0      0 *:smtp                  *:*                     LISTEN     8081/master
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     2309/named
tcp6       0      0 *:https                 *:*                     LISTEN     2184/apache2
tcp6       0      0 dom.tld:ssh         prg1-v-4-75.static:1162 ESTABLISHED30345/0
lamp:~#
Reply With Quote
  #6  
Old 7th November 2006, 12:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Please post the content of the courier authdaemonrc configuration file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 7th November 2006, 23:41
arcadlemon arcadlemon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Please post the content of the courier authdaemonrc configuration file.
My authdaemonrc contains only:
Code:
authmodulelist="authpam"

authmodulelistorig="authcustom authcram authuserdb authldap authpgsql authmysql authpam"

daemons=5

version=""

authdaemonvar=/var/run/courier/authdaemon
Note that on my system, the directory
/var/run/courier/authdaemon
is empty.
Reply With Quote
  #8  
Old 8th November 2006, 11:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

Please run:

/etc/init.d/courier-authdaemon start
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 9th November 2006, 00:15
arcadlemon arcadlemon is offline
Junior Member
 
Join Date: Nov 2006
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till
Please run:

/etc/init.d/courier-authdaemon start
Hi Till!
Thank you very much.
I rand your command and it worked!
So, it turned out that startup scripts were missing for courier-authdaemon too.

So I added them by doing:

Code:
lamp:/etc/init.d# update-rc.d -f courier-authdaemon remove
update-rc.d: /etc/init.d/courier-authdaemon exists during rc.d purge (continuing)
 Removing any system startup links for /etc/init.d/courier-authdaemon ...
   /etc/rc0.d/K20courier-authdaemon
   /etc/rc1.d/K20courier-authdaemon
   /etc/rc6.d/K20courier-authdaemon
lamp:/etc/init.d# update-rc.d  courier-authdaemon defaults
 Adding system startup for /etc/init.d/courier-authdaemon ...
   /etc/rc0.d/K20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc1.d/K20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc6.d/K20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc2.d/S20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc3.d/S20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc4.d/S20courier-authdaemon -> ../init.d/courier-authdaemon
   /etc/rc5.d/S20courier-authdaemon -> ../init.d/courier-authdaemon
lamp:/etc/init.d#
Now, everything seems to be OK.

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 14:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 09:27
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 13:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs mholownych HOWTO-Related Questions 10 29th May 2006 04:39
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 12:47


All times are GMT +2. The time now is 06:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.