Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 31st January 2007, 13:02
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
Default

Quote:
Originally Posted by Petr WhiskI
Thanks, I found it.
In /etc/awstats/awstats.model.conf
have to set
AllowAccessFromWebToAuthenticatedUsersOnly=1

- it was AllowAccessFromWebToAuthenticatedUsersOnly=0 !! after fresh install of your package
Strange thing - look at /home/admispconfig/ispconfig/web/ispc.awstats/awstats.model.conf
there is AllowAccessFromWebToAuthenticatedUsersOnly=0 too...

Thank you for fast reply and hope
is this what you meant by
Quote:
with some cosmetic issues mentioned above
? I see no other posts mentioning changes by you, is there anything else that needs changed?

please answer quick - I am sooooo keen on installing this, I have waited a long time for this :-)
Reply With Quote
Sponsored Links
  #22  
Old 31st January 2007, 13:56
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
Default

well, I tried it and have some problems:
I ran the cronjobs manually to test it imediately.

on one of my sites I managed to authentificate successfully and got an 500 server error. my suexec log says:
Quote:
[2007-01-31 13:47:57]: uid: (10001/web1_postmaster) gid: (10001/10001) cmd: awstats.pl
[2007-01-31 13:47:57]: command not in docroot (/home/admispconfig/ispconfig/web/ispc.awstats/awstats.pl)
[2007-01-31 13:55:03]: uid: (10011/web6_postmaster) gid: (10006/10006) cmd: awstats.pl
[2007-01-31 13:55:03]: command not in docroot (/home/admispconfig/ispconfig/web/ispc.awstats/awstats.pl)
the apache log says:
Quote:
www.web-designerz.de||||1190||||62.159.242.114 - - [31/Jan/2007:13:47:50 +0100] "GET /stats HTTP/1.1" 401 1190 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
www.web-designerz.de||||284||||62.159.242.114 - web1_postmaster [31/Jan/2007:13:47:57 +0100] "GET /stats HTTP/1.1" 301 284 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)"
any help on this?
Reply With Quote
  #23  
Old 31st January 2007, 15:32
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

The fixes I mentioned earlier in this thread are incorporated in the updated download, available from djtremors.
Reply With Quote
  #24  
Old 31st January 2007, 15:40
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

Quote:
Originally Posted by Tenaka
well, I tried it and have some problems:
I ran the cronjobs manually to test it imediately.

on one of my sites I managed to authentificate successfully and got an 500 server error. my suexec log says:

the apache log says:

any help on this?
The setup of dynamic awstats does not run with suexec, as it moves you out of the root web dir. It uses a 301 HTTP redirect. Which suexec does not allow.
Reply With Quote
  #25  
Old 31st January 2007, 17:25
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
Default

any fixes you can imagine to this? I LOVE awstats, but I'd not want to get away from suexec as well, *sigh* what a dilemma... if anyone can imagine a solution for this, pleasse post.
Reply With Quote
  #26  
Old 31st January 2007, 17:35
martinfst martinfst is offline
Senior Member
 
Join Date: Dec 2006
Location: Hilversum, The Netherlands
Posts: 880
Thanks: 1
Thanked 18 Times in 17 Posts
Send a message via MSN to martinfst Send a message via Skype™ to martinfst
Default

An alternative could be to define a ScriptAlias and do some smart rewriting in the general apache2.conf.

But someone has to make some time for this and figure it out.
Reply With Quote
  #27  
Old 31st January 2007, 21:08
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

hey all,

I just double checked and AllowAccessFromWebToAuthenticatedUsersOnly is set to 1 and always has been in my script so I don't know how people are getting it set to 0. I knew this was an issue when I first made this small package.

in regards to suexec, I don't run suexec as i've had issues just trying to get it working and also did it in this method due to some other issues (phpSafeMode blocks other directories and must be included in the path, too much trouble to do using install scripts to patch conf files). I might try to do the ScriptAlias method again and if I get it successful I will publish it as a separate package ("Marked as a ScriptAlias version") but I've been real busy lately.
Reply With Quote
  #28  
Old 1st February 2007, 00:03
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
Default

well you have one loyal supporter over here. I'll wait and wait until you maybe get this done :-)
Reply With Quote
  #29  
Old 1st February 2007, 07:57
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
Default

in that case, I'll do it tonight for ya.

Can't promise on the suexec stuff. I'll private message you on the download url and you can try it out.

[@night] Argghhh!!! ISPC update screwed my development files of ispc-awstats.. ha ha.. lucky I have the download to install and work off..

Last edited by djtremors; 1st February 2007 at 10:31.
Reply With Quote
  #30  
Old 3rd February 2007, 13:31
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
 
Default

I have some updates on this:

I got a report from: Cron <root@h898552> test -x /usr/sbin/anacron || run-parts --report /etc/cron.daily

Quote:
/etc/cron.daily/logrotate:
[Sat Feb 03 06:27:05 2007] [warn] The Alias directive in /etc/apache2/apache2.conf
at line 509 will probably never match because it overlaps an earlier Alias.
[Sat Feb 03 06:27:05 2007] [warn] The ScriptAlias directive in
/etc/apache2/apache2.conf at line 510 will probably never match because it overlaps
an earlier ScriptAlias.
[Sat Feb 03 06:27:06 2007] [warn] The Alias directive in /etc/apache2/apache2.conf
at line 509 will probably never match because it overlaps an earlier Alias.
[Sat Feb 03 06:27:06 2007] [warn] The ScriptAlias directive in
/etc/apache2/apache2.conf at line 510 will probably never match because it overlaps
an earlier ScriptAlias.

line 509,510 are these:
Quote:
Alias /icon/ /home/admispconfig/ispconfig/web/ispc.awstats/icon/
ScriptAlias /ispcstats/ /home/admispconfig/ispconfig/web/ispc.awstats/
any more advice?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04


All times are GMT +2. The time now is 01:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.