#81  
Old 25th October 2005, 21:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

You are mixing up the ISPConfig apache and your normal apache. The apache on port 81 is ONLY for the controlpanel and has nothing to do with the webpages you are hosting. When it shows webserver offline in the controlpanel, your normal webserver is meant, not the ISPConfig webserver. If the ISPConfig server would be offline, wont have seen the page
Sponsored Links
  #82  
Old 25th October 2005, 21:40
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by till
You are mixing up the ISPConfig apache and your normal apache. The apache on port 81 is ONLY for the controlpanel and has nothing to do with the webpages you are hosting. When it shows webserver offline in the controlpanel, your normal webserver is meant, not the ISPConfig webserver. If the ISPConfig server would be offline, wont have seen the page
Sorry, bare with me...
  #83  
Old 25th October 2005, 21:52
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Either way, I guess, both are showing as running under netstat. The ISPConfig CP must not be reporting it accurately for some reason. Nevertheless, I will ignore it for now, I just wanted to make sure it didn't have anything to do with my problem.

I am wondering...when I installed php-4.4.0, it did not install php.ini in /etc/, but I configured it to access it from there. Falko said to just copy one from the php-4.4.0 directory and place it in /etc/ and since I configured PHP to access from that location, it makes me wonder if it is really using that file...

I copied the php.ini-recommended and renamed it to php.ini. I ensured Safe mode was turned off and restarted httpd, but I still get:
Code:
Warning: Unknown(): SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access /home/www/web1/phptmp owned by uid 10001 in Unknown on line 0
when accessing the home web page.

I am finally starting to get frustrated about this. You guys have taught me a ton and I will pay you back somehow for it. I feel like I have gone too far to switch my Linux distro or just use php5. I hope to get this to work with FC4, PHP4, PHPBB2, ISPConfig, etc., but I think I am starting to wear you guys out too.

Anyhow, if you have any final suggestions, I would really appreciate it.

Thanks, Troy
  #84  
Old 25th October 2005, 22:40
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Falko/Till, is Debian Sarge 3.1 and Debian GNU/Linux one in the same? If not, which does "The Perfect Setup" cover. I am also considering Mandrake since it also comes with PHP4.

Also, what version of MySQL will be installed?

Last edited by ctroyp; 25th October 2005 at 22:44.
  #85  
Old 25th October 2005, 23:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by ctroyp
I copied the php.ini-recommended and renamed it to php.ini. I ensured Safe mode was turned off and restarted httpd, but I still get:
Code:
Warning: Unknown(): SAFE MODE Restriction in effect. The script whose uid is 0 is not allowed to access /home/www/web1/phptmp owned by uid 10001 in Unknown on line 0
when accessing the home web page.
Maybe you have enabled PHP Safe Mode for the web site in ISPConfig?

Quote:
Originally Posted by ctroyp
Falko/Till, is Debian Sarge 3.1 and Debian GNU/Linux one in the same? If not, which does "The Perfect Setup" cover. I am also considering Mandrake since it also comes with PHP4.

Also, what version of MySQL will be installed?
Debian Sarge (= Debian 3.1) is the latest version of Debian GNU/Linux.

I'm not quite sure about the MySQL version in Sarge, but I think it's 4.0.24.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #86  
Old 26th October 2005, 00:24
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko
Maybe you have enabled PHP Safe Mode for the web site in ISPConfig?
Not sure how/why I would have done that, but I did. Maybe my clicking finger got excited.

Anyways, that did the trick. I can access the websites fine now with one exception...I am getting another segfault when I try to install phpBB2...imagine that!

Oh well, I may try to debug it, but I'm a little brain tired for now. Thanks for all the help guys. I may just jump into Debian, who knows at this point, because I keep having problem after problem with the current setup.
  #87  
Old 31st October 2005, 18:08
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

I wanted to inform you guys that I have successfully installed debian sarge with ISPConfig, APache2, PHP4, phpBB2, and all the rest. I was able to flawlessly recreate my websites and ftp the web files. Everything seems to be working great.

#1
During setup using Debian The Perfect Setup, I encountered a contradiction of settings for postfix. After installing and configuring postfix per instruction, I viewed the /etc/postfix/main.cf file and noticed only one difference...
I didn't have anything set for smtpd_sasl_local_domain, but I noticed the example provided says that it should be, "smtpd_sasl_local_domain = $myhostname". Can someone clarify which it should be?

#2
I observed in Management -> Server -> Status -> Main Memory that my free memory seemed very low. This is what it displayed:
Code:
MemTotal: 256568 kB 
MemFree: 13172 kB
  #88  
Old 31st October 2005, 18:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by ctroyp

#1
During setup using Debian The Perfect Setup, I encountered a contradiction of settings for postfix. After installing and configuring postfix per instruction, I viewed the /etc/postfix/main.cf file and noticed only one difference...
I didn't have anything set for smtpd_sasl_local_domain, but I noticed the example provided says that it should be, "smtpd_sasl_local_domain = $myhostname". Can someone clarify which it should be?
It should be
Code:
smtpd_sasl_local_domain =
I've corrected that in the howto.

Quote:
Originally Posted by ctroyp
#2
I observed in Management -> Server -> Status -> Main Memory that my free memory seemed very low. This is what it displayed:
Code:
MemTotal: 256568 kB 
MemFree: 13172 kB
Should be ok. If the server is in heavy use, you should however keep an eye on it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
  #89  
Old 31st October 2005, 22:31
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Another thing I forgot to mention is that I did not get the expected results for "telnet localhost 25" and "ehlo localhost". I should have seen the "250-STARTTLS" and "250-AUTH", correct?

btw, this was after I removed the "$myhostname" from "smtpd_sasl_local_domain =".
  #90  
Old 31st October 2005, 23:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

What happens if you have
Code:
smtpd_sasl_local_domain = $myhostname
in /etc/postfix/main.cf? Don't forget to restart Postfix after the change.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
PHP not working jefash General 10 28th May 2006 08:48
Cannot compile new PHP with apxs olli Installation/Configuration 11 4th March 2006 15:32
Multiple domains jysse Installation/Configuration 2 10th August 2005 11:22
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 16:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.