Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #81  
Old 27th March 2011, 23:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

SSL certificates for which service?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #82  
Old 28th March 2011, 00:01
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

Hello Till,

It is "http://www.startssl.com". They told me, that I also need this Configuration:

Code:
SSLCertificateChainFile /usr/local/apache/conf/sub.class1.server.ca.pem
SSLCACertificateFile /usr/local/apache/conf/ca.pem
But there are no .pem-Files in the ISPConfig-Folders.

Thanks!

Hahni
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #83  
Old 28th March 2011, 00:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

The question is for which service or website do you want to setup that ssl cert.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #84  
Old 28th March 2011, 00:12
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

For the ISPConfig 2 Admin-Panel "https://server.domain.tld:81" and for the RoundCube webmailer under "https://server.domain.tld:81/roundcubemail".
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #85  
Old 28th March 2011, 00:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

The apache configuration for ispconfig is under /root/ispconfig/httpd/conf/httpd.conf and you have to add all directives for the ssl certificates and to load chain files there. You will find there alos the ssl folders where you acn add your pem files.

As a side note: If you have another question, please make always a new thread or find a matching therd. This thread is about user@domain logins in ispconfig 2 and not about ssl certificates for websites. Threads are always based on topics. Thanks
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #86  
Old 28th March 2011, 00:36
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

I know, that this is not really the topic. But Certificates and Webmailer with user@domain was my job

I wrote my question in the correct topic (http://www.howtoforge.com/forums/sho...126#post254126). Maybe you can help me to sort out my problem?
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de

Last edited by hahni; 28th March 2011 at 00:39.
Reply With Quote
  #87  
Old 5th April 2011, 15:02
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

In RoundCube everything works fine with reading and sending of mails! But if I use for example Outlook and want to send an mail, the user@domain.tld User does not work (POP3 does work).

If I activate in the SMTP-Auth a separate User (domain.tld_user), with the original user in ISPConfig 2, it works. But that is not a good effect. What could be the reason?
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #88  
Old 5th April 2011, 15:14
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,769
Thanks: 840
Thanked 5,609 Times in 4,420 Posts
Default

You have to enable smtp auth in outlook and use the same user and password that you use for pop3. Without smtp auth, every spammer would be able to send email trigh the mailserver of your clinet and I guess thats not what you client wants.

You have to enable smtp-auth for every smtp server these days, so thats absolutely normal.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #89  
Old 5th April 2011, 15:47
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

Hi Till,

I know that! The server is configured step by step like Perfect Server Setup for Ubuntu 8.04 LTS. But this server has the workaround for email@domain.tld-Login.

And this works fine with POP3. But not with SMTP. In this way only the sending is ok with the standard login from ISPConfig, not with the email@domain.tld login.

Best regards

Hahni
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #90  
Old 6th April 2011, 02:56
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
 
Question

In /var/log/mail.info are the follwoing error entries:

Code:
Apr  6 01:46:33 server postfix/smtpd[1526]: connect from localhost[127.0.0.1]
Apr  6 01:46:43 server pop3d-ssl: LOGIN, user=0172@9999999.de, ip=[::ffff:109.84.0.9], port=[47094]
Apr  6 01:46:59 server postfix/smtpd[1526]: disconnect from localhost[127.0.0.1]
Apr  6 01:47:10 server postfix/smtpd[1526]: connect from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:12 server postfix/smtpd[1526]: warning: 95-90-36-193-dynip.superkabel.de[95.90.36.193]: SASL LOGIN authentication failed: authentication failure
Apr  6 01:47:13 server postfix/smtpd[1526]: lost connection after AUTH from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:13 server postfix/smtpd[1526]: disconnect from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:21 server postfix/smtpd[1526]: connect from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:23 server postfix/smtpd[1526]: warning: 95-90-36-193-dynip.superkabel.de[95.90.36.193]: SASL LOGIN authentication failed: authentication failure
Apr  6 01:47:23 server postfix/smtpd[1526]: lost connection after AUTH from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:23 server postfix/smtpd[1526]: disconnect from 95-90-36-193-dynip.superkabel.de[95.90.36.193]
Apr  6 01:47:36 server pop3d: LOGIN, user=test@8888888.de, ip=[::ffff:95.90.36.193], port=[54729]
Apr  6 01:47:36 server pop3d: LOGOUT, user=test@8888888.de, ip=[::ffff:95.90.36.193], port=[54729], top=0, retr=0, rcvd=12, sent=39, time=0
Apr  6 01:50:43 server postfix/anvil[1550]: statistics: max connection rate 2/60s for (smtp:95.90.36.193) at Apr  6 01:47:21
Apr  6 01:50:43 server postfix/anvil[1550]: statistics: max connection count 1 for (smtp:95.90.36.193) at Apr  6 01:47:10
Apr  6 01:50:43 server postfix/anvil[1550]: statistics: max cache size 1 at Apr  6 01:47:10
The SMTP-Auth seem to fail. But only with "user@domain.tld". The ISPConfig 2 notation "domain.tld_user" work. What can and must be done?
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send email from OE through ISPconfig site tomd General 10 12th March 2009 07:05
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16
ISPConfig 2.2.0 problem with email addresses DataJet General 1 29th March 2006 14:29
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 21:58
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 21:30


All times are GMT +2. The time now is 04:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.