Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #71  
Old 3rd October 2007, 18:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

I recommend to replace courier in your setup with dovecot. In dovecot you will have to change just one line to enable user@domain.com authentication:

http://www.howtoforge.com/forums/showthread.php?t=12308
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #72  
Old 3rd October 2007, 20:04
Melchior Melchior is offline
Junior Member
 
Join Date: Jul 2007
Location: Germany, Darmstadt
Posts: 25
Thanks: 5
Thanked 1 Time in 1 Post
Default

hi till,
I am now using dovecot and its working very well :)

but now there's another problem. The isp's email-username is limited to n-characters so I get in trouble while using 'large-email-adresses'

in another post, grant is telling about a solution how to fix this by patching the couriers-user-workflow mentioned by desmondk in first post here.

perhaps you know a working solution for dovecot? Would like to use it furthermore cause there's a webmin module available :)

greetings,
m.
Reply With Quote
  #73  
Old 3rd January 2008, 14:01
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by falko
CentOS uses dovecot instead of Courier, therefore the instructions won't work for you.

Ah poop. lol.

I just just saw. And ive already done the SMTP instructions posted in the other post.

THe SMTP works trying to login from email clients but the pop doest becuase i havent done this step.

Does anyone know what the = is in saslauthd/dovecot.
Reply With Quote
  #74  
Old 1st May 2008, 08:12
bbrendon bbrendon is offline
Junior Member
 
Join Date: Apr 2008
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by oakleeman
Anybody know how to do this on Centos 4.4? I've already configured the systems to use DOMAIN_username but can't find any of the files mentioned in the post.
How do users login once they are set to administrators and the prefix is "[DOMAIN]_"
I haven't been able to get users to login.
Reply With Quote
  #75  
Old 25th March 2011, 13:19
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

The for Ubuntu 8.04LTS und Ubuntu 10.04LTS modified Skript for "userdb"-Creation is:

Code:
#!/bin/bash
# http://www.howtoforge.com/forums/showthread.php?t=7881&highlight=mailuser

delim="_"

OIFS=$IFS
IFS="
"

rm -rf /etc/courier/userdb
touch /etc/courier/userdb
chmod 600 /etc/courier/userdb

for line in `/usr/sbin/pw2userdb | grep -ir home=/var/www/web`
 do
   full=$( echo $line )
   domain=$( echo $line | cut -d"$delim" -f1 )
   remain=$( echo $line | cut -d"$delim" -f2,3,4 )
   username=$(echo $remain | cut -d "   " -f1 ) # tab inside
   remain2=$(echo $remain | cut -d "    " -f2 ) # tab inside
   uid=$( echo $remain2 | cut -d '|' -f1 )
   gid=$( echo $remain2 | cut -d '|' -f2 )
   home=$( echo $remain2 | cut -d '|' -f3 )
   shell=$( echo $remain2 | cut -d '|' -f4 )
   password=$( echo $remain2 | cut -d '|' -f5)
   echo "$username@$domain $uid|$gid|$home|$shell|$password|/var/www/www.$domain/user/${domain}_$username/Maildir" >> /etc/courier/userdb
   /usr/sbin/makeuserdb
 done

IFS=$OIFS
The content in /etc/courier/userdb is:

Code:
user1@domain.de uid=10014|gid=10006|home=/var/www/web6|shell=/bin/false|systempw=$1$CwvHHL@}$vLvpPKT6FN1Nxa1E5hDDC0|/var/www/www.domain.de/user/domain.de_werner/Maildir
user1@domain.us uid=10013|gid=10003|home=/var/www/web3|shell=/bin/false|systempw=$1$QJqPJviI$JU3UO4bOF.vL7CotHntuh1|/var/www/www.domain.us/user/domain.us_michael/Maildir
But the login does not work! What is wrong in the generated userdb-file?
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de

Last edited by hahni; 25th March 2011 at 18:17.
Reply With Quote
  #76  
Old 25th March 2011, 19:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Which error message do you get in the mail.log? You can also try to enable debuggong in courier for more detailed error messages.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #77  
Old 25th March 2011, 20:20
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

Hi Till,

Thanks a lot for helping me. This is a part of the log:

Code:
Mar 25 16:21:32 server imapd: LOGIN FAILED, user=michael@domain.us, ip=[::ffff:127.0.0.1]
Mar 25 16:21:37 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5
Mar 25 16:22:13 server imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 25 16:22:13 server imapd: LOGIN FAILED, user=michael@domain.us, ip=[::ffff:127.0.0.1]
Mar 25 16:22:18 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5
Mar 25 16:23:04 server imapd: Connection, ip=[::ffff:127.0.0.1]
Mar 25 16:23:04 server imapd: LOGIN FAILED, user=michael@domain.us, ip=[::ffff:127.0.0.1]
Mar 25 16:23:09 server imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5
I hope, that helps?

Hahni
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #78  
Old 26th March 2011, 23:40
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
Question

The script now works, if I start it manually.

The job-job file is:

--
# /etc/cron.d/courier_userdb
# E-Mail-Login with "user@domain.tld"

*/5 * * * * root /usr/local/sbin/courier_userdb
--

But the Cron-Job makes the file clean and do not create the recordsets. What could be the reason?
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
  #79  
Old 27th March 2011, 20:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

You might have to use absolute paths in the script (or set the PATH variable in the script).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #80  
Old 27th March 2011, 22:55
hahni hahni is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 1
Thanked 1 Time in 1 Post
 
Question

Hi Falko,

Thanks a lot. I could sort out this problem. Is there an manual for installation of StartSLL-certificates? I saved the server.key and server.crt. But the cert is not valid. What could be the problem?

Thanks a lot!

Hahni
__________________
björn hahnefeld InformationsTechnologien * Regensburg
.::. Magento - TYPO3 - Webdesign Regensburg .::.

Internet: http://www.hahnefeld.de
E-Mail: bjoern@hahnefeld.de
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot send email from OE through ISPconfig site tomd General 10 12th March 2009 06:05
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16
ISPConfig 2.2.0 problem with email addresses DataJet General 1 29th March 2006 13:29
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
ISP-Ubuntu breezy ispconfig dns email e-mail working finally yellowjelly HOWTO-Related Questions 0 19th November 2005 20:30


All times are GMT +2. The time now is 21:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.