Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 16th May 2006, 19:30
stamy stamy is offline
Junior Member
 
Join Date: May 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Have you restarted apache ?
Your web pages are locatd under /home/www/virtual/*/web and not under /home/www/*/web ?
Reply With Quote
Sponsored Links
  #12  
Old 1st August 2006, 22:52
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Red face same problems with drupal on Ubuntu 6.06

hello -
i was reading these entries and tried to fix my problems.
since i've put drupal into my /home/web6/web/cms - directory, i have the
"500 Internal Server Error".


my httpd.conf looks like this:

Code:
<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride All
#  AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

and the .htaccess-file looks like this:

Code:
#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "(\.(engine|inc|install|module|sh|.*sql|theme|tpl(\.php)?|xtmpl)|code-style\.pl|Entries.*|Repository|Root)$">
  Order deny,allow
  Deny from all
</FilesMatch>

# Set some options.
Options -Indexes
Options +FollowSymLinks

# Customized error messages.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php

# Override PHP settings. More in sites/default/settings.php
# but the following cannot be changed at runtime.

# PHP 4, Apache 1
<IfModule mod_php4.c>
  php_value magic_quotes_gpc                0
  php_value register_globals                0
  php_value session.auto_start              0
</IfModule>

# PHP 4, Apache 2

this is in the LOG-file (/home/web6/log):

Code:
[Wed Aug 02 10:23:16 2006] [alert] [client 85.125.230.181] /home/web6/web/.htaccess: Options not allowed here


so, i really don't know how to make it work properly.
Please folks, help me!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig

Last edited by pinz0; 2nd August 2006 at 10:28.
Reply With Quote
  #13  
Old 2nd August 2006, 03:19
geek.de.nz geek.de.nz is offline
Member
 
Join Date: Feb 2006
Posts: 65
Thanks: 0
Thanked 2 Times in 2 Posts
Send a message via ICQ to geek.de.nz Send a message via MSN to geek.de.nz
Default

Quote:
Code:
<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride All
#  AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
change to

Code:
<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride All
#  AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
#    <Files ~ "^\.ht">
#   Deny from all
#    </Files>
</Directory>
Try this. I'm not sure if that will work, but I think
Code:
<Files ~ "^\.ht">
   Deny from all
</Files>
prevents .htaccess to be loaded. "^\.ht" is a regular expression matching files beginning with ".ht", so .ht*.

I could be mistaken though. Have a look at the docs on the apache website.
__________________
Always mention at least your distribution/version! You can add it in your signature if you don't want to always type it. ;-)

Distributions:
Ubuntu 5.10 with custom kernel (2.6.16-suspend2),
Debian Sarge 3.1 and Etch

Please submit your ISP or Webhost to (free)
http://www.ihostnz.com
Reply With Quote
  #14  
Old 2nd August 2006, 14:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Code:
<Directory /home/*/user/*/web>
    Options +Includes -Indexes
    AllowOverride All
#  AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
is the wrong stanza.

It's this stanza:

Code:
<Directory /home/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>
that you must change.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 2nd August 2006, 14:32
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default

THANKS!

it works now! many thanks for the quick help.
bests!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig
Reply With Quote
  #16  
Old 3rd August 2006, 18:03
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default another problem!

hello again,

another problem showed up with isp-config and drupal .
for some reason it is not possible to view uploaded files.
if i click on the link of the uploaded file the server again posts the "500 error".

is there someone who can help me with that problem?

bests!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig

Last edited by pinz0; 4th August 2006 at 16:54.
Reply With Quote
  #17  
Old 4th August 2006, 13:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

The problem is the .htaccess file in your files directory. If you remove it, it should work, but as far as I know this opens a security hole so this is not recommended...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 4th August 2006, 16:53
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default

Quote:
Originally Posted by falko
The problem is the .htaccess file in your files directory. If you remove it, it should work, but as far as I know this opens a security hole so this is not recommended...
thanks for your response.

yes, if i rename or remove the .htaccess-file in /files, than it works fine, but as you mention, this can't be the way..

any recommendations for the .htaccess - file or for another back door-solution?
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig
Reply With Quote
  #19  
Old 4th August 2006, 18:03
pinz0 pinz0 is offline
Member
 
Join Date: Jun 2006
Location: Vienna, Austria
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to pinz0 Send a message via AIM to pinz0 Send a message via Skype™ to pinz0
Default Ok!

ok, i think i have a solution for the problem.
i pasted this into /etc/apache2/apache2.conf:

Code:
<Directory /home/*/web/drupal/files>
AllowOverride All
Order allow,deny
Allow from all
</Directory>
i think, that this works for all drupal-installs on the server.

bests!
__________________
___________________
pinz0 - working on ubuntu 6.06 + ispconfig
Reply With Quote
  #20  
Old 17th June 2007, 03:18
nzimas nzimas is offline
Member
 
Join Date: May 2007
Posts: 47
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Puzzling.

I have tried several recipes to allow .htaccess overrides and still get the error 500.

my apache2.conf looks like:

Code:
<Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride All
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
<Files ~ "^\.ht">
Deny from all
</Files>
</Directory>
The error log reports:

Sat Jun 16 20:49:50 2007] [alert] [client 83.165.10.237] /var/www/web2/web/.htaccess: Options not allowed here, referer: http://www.familythrive.com/administ...ask=showconfig

I have this actual web located at /var/www/web2/web/

Do i need to tweak anything at /etc/apache2/vhosts/Vhosts_ispconfig.con?

Thanks,
Nuno.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drupal and Apache Rewrite Rules andre Server Operation 10 4th May 2006 21:04
.htaccess / Apache kermit Server Operation 1 18th May 2005 16:32


All times are GMT +2. The time now is 18:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.