#1  
Old 3rd November 2006, 13:32
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
Question Moving IPs and leaving port 81

I've moved my ISPConfig server to different hardware, so it is on new IP addresses. The old IPs are being routed to it for now, but I need to switch soon.

At the same time, I want to move away from using port 81, which gives problems to quite a few people. I have five IP addresses to use, and plan to use one for ISPConfig, one for most of the websites, and two for sites that need their own certificates.

First step is to move one site to the new IP. I've got the IPs in /etc/network/interfaces and listed them in Server Settings | IP List. If I create a new site in Server Manager using the new IPs, all goes well. The vhosts.conf and the dns are set up properly as far as I can see. I can ping the address, but when I try to get to the website, I get an error:

IE - "The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings."

Firefox - "Firefox can't establish a connection to the server at..."

Any suggestions?
Reply With Quote
Sponsored Links
  #2  
Old 3rd November 2006, 17:55
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,590
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Please check the Vhost_ispconfig.conf file. Is the IP in the vhost set to the new IP?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 3rd November 2006, 19:13
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
Please check the Vhost_ispconfig.conf file. Is the IP in the vhost set to the new IP?
Yes, it is.
Reply With Quote
  #4  
Old 3rd November 2006, 23:38
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 2 Times in 2 Posts
 
Default Sorted!

I've found the problem and fixed it. Seems that I was looking in the wrong file for the source of the problem. I hadn't updated ports.conf

That's a huge relief. Now I can move away from port 81.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.