#1  
Old 7th October 2005, 17:46
thevinster thevinster is offline
Junior Member
 
Join Date: Aug 2005
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default Mailman

Has anyone tried installing mailman? Once everything is done, mailman puts the files in /usr/lib/cgi-bin. When I try to copy the files over to /home/www/web#/cgi-bin and run it through http://domain/cgi-bin/mailman/admin/ it doesn't work.

Any ideas?
Reply With Quote
Sponsored Links
  #2  
Old 8th October 2005, 02:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

I'm not quite sure but the problem might be that you have subdirectories in the cgi-bin directory...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th November 2005, 21:29
IntnsRed IntnsRed is offline
Member
 
Join Date: Nov 2005
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Default

thevinster, did you figure this one out?

This is one of my next tasks. After looking at it, I'm guessing that going into my domain's cgi-bin and then doing a ln -s ../../../../usr/lib/cgi-bin/mailman/ mailman to create a symlink to the default cgi-bin would do the trick. But I won't be able to test this theory until my DNS changes over.

I'd love to hear if/how anyone else has solved this issue.
________
Vaporizer Store

Last edited by IntnsRed; 4th March 2011 at 04:01.
Reply With Quote
  #4  
Old 16th November 2005, 20:49
IntnsRed IntnsRed is offline
Member
 
Join Date: Nov 2005
Posts: 49
Thanks: 1
Thanked 1 Time in 1 Post
Thumbs up MailMan setup on Debian

I only set this up for one domain under my ISPConfig, so you'll likely have to modify this to implement MailMan for all of your hosted domains.

Here's the rub with Debian. Debian's developer installs MailMan into /usr/lib/cgi-bin. Due to ISPConfig's virtual domain configuration, ISPConfig-created domains do not "see" Debian's main cgi-bin subdirectory.

What I did was to simply edit /etc/apache2/vhosts/Vhosts_ispconfig.conf (note I'm using Apache2) and make this change:

#ScriptAlias /cgi-bin/ /home/www/web1/cgi-bin/
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/

and then restarted Apache. Note: this "breaks" the default ISPConfig cgi-bin for this domain.

Myself, I like using the command-line "newlist" command to create a mailing list. So I created a new mailing list, and added the list's aliases to /etc/aliases like the script tells you to. I then, of course, ran "newaliases".

From that point, I can access MailMan "normally", e.g. http://mydomain.org/cgi-bin/mailman/listinfo/, http://mydomain.org/cgi-bin/mailman/listinfo/ListName or whatever URL.

There is no doubt that this is a crude fix. I don't use MailMan much, so it's a low priority hack just to get it working.

If you do actually put some effort into getting this working in a more integrated or comprehensive fashion, please let us all know...
Reply With Quote
  #5  
Old 17th November 2005, 01:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by IntnsRed
What I did was to simply edit /etc/apache2/vhosts/Vhosts_ispconfig.conf (note I'm using Apache2) and make this change:

#ScriptAlias /cgi-bin/ /home/www/web1/cgi-bin/
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
Your changes will be overwritten the next time you create/edit/delete a web site in ISPConfig because ISPConfig will completely rewrite Vhosts_ispconfig.conf!
It is better to disable CGIs for that web site in ISPConfig and to put the
Code:
ScriptAlias  /cgi-bin/ /usr/lib/cgi-bin/
line into the Apache Directives field.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 18th January 2006, 21:38
kuyaedz kuyaedz is offline
Junior Member
 
Join Date: Nov 2005
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via ICQ to kuyaedz
Default

I've been struggling with this as well. Can someone tell me how I can installing mailman for just ONE of my virtual hosts? I've installed the .deb package mailman but I can't seem to figure how to include mailman/ in my /cgi-bin/.

Appreciate any tips. I'm really stumped on this one. (You'd think such a largely used app would have clearer docs!)
Reply With Quote
  #7  
Old 19th January 2006, 07:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
 
Default

I think you shouldn't use Debian's Mailman package as it is installed in a standard location, but not in the web site you want. You should try the sources from the Mailman web site.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.