Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th October 2006, 16:00
roolet roolet is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Upgrading Dapper to Edgy with aptitude dist-upgrade

I'm following the instructions on ubuntuguide.org for upgrading my Dapper Server to an Edgy Server. (There were no guides here, so I had to take the next best route!) I'd initially followed the "Perfect Install" walkthrough on here for getting Dapper set up. I took the advice at ubuntuguide.org for upgrading to Edgy - changed the sources and used aptitude dist-upgrade.

It seems to be upgrading everything, not just the OS. So far it's asked me lots of questions about keeping my old conf files or replacing them with the new ones. I had questions about this on proftpd, mime and mysql server. Probably at least one more that I'm forgetting now.

The other issue is with configuring courier. It keeps hanging on upgrading courier.

Should I be concerned with either of these issues and if so, what steps will I need to take? Also, should I anticipate any problems with ISPConfig once it's done? (I'm not too worried about courier. So far I've been able to send mail out but I've not been able to configure my MX pointers correctly through Dyndns to get my incoming mailserver accepting anything. Courier is the least of my problems -- this is a locally hosted testing server only.)

Bear in mind, I just set up the Dapper server a few weeks back, so I've barely broken it in and have never had to restart it.

EDIT post upgrade: OK, nearly everything came out alright by always choosing "no" if it asked me about replacing config files. However, at the very end, it spat out the following:

Code:
Errors were encountered while processing:
 courier-authlib-userdb
 courier-base
 courier-authdaemon
 courier-imap
 courier-ssl
 courier-pop
 courier-pop-ssl
 courier-imap-ssl
Suggestions as to what to do about this?

Last edited by roolet; 29th October 2006 at 16:23.
Reply With Quote
Sponsored Links
  #2  
Old 29th October 2006, 17:29
sbovisjb1 sbovisjb1 is offline
Senior Member
 
Join Date: Feb 2006
Posts: 176
Thanks: 0
Thanked 1 Time in 1 Post
Default

Which method did you use? I hope you are aware that sysvinit is no longer in use and upstart is now the method of choice. Also dont forget that you have to configure your X-server with
Code:
 
sudo dpkg-reconfigure xserver-xorg
If you didn't do that or it didn't work, try this

Code:
 
gksu “update-manager -c -d”
The package manager checks for both beta versions as edgy is still listed as such. That should fix any problems you have. Don't forget to update any necessary packages that you may need. The main problem most likely is the x server problem.

References: http://digg.com/linux_unix/Ubuntu_Ed...aster_for_Many
http://www.howtogeek.com/howto/ubunt...pdate-manager/
Reply With Quote
  #3  
Old 29th October 2006, 17:43
roolet roolet is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Whoa, fun, it's like learning a foreign language all over again. My accent was always better than my vocabulary. :P

I used Method B. bash didn't recognize gksudo or gedit.

I have no idea what sysvinit or upstart is. xserver-xorg is not installed. All I had on the box is what Falko included in the Dapper server config. The only things I did from ubuntuguide are in this section.

All told I think it went reasonably well using aptitude dist-upgrade, except for the courier issues, which weren't working all that well to begin with.

It should be noted that I'm not using the desktop version. I've got no GUI to work with here.

Last edited by roolet; 29th October 2006 at 17:46.
Reply With Quote
  #4  
Old 30th October 2006, 13:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by roolet
EDIT post upgrade: OK, nearly everything came out alright by always choosing "no" if it asked me about replacing config files. However, at the very end, it spat out the following:

Code:
Errors were encountered while processing:
 courier-authlib-userdb
 courier-base
 courier-authdaemon
 courier-imap
 courier-ssl
 courier-pop
 courier-pop-ssl
 courier-imap-ssl
Suggestions as to what to do about this?
Are there any errors related to this in your mail log? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th October 2006, 16:54
roolet roolet is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Output of netstat -tap:

Code:
(No info could be read for "-p": geteuid()=1000 but you should be root.)
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN     -
tcp        0      0 *:81                    *:*                     LISTEN     -
tcp        0      0 192.168.1.100:domain    *:*                     LISTEN     -
tcp        0      0 localhost.locald:domain *:*                     LISTEN     -
tcp        0      0 *:smtp                  *:*                     LISTEN     -
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     -
tcp        0      0 192.168.1.100:4695      adsl-(host-mask):mysql ESTABLISHED-
tcp        0      0 192.168.1.100:4693      adsl-(host-mask):mysql ESTABLISHED-
tcp        0      0 localhost.localdom:1857 localhost.localdoma:www TIME_WAIT  -
tcp        0      0 192.168.1.100:mysql     adsl-(host-mask):1256 ESTABLISHED-
tcp        0      0 localhost.localdom:2668 localhost.localdoma:ftp TIME_WAIT  -
tcp6       0      0 *:www                   *:*                     LISTEN     -
tcp6       0      0 *:ftp                   *:*                     LISTEN     -
tcp6       0      0 *:ssh                   *:*                     LISTEN     -
tcp6       0      0 *:smtp                  *:*                     LISTEN     -
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     -
tcp6       0      0 *:https                 *:*                     LISTEN     -
tcp6       0    148 ::ffff:192.168.1.10:ssh ::ffff:192.:unix-status ESTABLISHED-
Mail error log:
Code:
Oct 15 15:18:28 (servername) imaplogin: DISCONNECTED, ip=[::ffff:209.132.114.210], time=0
Mail log:
Code:
Oct 29 23:59:25 (servername) postfix/master[16470]: daemon started -- version 2.3.3, configuration /etc/postfix
Oct 30 06:55:44 (servername)  postfix/smtpd[23565]: connect from 59-117-202-247.dynamic.hinet.net[59.117.202.247]
Oct 30 06:55:46 (servername)  postfix/smtpd[23565]: NOQUEUE: reject: RCPT from 59-117-202-247.dynamic.hinet.net[59.117.202.$
Oct 30 06:55:46 (servername)  postfix/smtpd[23565]: lost connection after RCPT from 59-117-202-247.dynamic.hinet.net[59.117$
Oct 30 06:55:46 (servername)  postfix/smtpd[23565]: disconnect from 59-117-202-247.dynamic.hinet.net[59.117.202.247]
Oct 30 06:59:06 (servername)  postfix/anvil[23570]: statistics: max connection rate 1/60s for (smtp:59.117.202.247) at Oct $
Oct 30 06:59:06 (servername) postfix/anvil[23570]: statistics: max connection count 1 for (smtp:59.117.202.247) at Oct 30 $
Oct 30 06:59:06 (servername)  postfix/anvil[23570]: statistics: max cache size 1 at Oct 30 06:55:44
Oct 30 07:17:48 (servername)  postfix/smtpd[23855]: connect from 218-167-64-29.dynamic.hinet.net[218.167.64.29]
Oct 30 07:17:49 (servername)  postfix/smtpd[23855]: NOQUEUE: reject: RCPT from 218-167-64-29.dynamic.hinet.net[218.167.64.2$
Oct 30 07:17:50 (servername)  postfix/smtpd[23855]: lost connection after RCPT from 218-167-64-29.dynamic.hinet.net[218.167$
Oct 30 07:17:50 (servername) postfix/smtpd[23855]: disconnect from 218-167-64-29.dynamic.hinet.net[218.167.64.29]
Oct 30 07:21:10 (servername)  postfix/anvil[23857]: statistics: max connection rate 1/60s for (smtp:218.167.64.29) at Oct 3$
Oct 30 07:21:10 (servername)  postfix/anvil[23857]: statistics: max connection count 1 for (smtp:218.167.64.29) at Oct 30 0$
Oct 30 07:21:10 (servername)  postfix/anvil[23857]: statistics: max cache size 1 at Oct 30 07:17:48
Oct 30 09:10:37 (servername)  postfix/smtpd[25605]: connect from localhost[127.0.0.1]
Oct 30 09:10:37 (servername)  postfix/smtpd[25605]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 30 09:10:37 (servername)  postfix/smtpd[25605]: disconnect from localhost[127.0.0.1]
Also of note: prior to the upgrade I had been able to log in to webmail through ISPConfig and send mails out. Now I cannot do so, am getting the following errors:
Code:
 Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:110 (Connection refused) in /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php on line 66

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/class.uebimiau_mail.php:66) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 64
Reply With Quote
  #6  
Old 30th October 2006, 19:43
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 9 Times in 8 Posts
Default

many a problems upgrading from Dapper to Edgy, from hardware to software issues. I would do my research before dist-upgrade. maybe too late?
Reply With Quote
  #7  
Old 31st October 2006, 17:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What happens when you try to restart Courier?
Code:
/etc/init.d/courier-pop restart
/etc/init.d/courier-imap restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 1st November 2006, 05:50
roolet roolet is offline
Junior Member
 
Join Date: Oct 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually, I did a full restart, which brought courier back up, but it's still not accepting mail.

Current netstat -tap is now:

Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN     3
787/mysqld
tcp        0      0 *:81                    *:*                     LISTEN     4
145/ispconfig_http
tcp        0      0 192.168.1.100:domain    *:*                     LISTEN     4
394/named
tcp        0      0 localhost.locald:domain *:*                     LISTEN     4
394/named
tcp        0      0 *:smtp                  *:*                     LISTEN     1
5184/master
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     4
394/named
tcp6       0      0 *:imaps                 *:*                     LISTEN     3
653/couriertcpd
tcp6       0      0 *:pop3s                 *:*                     LISTEN     3
688/couriertcpd
tcp6       0      0 *:pop3                  *:*                     LISTEN     3
668/couriertcpd
tcp6       0      0 *:imap2                 *:*                     LISTEN     3
633/couriertcpd
tcp6       0      0 *:www                   *:*                     LISTEN     4
252/apache2
tcp6       0      0 *:ftp                   *:*                     LISTEN     1
5088/proftpd: (acc
tcp6       0      0 *:ssh                   *:*                     LISTEN     3
970/sshd
tcp6       0      0 *:smtp                  *:*                     LISTEN     1
5184/master
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     4
394/named
tcp6       0      0 *:https                 *:*                     LISTEN     4
252/apache2
tcp6       0    148 ::ffff:192.168.1.10:ssh ::ffff:192.168.1.2:1344 ESTABLISHED3
2458/sshd: (username)
New Mail log:

Code:
Oct 31 03:37:05 (servername) postfix/smtpd[18038]: NOQUEUE: reject: RCPT from 61-216-80-74.dynamic.hinet.net[61.216.80$
Oct 31 03:37:06 (servername) postfix/smtpd[18038]: lost connection after RCPT from 61-216-80-74.dynamic.hinet.net[61.2$
Oct 31 03:37:06 (servername) postfix/smtpd[18038]: disconnect from 61-216-80-74.dynamic.hinet.net[61.216.80.74]
Oct 31 03:40:26 (servername) postfix/anvil[18040]: statistics: max connection rate 1/60s for (smtp:61.216.80.74) at Oc$
Oct 31 03:40:26 (servername) postfix/anvil[18040]: statistics: max connection count 1 for (smtp:61.216.80.74) at Oct 3$
Oct 31 03:40:26 (servername) postfix/anvil[18040]: statistics: max cache size 1 at Oct 31 03:37:04
Oct 31 06:38:02 (servername) postfix/smtpd[20460]: connect from 220-139-249-179.dynamic.hinet.net[220.139.249.179]
Oct 31 06:38:03 (servername) postfix/smtpd[20460]: NOQUEUE: reject: RCPT from 220-139-249-179.dynamic.hinet.net[220.13$
Oct 31 06:38:03 (servername) postfix/smtpd[20460]: lost connection after RCPT from 220-139-249-179.dynamic.hinet.net[2$
Oct 31 06:38:03 (servername) postfix/smtpd[20460]: disconnect from 220-139-249-179.dynamic.hinet.net[220.139.249.179]
Oct 31 06:41:23 (servername)postfix/anvil[20462]: statistics: max connection rate 1/60s for (smtp:220.139.249.179) at$
Oct 31 06:41:23 (servername) postfix/anvil[20462]: statistics: max connection count 1 for (smtp:220.139.249.179) at Oc$
Oct 31 06:41:23 (servername) postfix/anvil[20462]: statistics: max cache size 1 at Oct 31 06:38:02
One thing that I did notice is that when I try to point the MX record to the server over at dyndns, it gets routed instead to the other box I've got here sharing the same IP.
Reply With Quote
  #9  
Old 2nd November 2006, 14:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

I don't see any lins for Courier in your mail log, only Postfix...

Can you restart Courier and post the error messages here, if there are any?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading failed, ispconfig broken and ispconfig won't upgrade again dfriis Installation/Configuration 7 14th June 2006 17:54


All times are GMT +2. The time now is 00:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.