Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2006, 08:36
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to disable sending mail from server

Hi...

Is it possible to disable sending mail from the server ?

I have no use of it, and have problems with spam-relay.

But i still need to be able to recive mail's to my users. But they use they ISP's SMTP to send mail.

I have a SUSE 10 perfect setup...


thanks for any help
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2006, 08:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Are you sure the spam is send by one of your users and not a form script?

If yes, you can try to change the variable smtpd_recipient_restrictions in your main.cf file to:

smtpd_recipient_restrictions = permit_mynetworks,check_relay_domains

This will allow email sending only from the network configured in the variable mynetworks. This is normally set to 127.0.0.0/8 which means sending is only allowed from localhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd November 2006, 10:04
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi.

Not. i'm not sure....

Now i have:

smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination,check_relay_domains

It's not spamming at the moment, but I will watch it.

I did try
http://www.howtoforge.com/forums/sho...hlight=postcat

But as i wrote it's not working ?
Reply With Quote
  #4  
Old 3rd November 2006, 14:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by nvn
I did try
http://www.howtoforge.com/forums/sho...hlight=postcat

But as i wrote it's not working ?
What exactly isn't working?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th November 2006, 18:28
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What exactly isn't working?
postcat -q /var/spool/postfix/maildrop/A672A6F41BF


Is it possible to set authentification for localhost ?
Reply With Quote
  #6  
Old 8th November 2006, 10:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
Default

Quote:
Originally Posted by nvn
Is it possible to set authentification for localhost ?
Yes. Comment out the mynetworks line in the main.cf and restart postfix. But I dont think that this is a good idea as this will affect all sytem emails and will most likely break your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 8th November 2006, 20:22
nvn nvn is offline
Member
 
Join Date: Apr 2006
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I don't have "mynetworks = " ?

Only a "mynetworks_style" ?
Reply With Quote
  #8  
Old 9th November 2006, 09:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,482 Times in 4,316 Posts
 
Default

Quote:
Originally Posted by nvn
I don't have "mynetworks = " ?

Only a "mynetworks_style" ?
Ok, then this might be your problem. Please add:

mynetworks = 127.0.0.0/8

to your main.cf file and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 10:07
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 20:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.