Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th October 2005, 15:11
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default FTP access problem...

#1
I have one domain setup under my admin account. I have another domain under another account. I have ftp setup the same (to the best of my knowledge) on both accounts. Under the second domain I can access the ftp files fine, but under the first, I can access the ftp site, but it is in the wrong directory. The directory should point to: /home/www/web1/web/, correct. It actually points to: /home/"username"/.

I have looked in the ISPConfig files, including Vhosts and everything seems to point to /home/www/web1/web/. Why is the ftp site not being directed properly? Would it have anything to do with my LAN setup?

Oh, also when I login to the ISP CP, under the admin account, it does direct me to the appropriate folder.

#2
The second issue may correlate to the first, so I am posting them together. I can access the ftp sites for either domain setup in ISP config from anywhere outside of my server. But when I open my browser on the server and type in the ftp url for either one, I get a "530 Login incorrect!" alert popup. It doesn't even allow me to enter a login. Does this mean that anon users are enabled? If so where else can I disable anon access? I though I did this already...
Reply With Quote
Sponsored Links
  #2  
Old 7th October 2005, 15:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by ctroyp
#1
I have one domain setup under my admin account. I have another domain under another account. I have ftp setup the same (to the best of my knowledge) on both accounts. Under the second domain I can access the ftp files fine, but under the first, I can access the ftp site, but it is in the wrong directory. The directory should point to: /home/www/web1/web/, correct. It actually points to: /home/"username"/.

I have looked in the ISPConfig files, including Vhosts and everything seems to point to /home/www/web1/web/. Why is the ftp site not being directed properly? Would it have anything to do with my LAN setup?
Make sure you're using the right ftp user for your first web site. To me it seems as if you had set up a usef manually on the shell with the homedir /home/user, and you're using this user for ftp.
You have to use a user that you set up with ISPConfig.

Quote:
Originally Posted by ctroyp
#2
The second issue may correlate to the first, so I am posting them together. I can access the ftp sites for either domain setup in ISP config from anywhere outside of my server. But when I open my browser on the server and type in the ftp url for either one, I get a "530 Login incorrect!" alert popup. It doesn't even allow me to enter a login. Does this mean that anon users are enabled? If so where else can I disable anon access? I though I did this already...
If anonymous ftp was enabled, then you wouldn't get the "Login incorrect" message.
Did you try this syntax in your browser?
ftp://<username>:<password>@<ftpserver>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th October 2005, 15:45
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko
Make sure you're using the right ftp user for your first web site. To me it seems as if you had set up a usef manually on the shell with the homedir /home/user, and you're using this user for ftp.
You have to use a user that you set up with ISPConfig.
I used your Perfect Setup for Fedora, but I did setup a user with the same username as the user setup in ISPConfig, after installing fedora but before installing ISPConfig. How can I fix this?

Quote:
If anonymous ftp was enabled, then you wouldn't get the "Login incorrect" message.
Did you try this syntax in your browser?
ftp://<username>:<password>@<ftpserver>
Strange, that actually took me to the right directory? But this is from outside my server...I will try the server later.
Reply With Quote
  #4  
Old 8th October 2005, 02:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
but I did setup a user with the same username as the user setup in ISPConfig
What do you mean with that? Do you mean you created a user manually on the shell, and later created the same user in ISPConfig?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th October 2005, 15:29
ctroyp ctroyp is offline
Senior Member
 
Join Date: Sep 2005
Posts: 292
Thanks: 3
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko
What do you mean with that? Do you mean you created a user manually on the shell, and later created the same user in ISPConfig?
Yes, correct...
Reply With Quote
  #6  
Old 8th October 2005, 15:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
I used your Perfect Setup for Fedora, but I did setup a user with the same username as the user setup in ISPConfig, after installing fedora but before installing ISPConfig. How can I fix this?
I'd simply comment out your manually created user in /etc/passwd and /etc/shadow.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th October 2005, 16:59
themachine themachine is offline
Senior Member
 
Join Date: Oct 2005
Location: Texas, USA
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Default Your not alone

I had the same thing happen. I manually setup a user, which was created as "UID 10012". Then ISPConfig created a user with the same UID... so I had duplicates in my /etc/passwd.

I simply just manually editted /etc/passwd with 'vi' to change my *manually* added user's UID/GUID's to 512. I then had to go to this user's home directory and chown the files to change the ownership UID:GUID to the new number.

# chown -R username:groupname /home/username_dir

The '-R' changes all files/folders recursively... so be aware that there are certain files that may be owned by root in the user's dir... like:

-rw-r--r-- 1 root root 544 Oct 11 08:33 .antivirus.rc
-rw-r--r-- 1 root root 742 Oct 11 08:33 .autoresponder.rc
-rw-r--r-- 1 root root 22 Oct 11 08:33 .bounce-exceed-quota.txt
-rw-r--r-- 1 root root 67K Oct 11 08:33 .html-trap.rc
-rw-r--r-- 1 root root 3.8K Oct 11 08:33 .local-rules.rc
-rw-r--r-- 1 root root 180 Oct 11 08:33 .mailsize.rc
-rw-r--r-- 1 root root 321 Oct 11 09:07 .procmailrc
-rw-r--r-- 1 root root 2.6K Oct 11 08:35 .quota.rc
-rw-r--r-- 1 root root 1.2K Oct 11 08:35 .spamassassin.rc
-rw-r--r-- 1 root root 1.6K Oct 11 08:33 .user_prefs
-rw-r--r-- 1 root root 0 Oct 11 08:33 .vacation.cache
-rw-r--r-- 1 root root 0 Oct 11 08:33 .vacation.msg

thanx.
Reply With Quote
  #8  
Old 12th October 2005, 17:07
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,388
Thanks: 833
Thanked 5,485 Times in 4,317 Posts
 
Default

To prevent duplicate user ID's, you can set the minimum userid ISPConfig strts with. The setting is in ISPConfig under Management > Server > Settings.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Web Issues - Access Forbidden! rytech Installation/Configuration 23 22nd June 2006 15:25
FTP very slow in LAN, "fast" from WAN-> Firewall problem? Pasco Server Operation 6 7th March 2006 15:17
FTP access? ctroyp Installation/Configuration 14 29th September 2005 17:26
Problem with webmail MyLinux General 10 17th September 2005 14:31
Installation problem: PHP problem? hgoor Installation/Configuration 7 21st August 2005 22:15


All times are GMT +2. The time now is 12:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.