#1  
Old 26th October 2006, 14:52
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default sasld authentication settings

Hi all,

Recenty upgraded server to Debian 3.1 (sarge) and ISP 2.2.7. I used the perfect setup walkthough but I opted out from installing the Courier-POP3/Courier-IMAP pgks.

The prob I am having is that I can't login to the uw-imapd2002edebian server mail using squirrelmail or roundcube. The error I am getting is...
Code:
The IMAP server is reporting that plain text logins are disabled.
I reviewed my setup and even tried to reinstall using the roundcube/sendmail walkthoughs but then I got an Internal Server Error when pointing to webmail.mydomain.com.

My mail.log says
Code:
Oct 26 08:48:14 xxx imapd[2592]: imap service init from 192.168.1.100
Oct 26 08:48:17 xxx imapd[2592]: Command stream end of file, while reading line user=xxx host=mydomain.com [192.168.1.100]
When I telnet to port 25 I get the right response too
Code:
ehlo show
250-mydomain.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
I don't know where to look next? Pls help.
Reply With Quote
Sponsored Links
  #2  
Old 26th October 2006, 17:46
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

OK.. when I try and TELNET to localhost imap I get this.

Notice it says LOGINDISABLED?

Code:
* OK [CAPABILITY IMAP4REV1 LOGIN-REFERRALS STARTTLS LOGINDISABLED] localhost.localdomain IMAP4rev1 2003.339 at Thu, 26 Oct 2006 11:41:54 -0400 (EDT)
Reply With Quote
  #3  
Old 26th October 2006, 18:13
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ok.. Im done...I give up. I have to get this email working..

If I don't get some kind of help, I guess I will revert to removinging the mail packages and reinstalling them manually without SSL.
Reply With Quote
  #4  
Old 26th October 2006, 18:56
jnsc jnsc is offline
rotaredoM
 
Join Date: Mar 2006
Location: Lausanne, Switzerland
Posts: 525
Thanks: 10
Thanked 172 Times in 77 Posts
Default

Do you have this file? /etc/c-client.cf

and does it contain:

I accept the risk
set disable-plaintext nil
Reply With Quote
  #5  
Old 26th October 2006, 19:13
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks for replying jnsc

Ok.. I have reinstall all the packages all over again (postfix imap-ssl etc)
I have rechecked all the perfect setup options.

And I noticed that SquirrelMail config has a imap Auth optins and changed it to PLAIN which was confusing to me cause I thought plain was plain text ???

SquirrelMail Config for IMAP Settings
Code:
IMAP Settings
--------------
4.  IMAP Server            : localhost
5.  IMAP Port              : 143
6.  Authentication type    : plain
7.  Secure IMAP (TLS)      : 0
8.  Server software        : uw
9.  Delimiter              : /

B.  Update SMTP Settings   : localhost:25
H.  Hide IMAP Server Settings

R   Return to Main Menu
C   Turn color off
S   Save data
Q   Quit

Command >> 6

If you have already set the hostname and port number, I can try to
detect the mechanisms your IMAP server supports.
I will try to detect CRAM-MD5 and DIGEST-MD5 support.  I can't test
for "login" or "plain" without knowing a username and password.
Auto-detecting is optional - you can safely say "n" here.

Try to detect supported mechanisms? [y/N]:

What authentication mechanism do you want to use for IMAP connections?

login - Plaintext. If you can do better, you probably should.
plain - SASL PLAIN. If you need this, you already know it.
cram-md5 - Slightly better than plaintext methods.
digest-md5 - Privacy protection - better than cram-md5.

*** YOUR IMAP SERVER MUST SUPPORT THE MECHANISM YOU CHOOSE HERE ***
If you don't understand or are unsure, you probably want "login"

login, plain, cram-md5, or digest-md5 [plain]: plain
Now I can try and login but Squirrelmail keeps saying I have wrong username or password. Yet, I have set up the username.

I am checking /etc/postfix/aliases now.
Reply With Quote
  #6  
Old 26th October 2006, 19:20
DaddyFix DaddyFix is offline
Member
 
Join Date: Jan 2006
Location: Canada
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yikes... no aliases in /etc/postfix? I just moved from mandriva to debian. Ohuh what did I do?

I would prefer not to use Courier-IMAP/Courier-POP3 cause I am used to UW-imap.

So basically, I'm lost again. I don't know why I can't login. Hmmm.
Reply With Quote
  #7  
Old 27th October 2006, 15:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by DaddyFix
Yikes... no aliases in /etc/postfix? I just moved from mandriva to debian. Ohuh what did I do?
It's /etc/aliases.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix: smtpd --> SASL LOGIN authentication failed tom General 25 2nd February 2010 17:43
smtpd, SASL authentication failure: Steve_P Installation/Configuration 4 6th February 2009 16:26
::Roundcube Settings Now Save:: cctex10 Installation/Configuration 1 15th June 2006 14:26
Can't access System config / Settings section Spektro Installation/Configuration 1 9th December 2005 15:31
Server Settings won't save Critical Installation/Configuration 6 21st October 2005 23:26


All times are GMT +2. The time now is 16:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.