Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th August 2005, 04:07
paulbrown83 paulbrown83 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix install on Mandrake/Mandriva

This is my first time ever trying to build a web server. I love the straightforwardness of these "Perfect Setups." I am installing the Mandrake "perfect setup" and I'm on the Postfix With SMTP-AUTH And TLS section. I have made it to the last part, at this command:

telnet localhost 25

When I type this, it gives me the following:

Trying 127.0.0.1...
Connected to server1.MYDOMAINNAMEHERE.com (127.00.1).
Escape character is '^]'.

And that's it. I'm assuming that is correct, so then I type:

ehlo localhost

and press Enter. Nothing happens at all. And I also don't know how to escape from this telnet session either. Does anyone have any suggestions for me. Thanks
Reply With Quote
Sponsored Links
  #2  
Old 20th August 2005, 15:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

It should look like this:

Code:
telnet localhost 25
Trying ::1...
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 server1.example.com ESMTP Postfix
So you're missing the 220 line. When that line appears, you type
Code:
ehlo localhost
To escape from that shell, you enter
Code:
quit
.

Can you post /etc/postfix/main.cf here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th August 2005, 17:56
paulbrown83 paulbrown83 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It does not give me the Trying ::1... line, unless it is just so fast that I don't see it.

Another difference is that mine says Connected to server1.domainname.com (127.0.0.1).

After the Escape character is '^]' line, the next line is blank, and my cursor just blinks. If I type anything and press enter, it just goes to the next line and blinks some more.

I have a feeling if I get those differences worked out, then the 220 line will appear, and then I'll be able to type ehlo localhost and continue from there.

You said you would like me to post main.cf? How can I get that file off of the linux box and onto another computer, so that I won't have to manually type it over on another computer?
Reply With Quote
  #4  
Old 20th August 2005, 20:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by paulbrown83
You said you would like me to post main.cf? How can I get that file off of the linux box and onto another computer, so that I won't have to manually type it over on another computer?
If you use Windows then you can use WinSCP (http://winscp.net/eng/index.php).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th August 2005, 23:33
paulbrown83 paulbrown83 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK, here is my main.cf file (I didn't take the time to figure out how to put the cool blue outlined box around it):



# These are only the parameters changed from a default install
# see /etc/postfix/main.cf.dist for a commented, fuller version of this file.

# These are changed by postfix install script
readme_directory = /usr/share/doc/postfix-2.1.5/README_FILES
sample_directory = /usr/share/doc/postfix-2.1.5/samples
html_directory = /usr/share/doc/postfix-2.1.5/html
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
command_directory = /usr/sbin
manpage_directory = /usr/share/man
daemon_directory = /usr/lib/postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
queue_directory = /var/spool/postfix
mail_owner = postfix

# User configurable parameters

inet_interfaces = all
mynetworks_style = host
delay_warning_time = 4h
smtpd_banner = $myhostname ESMTP $mail_name ($mail_version) (Mandrakelinux)
unknown_local_recipient_reject_code = 450
smtp-filter_destination_concurrency_limit = 2
lmtp-filter_destination_concurrency_limit = 2
smtpd_sasl_path = /etc/postfix/sasl:/usr/lib/sasl2
recipient_delimiter = +
owner_request_special = no
alias_maps = hash:/etc/postfix/aliases, hash:/var/lib/mailman/data/aliases
smtpd_sasl_local_domain =
smtpd-sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
mydomain = writerspider.com
myhostname = server1.$mydomain
mydestination = /etc/postfix/local-host-names,localhost.writerspider.com
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_sasl_auth_enable = yes
Reply With Quote
  #6  
Old 21st August 2005, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I can't find myhostname in your main.cf.
Can you run
Code:
postconf -e 'myhostname = server1.example.com'
(replace server1.example.com with your hostname) and restart Postfix:
Code:
/etc/init.d/postfix restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 21st August 2005, 21:00
paulbrown83 paulbrown83 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah, it's about two thirds of the way down the user configurable section:


mydomain = writerspider.com
myhostname = server1.$mydomain

Should I replace $mydomain with the actual value of mydomain, instead of the variable reference?
Reply With Quote
  #8  
Old 21st August 2005, 21:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by paulbrown83
mydomain = writerspider.com
myhostname = server1.$mydomain

Should I replace $mydomain with the actual value of mydomain, instead of the variable reference?
Sorry, I've overseen that. It's ok like that.

Can you run
Code:
postconf -e 'smtpd_sasl_local_domain = $myhostname'
and restart Postfix?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 21st August 2005, 21:47
paulbrown83 paulbrown83 is offline
Junior Member
 
Join Date: Aug 2005
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yep, it stops and starts just fine. Now what should I type? I'm assuming this:

telnet localhost 25
Reply With Quote
  #10  
Old 21st August 2005, 23:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by paulbrown83
Yep, it stops and starts just fine. Now what should I type? I'm assuming this:

telnet localhost 25
Yes, try this again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Header Checks dirk Installation/Configuration 8 30th May 2010 13:38
Where to Install latcarf Installation/Configuration 31 17th August 2005 10:46
Error trying to install - on RH9 bgarlock Installation/Configuration 7 17th August 2005 10:43
Install stopped at: create clamav.tar.gz domino Installation/Configuration 2 16th August 2005 06:36
Fresh Install of FC4 using Perfect Install HowTo latcarf HOWTO-Related Questions 21 10th August 2005 22:55


All times are GMT +2. The time now is 03:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.