Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th November 2005, 16:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,676
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

The ISPConfig installer creates a database itself. Dont create the database manually! If the database exists, the installer will fail.
Reply With Quote
Sponsored Links
  #12  
Old 17th November 2005, 17:53
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ah, that fixed that problem ... after installing it to wards the end it says

'no such file in: /etc/apache2/vhost.d/*.conf'

and when i create sites and try them in my browser they dnt work ...
Reply With Quote
  #13  
Old 17th November 2005, 17:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,676
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

Did you get an error when you execute:

httpd -t
Reply With Quote
  #14  
Old 17th November 2005, 18:01
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

nope ... i got sytax ok ...

*sigh*

looks like im gonna have to re-install it ... again ....
Reply With Quote
  #15  
Old 17th November 2005, 18:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,676
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

No... We have a few more options to figure out whats wrong

Please have a look in the ISPConfig logfile:

/home/admispconfig/ispconfig/ispconfig.log

any errors?
Reply With Quote
  #16  
Old 17th November 2005, 18:19
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok ..

There seems to be alot of info in there so i took the last WARN msg which says there is an error in the sytax of httpd ...

11.2005 - 17:14:07 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2337: WARNING: could not httpd -t &> /dev/null
17.11.2005 - 17:14:07 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2343: httpd syntax seems to contain errors, reloading with old configuration

if u have vnc u can login and help fix if that would be easier ... just pm me

Last edited by zer0_g666; 17th November 2005 at 18:26.
Reply With Quote
  #17  
Old 17th November 2005, 18:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by zer0_g666
Ah, that fixed that problem ... after installing it to wards the end it says

'no such file in: /etc/apache2/vhost.d/*.conf'
Don't worry about that warning. Nothing serious.

Quote:
17.11.2005 - 17:14:07 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2343: httpd syntax seems to contain errors, reloading with old configuration
That means that ISPConfig tried to write a new vhost configuration, but your Apache doesn't support all the features of that new web site (e.g. PHP, CGI, ...), maybe because some modules are missing. ISPConfig detects that and reverts the configuration back to the last working state so that your Apache can start. But this explains why you cannot see any of the sites you created in ISPConfig.
Make sure Apache loads all the needed modules.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 17th November 2005, 22:30
zer0_g666 zer0_g666 is offline
Member
 
Join Date: Nov 2005
Location: Newcastle, Northeast England
Posts: 60
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Amazing, its working!!! yey ....

I installed a few apache2-mod's and bingo

Thankyou
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 16:37
Mysql Problem Adding adamluz General 2 20th September 2005 09:33
MySQL issue during install of ISPConfig ricbax Installation/Configuration 4 16th September 2005 09:41
Mysql ejs Installation/Configuration 5 12th August 2005 07:01
MySQL Privileges mcfly Server Operation 4 26th May 2005 19:00


All times are GMT +2. The time now is 20:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.