#1  
Old 18th October 2006, 17:30
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default Mailgraph and CGi-bin

So i have followed everything on this tutorial

http://www.howtoforge.com/mail_stati...raph_pflogsumm
But when i got to https://example.com/cgi-bin/mailgraph.cgi
I get the text that i in that file and it is not running that file.

How do i enable cgi on debian apache2?
Reply With Quote
Sponsored Links
  #2  
Old 18th October 2006, 18:22
nsurge nsurge is offline
Junior Member
 
Join Date: Sep 2006
Posts: 20
Thanks: 0
Thanked 2 Times in 1 Post
Default

Did you make the cgi script executable?
Reply With Quote
  #3  
Old 18th October 2006, 18:37
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yes I did when i copied it over have it excutable.
Reply With Quote
  #4  
Old 18th October 2006, 18:40
nsurge nsurge is offline
Junior Member
 
Join Date: Sep 2006
Posts: 20
Thanks: 0
Thanked 2 Times in 1 Post
Default

What are the permissions on the file currently?
Reply With Quote
  #5  
Old 18th October 2006, 20:26
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

owner is: www-root
permitions 755

But it still comes up with the text

Do i not have to activate or install cgi? and if so how?
Reply With Quote
  #6  
Old 19th October 2006, 13:30
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

Maby i should ask how do i activate cgi on apache2?
Reply With Quote
  #7  
Old 19th October 2006, 16:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Which distribution do you use? Can you post your vhost configuration here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 19th October 2006, 16:17
namit namit is offline
Member
 
Join Date: Jan 2006
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Default

Debian

<VirtualHost *>
ServerName mywebsite.org
DocumentRoot /home/namit/public_html/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

LogLevel warn
</VirtualHost>
Reply With Quote
  #9  
Old 20th October 2006, 16:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by namit
Debian

<VirtualHost *>
ServerName mywebsite.org
DocumentRoot /home/namit/public_html/
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

LogLevel warn
</VirtualHost>
Try

Code:
<VirtualHost *>
         ServerName mywebsite.org
        DocumentRoot /home/namit/public_html/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>

        LogLevel warn
<Directory /home/namit/cgi_bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
</Directory>

ScriptAlias  /cgi-bin/ /home/namit/cgi_bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
</VirtualHost>
Of course, you must create /home/namit/cgi_bin before. Restart Apache, and put your CGI scripts into /home/namit/cgi_bin.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.