Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 7th October 2005, 12:00
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Have you installed mod_php in your webserver and enabled it?
Okay. I just install mod_php using comand #apt-get install mod_php. So how to enable it?
Reply With Quote
Sponsored Links
  #22  
Old 7th October 2005, 12:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

It should be enabled automatically. I dont think the apt package is named exactly mod_php. Better you search with apt-cache search php.

In Debian 3.0 the package for php4 and apache 1.3 is named: libapache-mod-php4
and for apache 2: libapache2-mod-php4
Reply With Quote
  #23  
Old 7th October 2005, 14:44
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
It should be enabled automatically. I dont think the apt package is named exactly mod_php. Better you search with apt-cache search php.

In Debian 3.0 the package for php4 and apache 1.3 is named: libapache-mod-php4
and for apache 2: libapache2-mod-php4
Yes, I have instaled apache2-mod_php5.
Reply With Quote
  #24  
Old 7th October 2005, 15:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You might have to create symlinks from the directory /etc/apache2/mods-enabled to the php.conf and php.load files in /etc/apache2/mods-available (the symlinks must have the same names as the original files) and restart Apache.
An example on how to do this is on this page: http://www.howtoforge.com/perfect_setup_debian_sarge_p5
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 9th October 2005, 15:54
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
You might have to create symlinks from the directory /etc/apache2/mods-enabled to the php.conf and php.load files in /etc/apache2/mods-available (the symlinks must have the same names as the original files) and restart Apache.
An example on how to do this is on this page: http://www.howtoforge.com/perfect_setup_debian_sarge_p5
Hi! I have another problem with email:
why my user for instance user@<mydomain.ltd> can`t send mail using my SMTP server to another user (not to mydomain user)? This my user is not physically in my network. It he is, than everything works fine. He receives error like this:

The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'auser@<NO_mydomain.ltd>'. Subject 'Test message', Account: '<myhostname>.<mydomain.ltd>', Server: '<myhostname>.<mydomain.ltd>', Protocol: SMTP, Server Response: '554 <auser@<NO_mydomain.ltd>>: Recipient address rejected: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79
Reply With Quote
  #26  
Old 9th October 2005, 16:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

You have to enable SMTP_Auth in the email client. In most Email clients this feature is named like "SMTP server requires authentication".
Reply With Quote
  #27  
Old 9th October 2005, 17:55
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
You have to enable SMTP_Auth in the email client. In most Email clients this feature is named like "SMTP server requires authentication".
Can I disable this feature?
Reply With Quote
  #28  
Old 9th October 2005, 18:02
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,814
Thanks: 821
Thanked 5,340 Times in 4,189 Posts
Default

If your server is connected to the internet and you disable SMTP_Auth your server will be an open Relay and will be banned by other mailservers.

If your Server is in a private network, you can change mynetworks = 127.0.0.0/8 in the main.cf to a netmask that allows your complete internal network to relay mails through this server.
Reply With Quote
  #29  
Old 9th October 2005, 18:51
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
If your server is connected to the internet and you disable SMTP_Auth your server will be an open Relay and will be banned by other mailservers.

If your Server is in a private network, you can change mynetworks = 127.0.0.0/8 in the main.cf to a netmask that allows your complete internal network to relay mails through this server.
My mail server is connected to the internet.I need, that my user with adress user@<mydomain.ltd> can send e-mails using my smtp server <myhostname>.<mydomain.ltd> without being in my network and witout any autentification like other mail server users can.
Reply With Quote
  #30  
Old 9th October 2005, 21:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by intars
My mail server is connected to the internet.I need, that my user with adress user@<mydomain.ltd> can send e-mails using my smtp server <myhostname>.<mydomain.ltd> without being in my network and witout any autentification like other mail server users can.
But then it would be an open relay...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help forward root email to me domino Technical 10 2nd May 2006 15:01
apache user/group won't create directory weedguy Installation/Configuration 6 19th September 2005 23:40
Can't set up email account Art Garfunkle General 2 3rd September 2005 16:22
email client configuration davidg General 3 22nd August 2005 16:40
Install stopped at: create clamav.tar.gz domino Installation/Configuration 2 16th August 2005 06:36


All times are GMT +2. The time now is 07:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.