Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 4th October 2005, 10:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by intars
suse:~ # telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Hello there.
user intars
+OK Password required.
pass xxxx
-ERR Maildir: No such file or directory
Connection closed by foreign host.

User <intars> I create in installation process.
Ok, you're using Maildir. The Maildir is created upon the first email that arrives at that account, therefore send a test email to that account, then the error message will disappear.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 4th October 2005, 12:32
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Ok, you're using Maildir. The Maildir is created upon the first email that arrives at that account, therefore send a test email to that account, then the error message will disappear.
Okay, after #postconf -n I found wrong mydomain, - <myhostname>.<mydomain.ltd>.
How can I change this to mydomain = <mydomain.ltd>?
Reply With Quote
  #13  
Old 4th October 2005, 12:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by intars
Okay, after #postconf -n I found wrong mydomain, - <myhostname>.<mydomain.ltd>.
How can I change this to mydomain = <mydomain.ltd>?
By running
Code:
postconf -e 'mydomain = <mydomain.ltd>'
or editing /etc/postfix/main.cf manually. Restart Postfix afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 4th October 2005, 17:05
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
By running
Code:
postconf -e 'mydomain = <mydomain.ltd>'
or editing /etc/postfix/main.cf manually. Restart Postfix afterwards.
Without success

suse:~ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 <hostname>.<mydomain.ltd> ESMTP Postfix
mail from: xxx@xxx.xx
250 Ok
rcpt to: yyy@<mydomain.ltd>
250 Ok
data
354 End data with <CR><LF>.<CR><LF>
Test
.
250 Ok: queued as 551E21A7F8
quit
221 Bye
Connection closed by foreign host.
suse:~ # telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
+OK Hello there.
user yyy
+OK Password required.
pass lalala
-ERR Maildir: No such file or directory
Connection closed by foreign host.

suse:~ # postconf -n
alias_maps = hash:/etc/aliases
biff = no
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
home_mailbox = Maildir/
html_directory = /usr/share/doc/packages/postfix/html
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command =
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 10240000
mydestination = $myhostname, localhost.$mydomain
mydomain = <mydomain.ltd>
myhostname = suse.$mydomain
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550

Here all is ok?
Reply With Quote
  #15  
Old 4th October 2005, 19:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

If you're sending emails to yyy@mydomain.ltd you have to make sure that mydomain.tld is in mydestination. Currently it isn't!
Then you must have a system user yyy.

If yyy is just an alias, not a system user, you have to run:
Code:
postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
Then create /etc/postfix/virtusertable with the following contents:
Code:
yyy@mydomain.ltd    system_user_that_should_get_the_email
Whenever you change /etc/postfix/virtusertable, you have to run
Code:
postmap /etc/postfix/virtusertable
Don't forget to restart Postfix after your changes.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 5th October 2005, 11:48
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
If you're sending emails to yyy@mydomain.ltd you have to make sure that mydomain.tld is in mydestination. Currently it isn't!
Then you must have a system user yyy.

If yyy is just an alias, not a system user, you have to run:
Code:
postconf -e 'virtual_maps = hash:/etc/postfix/virtusertable'
Then create /etc/postfix/virtusertable with the following contents:
Code:
yyy@mydomain.ltd    system_user_that_should_get_the_email
Whenever you change /etc/postfix/virtusertable, you have to run
Code:
postmap /etc/postfix/virtusertable
Don't forget to restart Postfix after your changes.

Now is O.K.!!! It working! Thank you!
But now I have another question about apache: why when I write in explorer http://www.<mydomain.ltd> I receive: Access forbidden! Error 403?
Reply With Quote
  #17  
Old 5th October 2005, 18:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Quote:
Originally Posted by intars
But now I have another question about apache: why when I write in explorer http://www.<mydomain.ltd> I receive: Access forbidden! Error 403?
Did you create an index file (e.g. index.html) in the directory that Apache tries to access? If not, do that.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 5th October 2005, 22:00
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Did you create an index file (e.g. index.html) in the directory that Apache tries to access? If not, do that.
Thank You!
Reply With Quote
  #19  
Old 7th October 2005, 11:39
intars intars is offline
Junior Member
 
Join Date: Sep 2005
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Did you create an index file (e.g. index.html) in the directory that Apache tries to access? If not, do that.
HI FALKO! I set up UebiMiau(POP3 mail reader) on my mail server(set up byThe Perfect Setup - SUSE 9.3), but when I try to open this mail page, I receive just index.php code! Why???
Reply With Quote
  #20  
Old 7th October 2005, 12:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
 
Default

Have you installed mod_php in your webserver and enabled it?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help forward root email to me domino Technical 10 2nd May 2006 16:01
apache user/group won't create directory weedguy Installation/Configuration 6 20th September 2005 00:40
Can't set up email account Art Garfunkle General 2 3rd September 2005 17:22
email client configuration davidg General 3 22nd August 2005 17:40
Install stopped at: create clamav.tar.gz domino Installation/Configuration 2 16th August 2005 07:36


All times are GMT +2. The time now is 09:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.